• Sign in to Neowin Faster!

    Create an account on Neowin to contribute and support the site.

Sign in to follow this  

[URGENT] ONKYO amplifier, display not working

Recommended Posts

booboo    6

Hey,

I have recently purchased a onkyo tx-sr505 and it has been really good up till now. There is a small problem with it now:

I turn it on, and set the input to the DVD, which recieves an input using optical from my laptop. It will output the sound as normal, but none of the lights are on the amp (pure audio) and the display will not turn on. If i click standby then it will show a red light.

Why is this, is there any easy fix, and is it something i pressed accidently?

Thanks

Share this post


Link to post
Share on other sites
goji    30

A. Did you purchase it from an authorized dealer?

B. If so call them up and talk to customer support.

Share this post


Link to post
Share on other sites
booboo    6

A. Yes

B. I'd rather not if there's an easier way to fix it?

Thanks

Share this post


Link to post
Share on other sites
goji    30

You'd rather wait for a non guaranteed response on here vs calling them up and getting an official response from the company?

ok..

Check with your use manual, corp website to see if there is any documentation on this phenomena.

Share this post


Link to post
Share on other sites
S.MULLA    8

try pressing the dimmer button on the remote- number 0 on the key pad on my TX-SR605. but if that doesnt work-then:

are you hooked up via hdmi to a screen? when u press the setup button-does it display onto ur screen? normally in this situation if nothing works- call up onkyo (where are u based?) and they will either send an engineer out to repair it or swap it over.

Share this post


Link to post
Share on other sites
booboo    6

The reason that I don't want to phone them up, and want a quick fix is because I am at school, and my phone is out of credit. So when I get home, and if all else fails me, then I will give them a ring :)

I will try the dimmer thing.................. Ok I tried it, but it didnt work, maybe i have to press a certain button before i click "o" (like Fn on laptops)?

And the HDMI thing, no I don't have a HD screen yet :(

Share this post


Link to post
Share on other sites
S.MULLA    8

bummer. to use the dimmer its just simple- just press it- the light on display changes through 3 different brightnesses. does it play audio when a device is attached? through any rear input? maybe try re wiring ur rear banana plug connections to speakers just incase +ve and -ve ends are touching ?

otherwise try www.avforums.com

Share this post


Link to post
Share on other sites
booboo    6

Well it does output sound but the display doesn't work.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.