There are many great features available to you once you register at Neowin, including:

  • Richer content, access to many features that are disabled for guests like commenting on the front page
  • Access to a great community, with a massive database of experience on hard & software issues, gaming and recreational activities, and more
  • Access to the Neowin IRC - you could make a friend from across the world and talk to them live
  • Access to Neowin contests & subscription offers and forums that are not open to guests/li>
  • It's simple, and FREE! · Register here

Disable Subs in MKV Files?


 Share

Recommended Posts

I am currently using Windows Media Player Classic with the K-Lite Codec Package. I have an MKV 1080p video that has subtitles. I want to disable these subtitles. How can I do this? Thanks in advanced for anyone who helps.

Link to comment
Share on other sites

Depends, are the subtitles coded into the movie or do you have an .srt file ( Subtitle file ) in the movie folder?

If It's coded into the movie, there's nothing you can do.

Do you have a subtitle file, just remove it from the folder ( or right click in the movie window, select Subtitles and then "Off/none" )

Link to comment
Share on other sites

I have no srt file :(. It's a separate MKV file. Nothing associated with it.. And the weirdest part is the Subtitles Option when right clicked is grayed out. I guess the it's all 1 layer :(.

Link to comment
Share on other sites

Yup in that case the subtitles are hardcoded into the video itself (called hardsubs by some.) You cannot remove them and your only option is to get another copy of the file that doesn't have them. :/

Link to comment
Share on other sites

I don't know of a way to disable subtitles but I know of a way to hide it. At the menu bar select Play, hover your cursor over Filter, then DirectVobSub (autoloading version), and select "Hide Subtitles". Unfortunately you're going to have to do this every time you play .mkv videos with subtitles.

Link to comment
Share on other sites

Open the file in MediaInfo (Google it, it's free, on Sourceforge) and open up the MKV in question, and see if it has a subtitle track in the MKV.

If it does, you are in luck. You can probably find a way to remove it with minimal effort (although I have never done it myself).

If it does not have a subtitle track, that means that it is exactly what Code.Red has already said.*

*also, make sure there are no SRT files, etc in the same directory, although that has already been mentioned.

This is an example of an MKV w/ 3 subtitle streams. [edit] I'm blind. Twelve (!) subtitle streams, while 3 viewable at the bottom.

picture1ov8.png

Link to comment
Share on other sites

Thanks gonna try those suggestions.

OMG. Thanks Anaron. It works now. No subtitles. I guess by default it is forced to show them. Thanks a lot once again.

Link to comment
Share on other sites

  • 1 year later...
  • 5 months later...
This topic is now closed to further replies.
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.