• Sign in to Neowin Faster!

    Create an account on Neowin to contribute and support the site.

Sign in to follow this  

Z-2300s and iMac

Recommended Posts

StevoJD    0

Currently I have some Z-2300s paired up with my iMac, I have a small complaint though. Whenever I turn up the volume past about 50% on the speakers, and 100% on the system sound, the sound starts to get distorted. What's causing this? Weak sound card? Or am I just playing the music too loud for my own good? Since I used to own a pair of X-530s before I had a Mac, and at full blast they sounded great, but not as loud of course.

Will I notice a difference if I get the Creative Xmod?

Share this post


Link to post
Share on other sites
auto-logic    1

You're probably clipping the input of the speakers... it happens on a lot of computers at 100%.

If you put system volume at 1/4 or 3/4, you should be able to crank the speakers up louder than if the system volume is at 100%.

Share this post


Link to post
Share on other sites
+StevoFC    21

Yeah, put the system volume at like 75-80% and see what happens.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.