• 0

[help] Portforwarding with the BT Home hub


Question

Harreh

So recently I've been having unbearable lag problems when playing WC3 tft on battle.net and I'm pretty sure that the problem is related to my ports not being forwarded.

I've put the entry in to the BT Home Hub and selected the correct target machine, but the ports just won't forward according to the uTorrent port checker. Plus I get the lag on battle.net. I've had the entry in ever since I started playing it and only now I start to experience problems.

I've been able to have ports open before but now it just won't work.

Also I can't really use uTorrent to download torrents since the port isn't open.

I get very good results on speed testers, so my internet isn't acting up or my brother killing it with downloads etc.

I'm also using the built in firewall to Vista, but I have WC3 and uTorrent allowed.

Any help would be greatly appreciated.

Link to post
Share on other sites

21 answers to this question

Recommended Posts

  • 0
+BudMan

do you any other device between you and the home hub, or between the home hub and the internet? ie another router/modem or voip device?

are you forwarding by IP or by some name listed in the BTHH? Verify that the IP of your machine is what the BTHH shows for your machine.

I would turn off any software firewalls on your machine, atleast for testing. But to be honest if your behind a nat router, unless you need to treat other machines on your local network as hostile, there is little need for a software firewall.

Link to post
Share on other sites
  • 0
Harreh

There is nothing between my PC and the home hub. I'm connecting directly to it wirelessly.

I'm forwarding by device name (Shaun is the device name for my PC here) and it has correctly identified my machine.

I'm going to try to see if I can open these ports to a different machine.

Link to post
Share on other sites
  • 0
+BudMan

Do you have a machine listed in the dmz? Some router will not forward any traffic if there is a IP in the DMZ, since all traffic is going there. Other routers will still forward specific ports to where you setup, and anything else not setup goes to the dmz.

Link to post
Share on other sites
  • 0
Harreh

There are no machines listed in the dmz.

I also disabled my software firewall and the problem still persists.

I tried opening ports to a different machine but again they don't open.

Link to post
Share on other sites
  • 0
+BudMan

Have you tried being wired to the router. Did you change your machine to a static, and your hub thinks its on a dhcp address? Not a big fan of the routers that list machines by name vs IP.. They can be wrong -- since they tend to pull those from the dhcp lease table.

Did your ISP put you behind a NAT? Double check your routers wan IP, is it a public IP?

Are you trying to use UPnP or a manual forward -- turn off UPnP. A simple way to check for a open port is using http://www.canyouseeme.org/ and turn on the telnet server on your machine, port 23 for a simple check.

edit: how exactly does the BTHH find the names of the computers? From its dhcp lease table? Broadcasting? Talking to the browser for the segment?

Link to post
Share on other sites
  • 0
Harreh

The other machine that I tried is wired and thing didn't work there. But I will try with this machine wired nonetheless.

I'm not sure if my ISP has put me behind a NAT. Not sure if BT does this.

I'm not sure if my router's IP is public or not, but I assume it is as any machine that can connect to it can find it out (ipconfig -> read: default gateway).

I just disabled UPnP, but I wasn't trying to use it anyway.

I just enabled telnet, used your link and checked port 23 and the results were: Connection timed out

I'm pretty sure that the BTHH uses a DHCP lease table.

In the status page for each device, it says "IP Address Assignment: DHCP" and displays the DHCP Lease time.

I think that I can specifically forward ports to a desired IP address but the last time I did that, I entered the IP and when I hit apply it just changed to the device's name. I'm pretty sure it isn't getting anything wrong here. It lists my computer's IP address as 192.168.1.107 and ipconfig tells me that my network IP is 192.168.1.107. It also lists the correct MAC address.

Link to post
Share on other sites
  • 0
+BudMan

Well if your IP is correct, then either the BTHH is not forwarding the traffic. Or your behind another NAT in front of the BTHH is never seeing the traffic. Can you look on the BTHH status page and see what IP it has on its internet interface.. if that IP 10.x.x.x or 192.168.x.x or 172.16-31.x.x your behind a NAT and your port forwards on your BTHH would never work, unless traffic was forwarded at the device in front of your BTHH.

Or you have something else blocking the traffic -- you have not installed any 3rd party type security software? Virus scanners can do a lot more than scan for viruses now -- many of them are software firewalls as well.

Have you tried power cycle on your BTHH? When you enabled telnet on your machine - you verified that it was listening on 23 with a netstat -an command, etc.

IPconfig default gateway would be the private side of your router, not the public side. You need to look on the routers web ui for some type of status page that shows its connection status and IP.

Link to post
Share on other sites
  • 0
Harreh

I don't have any 3rd party security software.

I have tried rebooting the BTHH but not a complete un-plug, I will try that now.

As for telnet, I'm a bit confused. Do you want me to try and start a telnet session? If so, with who?

Previously, I just turned it on (as per: Link)

Then entered port 23 in canyouseeme.org.

As for your comments in your first and last paragraph, I think that the following screenshots will help:

post-110879-1214314319.jpg

post-110879-1214314330.jpg

Link to post
Share on other sites
  • 0
+BudMan

You need to turn on the telnet SERVER, not the client. And you need to make sure it's listening -- and you setup the port foward, for it to show up on canyou see me.

C:\>net start telnet

The Telnet service is starting.

The Telnet service was started successfully.

C:\>netstat -an

Active Connections

Proto Local Address Foreign Address State

TCP 0.0.0.0:23 0.0.0.0:0 LISTENING

TCP 0.0.0.0:135 0.0.0.0:0 LISTENING

TCP 0.0.0.0:445 0.0.0.0:0 LISTENING

Now its not listening.

C:\>net stop telnet

The Telnet service is stopping.

The Telnet service was stopped successfully.

C:\>netstat -an

Active Connections

Proto Local Address Foreign Address State

TCP 0.0.0.0:135 0.0.0.0:0 LISTENING

TCP 0.0.0.0:445 0.0.0.0:0 LISTENING

Well 86.170 is clearly a public IP.

Link to post
Share on other sites
  • 0
Harreh

Forwarded port 23 to my machine and:

C:\>net start telnet

System error 1058 has occurred.

The service cannot be started, either because it is disabled or it has no enabled devices associated with it.

Link to post
Share on other sites
  • 0
JMann

Hi Harreh,

A few of my friends experience this issue as well, but I have only heard of it happening on BT Routers, surprise! :p It sounds like Budman has gone through a lot with you already but the following Article (if done correctly) has always worked on the occasions I have had to get Warcraft III working:

http://portforward.com/english/routers/por...arcraft_III.htm

It's from PortForward.com which I think of as a pretty reliable source when it comes to Routers, and basic setups/configs. If you follow those instructions if you haven't already that should get you up and running. (Also on another external site, it advises to powercycle (reboot) the Router (BT Home Hub) once the config is completed (Router's shouldn't need a reboot everytime something changes, but it's always best for the BT Router's apparently). :pinch:

I hope this helps, if not I am sure Budman will sort you out. :)

Link to post
Share on other sites
  • 0
+BudMan

Well if you were never able to start the telnet server -- then no canyousee me would never show it open, no matter what you did as far as portforwards.

Once you install the telnet service, you have to enable the service -- the article you linked seemed to forget that part ;)

This guide does not forget the enable the service part. ;)

http://www.mydigitallife.info/2007/08/20/i...-windows-vista/

In a nutshell

after you have installed the telnet server. You will not be able to start the service, since it is disabled - enable it to be able to start, auto or manual (demand) and then your good too go.

Example;

post-14624-1214335894.jpg

Link to post
Share on other sites
  • 0
Harreh
Hi Harreh,

A few of my friends experience this issue as well, but I have only heard of it happening on BT Routers, surprise! :p It sounds like Budman has gone through a lot with you already but the following Article (if done correctly) has always worked on the occasions I have had to get Warcraft III working:

http://portforward.com/english/routers/por...arcraft_III.htm

It's from PortForward.com which I think of as a pretty reliable source when it comes to Routers, and basic setups/configs. If you follow those instructions if you haven't already that should get you up and running. (Also on another external site, it advises to powercycle (reboot) the Router (BT Home Hub) once the config is completed (Router's shouldn't need a reboot everytime something changes, but it's always best for the BT Router's apparently). :pinch:

I hope this helps, if not I am sure Budman will sort you out. :)

Yeah, I went to that page before but I found out that I was doing exactly what those instructions mentioned. The powercycle thing sounds a bit strange.

BudMan: Yep, I got the telnet server running and I see the line you highlighted in your picture. Checked port 23 on canyouseeme.org and the results are "Success: Your ISP is not blocking port 23.". The uTorrent port checker also confirms that it is open.

I just played a game of WC3 (online) and it ran perfectly. What on Earth happened here? Has running the telnet server helped fix this problem and am I going to want to execute the "sc config tlntsvr start= demand" line?

BudMan, you truly are a networking guru.

Link to post
Share on other sites
  • 0
+BudMan

running the telnet server would not do anything -- make sure you turn it OFF.. You don't want something like that running and forwarded on at your router.

Did you power cycle your router? That would be my guess as to what cleared the issue.

I just suggested the telnet as its something quite easy to verify that its listening and working, etc. standard port -- nothing fancy, etc. very easy to check that can access it from another machine on your network, etc.

But no running that would have nothing to do with the port forwards on your router. Unless just creating a new one cleared something up on it.. But if you did power cycle it -- that would be my guess.

Again -- make sure you disable the telnet server, and do not forward it on your router. Not secure by any means, and should not be open to the public net..

edit: you can disable the service with the gui, or the command

sc config tlntsvr start= disabled

will work too, and then make sure you stop it.

net stop telnet

Link to post
Share on other sites
  • 0
Harreh

Well, it magically did start working as soon as I started the telnet server (which I have disabled now, including the open port) and running a power cycle didn't yield any results.

But the problem is back, now that the telnet server is disabled. The ports are not seen as open.

Link to post
Share on other sites
  • 0
+BudMan

really?? And if you turn it back on and forward the port they start working??

Link to post
Share on other sites
  • 0
Harreh

I re-enabled the telnet server and opened its port. canyouseeme.org has success seeing that port 23 is open immediately. All my other ports appear to be closed.

I then loaded up uTorrent, and after a minute or so its port eventually appeared to be open (according to itself and these port checkers). I just checked things out by finding a torrent with a ton of seeds and I reached very acceptable download speeds. I certainly can't attain these speeds with the port blocked.

I closed uTorrent and stopped the telnet server and loaded up uTorrent again. Then after a while its port appears to be open (but not when uTorrent is closed) and I attain similar speeds as to the previously mentioned speeds.

However, the WC3 ports don't ever open.

Link to post
Share on other sites
  • 0
+BudMan

sounds like UPnP to me.

Make sure you disable UPnP and only forward manual ports.. If you have some other computer wanting to open ports, it can atleast temp disconnect the other forwards, etc.

To be honest sounds like your router is a big POS to me ;)

Link to post
Share on other sites
  • 0
Harreh

Well, UPnP is disabled and this router is a big POS. UPnP is also disabled in uTorrent.

This router's fine if all you want is to get online but anything slightly more advanced then god help you it seems.

I don't think that things are gonna get any further with this (Unless you have any more ideas.. :unsure:), might phone BT for a replacement.

Cheers for the top-notch help (Y).

Link to post
Share on other sites
  • 0
+BudMan

Not sure what else to do.. We have verified that port forwards work.. ie the telnet thing. But then they stop.

Your not doing any type of port triggers are you? Where the ports are open only when its sees traffic. Can you post a screen shot of your forwards.

Link to post
Share on other sites
  • 0
Harreh

There is an option for port triggers, but I have no idea what they are as I've never heard or seen this feature before so I left it alone.

post-110879-1214410600.jpg

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.