• Sign in to Neowin Faster!

    Create an account on Neowin to contribute and support the site.

Sign in to follow this  

Windows 7 Official Public Beta

Recommended Posts

Ayepecks    117

Hmmm, trying to get Crysis: Warhead to run on Windows 7 to no avail. It's 32 bit and I'm running the 64-bit Windows 7, but that shouldn't be a problem at all.

Share this post


Link to post
Share on other sites
Darrian    259

I haven't tried to play Crysis, but I know all my games that use bull**** copy protection either 1) must be "Run as administrator" or if that doesn't work 2) must be cracked, try gamecopyworld.

Share this post


Link to post
Share on other sites
primexx    372

gaahhhh!!! SecureW2 doesn't work anymore!!

Share this post


Link to post
Share on other sites
DAMNiatx    0

anyone know direct link to download windows 7 ?

thanks

Share this post


Link to post
Share on other sites
danisflying527    5

Microsoft website?

Warhead works fine for me.....??

Infact all my games do

Share this post


Link to post
Share on other sites
Shaun N.    569

Woohoo Got my key. i thought they would have run out by now :p

Share this post


Link to post
Share on other sites
FloatingFatMan    18,768
Woohoo Got my key. i thought they would have run out by now :p

They've removed the 2.5 million key's limit. It's now unlimited until about the 26th.

Share this post


Link to post
Share on other sites
Yamanaka    0

Anyone that has Steam working?

I try to run it on Win7, but nothing happens when I start Steam.

Share this post


Link to post
Share on other sites
Unimatrix Xero    37

steam works fine for me

Share this post


Link to post
Share on other sites
Mannlich    17

Yeah, I've got my stem account up and running on 3 Widows 7 PCs. Works fine on all of them.

Share this post


Link to post
Share on other sites
weldon    0

I have been using Beta 1 x86 for a day or so, and when I try to install x64 on my laptop, it gives me an error

0. No Emulation System Type: 00

1. No Emulation System Type: 00

hitting 0 or 1 gives a disk error and goes to the boot menu.

Putting in my x86 disk works just fine. Any Ideas? Ive burned the disk in clonecd and imgburn and they both verified okay, and the x64 version is installable via XP, but I want it to be the only partition and be bootable from dos.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.