Archived

This topic is now archived and is closed to further replies.

Annoying IE8 Bug!

Recommended Posts

DannyOcean    0

1. Clean install of Vista Ultimate x86 SP1 with IE8 Final (laptop) and Open in same window is selected:

Steps to repro: Open Computer, double click on C:\, then double click on Program Files

Result: My folders open in the same window

2. Clean install of Vista Ultimate x64 SP1 with IE8 Final (desktop) and Open in same window is selected:

Steps to repro: Open Computer, double click on C:\, then double click on Program Files

Result: My folders open in the same window

Sounds like a problem specific to your machine.

Share this post


Link to post
Share on other sites
tinyavengerva    0

Lets not stir the fanboy pot

Share this post


Link to post
Share on other sites
gertin    0

Uninstalling IE8 fixed this issue for me.

Share this post


Link to post
Share on other sites
paritycheck    0

Hi,

same problem here yesterday but changing the default handler in

HKEY_CLASSES_ROOT\Folder\shell\open\command

to

%SystemRoot%\Explorer.exe /separate,/e,/idlist,%I,%L

fixed it for me.

Hope this will help somebody.

Share this post


Link to post
Share on other sites
jrf2027    0

This worked for me, but YMMV...

Before I installed IE 8, I had created an image of the system, so I uninstalled IE 8 by reimaging the known good image. The folders opened as they should - in the same window.

The files in the IE 8 .exe can be extracted using WinRAR or 7-Zip. Upon extracting the files, there are four files within the .exe - one of which is called ie8.msu. (For those of you who don't know, .msu files are Vista's update files.) I saved this file and deleted the rest.

I then reinstalled IE 8 by running the .msu file. The installation proceeds like you are installing a Vista update, rather than the standard IE 8 installation screens. After the install completes, it prompts you to restart Windows. Before restarting, I confirmed that folders still open in the same window.

Then, after restarting, but before running IE 8, I once again confirmed that folders still open in the same window. After the first run of IE 8, I checked it one last time - the folders open in the same window, as they should.

It worked for me...maybe it won't for you, but I'd rather put this information on the Interweb than not.

Share this post


Link to post
Share on other sites
Mike Frett    34

Tradien is right. Hold down Shift and right click the Internet Explorer link and Run it as Admin just once solved my problem.

Thanks Tradien ;)

Share this post


Link to post
Share on other sites
gertin    0
Hi,

same problem here yesterday but changing the default handler in

HKEY_CLASSES_ROOT\Folder\shell\open\command

to

%SystemRoot%\Explorer.exe /separate,/e,/idlist,%I,%L

fixed it for me.

Hope this will help somebody.

This worked for me too, apparently the following key:

HKEY_CLASSES_ROOT\Folder\shell\open\command

is changed from:

%SystemRoot%\Explorer.exe /separate,/e,/idlist,%I,%L

to:

%SystemRoot%\Explorer.exe /separate,/idlist,%I,%L

(notice the missing argument /e) after installing IE8 on my Vista x64 SP1 installation.

However, the key

HKEY_CLASSES_ROOT\Folder\shell\explore\command

stays unchanged and if you right click a folder, the Explore action is listed as default.

Share this post


Link to post
Share on other sites
Tradien    0
Tradien is right. Hold down Shift and right click the Internet Explorer link and Run it as Admin just once solved my problem.

Thanks Tradien ;)

Glad it helped someone!

Share this post


Link to post
Share on other sites
Tenchi103    1

Wanted to confirm the above too. Had the same problem where all windows were opening in new windows after installing IE8 on my vista. Also I noticed that url's within IE that opens a new browser to load failed to load the new window completly. After running IE from the start menu as that administrator once, it solved both issues.

You da man Tradien!

Share this post


Link to post
Share on other sites
jlfutari    0

In regards to the above IE 8 bug, had anyone found any more fix's or work arounds?

I have tried all of the above solutions and when I have IE8 Installed it will still open new folders in new windows, despite setting vista not to.

James

Share this post


Link to post
Share on other sites
Glen    48
In regards to the above IE 8 bug, had anyone found any more fix's or work arounds?

I have tried all of the above solutions and when I have IE8 Installed it will still open new folders in new windows, despite setting vista not to.

James

In Vista, if you have UAC enabled, when you open a secure socket like (HTTPS), it will open in a new window regardless of settings. This is a security feature and the only way around it that I know if is to disable UAC, which I wouldn't recommend.

Share this post


Link to post
Share on other sites
jlfutari    0
In Vista, if you have UAC enabled, when you open a secure socket like (HTTPS), it will open in a new window regardless of settings. This is a security feature and the only way around it that I know if is to disable UAC, which I wouldn't recommend.

I'm confused about your reply Glen, are we thinking of the same IE8 bug?

Share this post


Link to post
Share on other sites
gertin    0
In regards to the above IE 8 bug, had anyone found any more fix's or work arounds?

I have tried all of the above solutions and when I have IE8 Installed it will still open new folders in new windows, despite setting vista not to.

James

What finally fixed it for me was re-registering actxprxy.dll.

Start -> enter cmd in search field -> right click cmd.exe -> Run as administrator -> then enter 'regsvr32 actxprxy.dll'.

Source: http://blogs.msdn.com/ie/archive/2009/03/1...ow.aspx#9497248

Share this post


Link to post
Share on other sites
jlfutari    0
What finally fixed it for me was re-registering actxprxy.dll.

Start -> enter cmd in search field -> right click cmd.exe -> Run as administrator -> then enter 'regsvr32 actxprxy.dll'.

Source: http://blogs.msdn.com/ie/archive/2009/03/1...ow.aspx#9497248

Tried that fix - I get this error -

'The Module "actxprxy.dll" was loaded but the call to DllRegsiterServer failed with the error code 0x80070005'

New_Picture.bmp

New_Picture.bmp

Share this post


Link to post
Share on other sites
Glen    48
I'm confused about your reply Glen, are we thinking of the same IE8 bug?

I guess not. That's what I get for not being more attentive to what I'm reading. Sorry about that. :)

Share this post


Link to post
Share on other sites
gertin    0
Tried that fix - I get this error -

'The Module "actxprxy.dll" was loaded but the call to DllRegsiterServer failed with the error code 0x80070005'

New_Picture.bmp

The command needs to be run as Administrator. Start run cmd.exe as administrator and then input the command at the prompt.

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.