Archived

This topic is now archived and is closed to further replies.

X-Fi Sound Card issues

Recommended Posts

DrewJW    9

I have a really strange issue with my X-Fi Xtreme Audio, it seems when I am playing music the volume with alter up and down seemingly at random.

I am on Windows 7 X64 RTM with the latest drivers from Creative.

It is incredibly irritating. Anyone got any tips?

Share this post


Link to post
Share on other sites
Yusuf M.    1,354

It could be a volume issue with your speakers or headphones. I'd try a different playback device.

Share this post


Link to post
Share on other sites
DrewJW    9

I am on speakers at the minute, but have noted the problem through my headset ( Creative Fatality ) and my Headphones ( Sony DJ ). It's almost as if it is backing off when as EQ mode gets too high and then turns back up directly after.

I've noted turning off "crystalizer" helps to eliminate it, although not fully.

I'm hoping perhaps another Creative user has noted this issue before?

Share this post


Link to post
Share on other sites
SojIrOu    4

I can't remember the exact name but I believe its SVM (smart volume management?) thats causing the fluctuations in volume. Check to make sure yours is off.

Share this post


Link to post
Share on other sites
DrewJW    9
I can't remember the exact name but I believe its SVM (smart volume management?) thats causing the fluctuations in volume. Check to make sure yours is off.

I may have missed the option, any chance you could point me to which menu?

Share this post


Link to post
Share on other sites
Raa    1,411

I know the option he means. Although it's not usually enabled by default.

Go into the Creative Audio Control Panel, click "Speakers" tab, then click "SVM Off".

That should fix it...

Share this post


Link to post
Share on other sites
DrewJW    9
I know the option he means. Although it's not usually enabled by default.

Go into the Creative Audio Control Panel, click "Speakers" tab, then click "SVM Off".

That should fix it...

I am unable to find that option with my control panel...

post-238175-1250688242_thumb.jpg

Share this post


Link to post
Share on other sites
zeke009    64
I am unable to find that option with my control panel...

SVM is a small checkbox on one of those tabs. I'm running Vista at home, not sure if the panels for the drivers have changed between Vista and 7.

It can also be done using that fancy Creative Panel that is a separate install.

Share this post


Link to post
Share on other sites
DrewJW    9

I just checked each tab and curiously the option is not there.

I'll look for the GUI control panel on Creatives site and see if that helps.

Share this post


Link to post
Share on other sites
Jason S.    1,272

i had this same issue with my Xtrememusic... nothing i tried fixed it. first happened on Vista x64 (but not my previous x86 install). i recently formatted and installed Windows 7 x64 RTM w/ the latest creative drivers and i dont seem to have this issue anymore.

i think it's just a x64 driver issue... doesnt surprise me w/ Creative's past.

Share this post


Link to post
Share on other sites
DrewJW    9
i had this same issue with my Xtrememusic... nothing i tried fixed it. first happened on Vista x64 (but not my previous x86 install). i recently formatted and installed Windows 7 x64 RTM w/ the latest creative drivers and i dont seem to have this issue anymore.

i think it's just a x64 driver issue... doesnt surprise me w/ Creative's past.

I have to agree, it is strange as I was previously on Vista X64 SP2 Ultimate before moving to Windows 7 RTM X64, and then these issues happened.

I am downloading the full GUI pack + drivers at the minute, when completed I'll do a full uninstall of my old drivers, and reinstall of the full pack and hopefully I should be able to enjoy some music, while I plan on a replacement.

Share this post


Link to post
Share on other sites
zeke009    64
I have to agree, it is strange as I was previously on Vista X64 SP2 Ultimate before moving to Windows 7 RTM X64, and then these issues happened.

I am downloading the full GUI pack + drivers at the minute, when completed I'll do a full uninstall of my old drivers, and reinstall of the full pack and hopefully I should be able to enjoy some music, while I plan on a replacement.

Good luck uninstalling the drivers, I had nothing but problems with that and am sure something is not set right in my PC now. With Win7 around the corner I'm waiting for that instead of reimaging.

When I uninstalled the drivers, uninstalled the device and ran a driver cleaner I get warnings about the product already being installed when I try to reload Alchemy or any other app for the X-Fi drivers.

Creative really should have hired that kid who made their drivers work (hacked).

Share this post


Link to post
Share on other sites
SojIrOu    4

thats odd. its right under my "speakers" tab. right now i'm using my x-fi fatality with windows 7 x64 as well and don't encounter any fluctuations in volume.

some other stuff you could try is to disable EAX, Crystalizer and CMSS. all these three would contribute to the problem as well. i usually turn off all sound blaster enhancements and check the box to disable it completely. maybe that would help with your problem.

Share this post


Link to post
Share on other sites
DrewJW    9

Yeah turning off the "effects" does remove the issue, however it also reduces the sound quality.

I use Foobar for my MP3/Flac playback, and often stream internet radio through Firefox. So the X-Fi's enhancements are a nice option.

I'll look for a third party audio enhancement tool and disable the on-board enhancements.

Share this post


Link to post
Share on other sites
SojIrOu    4

Out of those 3, the main culprit would be CMSS. If you want to, you can try leaving crystaliser on but switch off the other two.

Share this post


Link to post
Share on other sites
DrewJW    9

I've turned off CMSS, I'll update if I continue to have issues :)

Thanks.

Share this post


Link to post
Share on other sites
bladebarrier    1
I've turned off CMSS, I'll update if I continue to have issues :)

Thanks.

I run Win7, use ref cans, and x-fi music.

As stated before, It sounds like the SVM option is enabled. or CMSS (though CMSS has it's place for some things). It could also be the way win7 is improperly recognizing your setup. Remove all of your sound drivers for your SB card. EVERYTHING. Re-install. If you still get issues, disable the crap by hitting the mode button and placing it in audio creation mode, set all disabled x-fi options forced off in windows itself, after re-installing. If that doesn't work, I can email you the hacked drivers that were around before, and walk you through a proper setup.

Creative isn't very good at making drivers.

My email is bladebarrier@gmail.com. Just put x-fi drivers, or simliar, in the title so I know it's not spam. I can send you basic setups and drivers that I downloaded for win7 x64 before I lost the ability to find them, or give basics on how to set up for sound quality with x-fi in win7.

I'm using $1000 reference cans (refer to sig), so I've spent time screwing with it.

Share this post


Link to post
Share on other sites
DrewJW    9

You have e-mail.

Share this post


Link to post
Share on other sites
DrewJW    9

Big thanks to Blade, who after sending me these drivers has solved the issue.

I can finally listen to my FLAC collection in perfect harmony now :)

Huge thanks to everyone though, :D great community spirit :D

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.