Sign in to follow this  
Followers 0
Simon

HOWTO: Make Windows 7 use a good Mac color profile

12 posts in this topic

Throughout the Windows 7 beta, one thing that put me off a little bit was the poor color that I got by default, and even after using Windows to calibrate my display.

So I set out to fix it. Here's the steps I took. Keep in mind this is easier if you have the Boot Camp 3.0 drivers installed, as you'll be using the color profile generated for you by Mac OS X, and with Boot Camp 3.0 you don't need to get the profile off your other partition via a flash drive/email/upload/whatever.

  1. Open up your Macintosh HD via "Computer", and browse to /Library/ColorSync/Profiles/Displays
  2. You should see a color profile of some sort there. If you do not, try looking in /Users/<your home directory>/Library/ColorSync/Profiles/. You may need to generate a color profile via the Mac OS X system preferences - see below
  3. Right click on this color profile and select "Install Profile". You can now close your Mac HD.
  4. Open the Control Panel, click "Adjust Screen Resolution", and click "Advanced Settings"
  5. Select the "Color Management" tab, and click the "Color Management" button that appears.
  6. Alternatively, just type "color management" into the Start menu and select it from the search pane. (thanks Danrarbc!)
  7. Click the "Advanced" tab, and click the "Change System Defaults" button.
  8. Click the "Advanced" tab in the new window that appears
  9. Ensure that the "Use Windows display calibration" checkbox is checked
  10. Select the "Devices" tab in this window again.
  11. Click the "Add" button and select the color profile you installed from your Mac partition.
  12. Click "OK"
  13. Now, select the color profile from the list.
  14. Click the "Set as default profile" button, on the bottom right.
  15. Your display should now brighten and lose the heavy blue tinge that has plagued you for months, or even years if you used Vista.

You may not need to complete all the steps, but I did. It really does make the Windows experience on a MacBook much nicer, and the same should apply to an iMac or any Mac with an integrated display. I believe Windows can figure out external displays without problem, but don't quote me there...

Share your experiences here! I have no doubt that this guide will not work for everyone, but the guide I found didn't do everything for me (see here, thanks to whoever did that).

And happy proper color support!

If there isn't a profile there

  1. Boot into Mac OS X
  2. Open System Preferences.
  3. Open the "Displays" panel and click the "Color" tab.
  4. Click the "Calibrate" button
  5. You can actually click "next" through this wizard, the whole way through. The default settings should be selected.
  6. Once the wizard is done, your profile will be located in /Users/<your user folder>/Library/ColorSync/Profiles/. Continue the process in Windows 7 from here.

If your color choice doesn't stick after a reboot, and you use an nVidia video card (9400M, 9600M GT, etc. etc.)

  1. Go here: http://www.nvidia.com/Download/index.aspx?lang=en-us
  2. Download the driver for your video card; chances are that your current driver is out of date.
  3. Install it
  4. Go to the Start Menu and start to type in 'nvidia'. You'll probably get a result that has the word 'PhysX' in it - that will get you to the nVidia control panel.
  5. On the left hand sidebar, select 'Adjust desktop color settings' (under the 'Display' header)
  6. On the screen that appears, under 'Choose how color is set', make sure 'Other applications control color settings' is the choice selected. Click OK, or exit the control panel.
  7. Now, try the guide above again.

If you use an ATI card, I can't help you as I'm on a MacBook Pro with the 9400M/9600M GT. All I can suggest is that you make sure you have the latest drivers, and are not managing your color through the ATi driver.

Edited by Simon

Share this post


Link to post
Share on other sites

Thanks for the howto! I'll keep this Yojimbo'd for when I install Windows 7 in Boot Camp. :D

Share this post


Link to post
Share on other sites

Pretty cool, thanks.

Never thought about using my Mac profile.

Share this post


Link to post
Share on other sites

Thanks! Windows 7 colour's on my iMac has always been washed out looking :p.

Share this post


Link to post
Share on other sites

thanks! I'll try this when i get my laptop back from repairs.

Share this post


Link to post
Share on other sites

You could always just type "Color Management" or "col m" or something along those lines into the start menu to quickly get to that control panel, no need to get there the long way.

Start Menu search. It's a good thing.?

Share this post


Link to post
Share on other sites

Good point, but getting there the long way *does* ensure that you get to the right panel.

We're Mac users, Windows noobs :p

Share this post


Link to post
Share on other sites

INCREDIBLE....

And I thought this was by design. My god, the windows are actually not blue anymore and look "normal"!

Thx for sharing!

Share this post


Link to post
Share on other sites

Can somebody upload that profile for me please?

Thanks in advance

Share this post


Link to post
Share on other sites

The profile you use depends entirely on the monitor you're using. A MacBook from 2006 will be different from a MacBook Pro from 2006 which will be different from a MacBook from 2008 and a MacBook Pro from 2008, which are all different from every iMac.

Basically, we need a model :p or you can grab the profile from your Mac partition, which will probably be the best route to take.

I've also solved a problem I had with color management settings not sticking after a reboot. I might be the only one with the problem, but I think it's all down to nVidia's control panel and color management (which does not seem as powerful as Windows' color management, nor does it seem to read standard color profiles).

So, here's what you do:

  1. Go here: http://www.nvidia.com/Download/index.aspx?lang=en-us
  2. Download the driver for your video card; chances are that your current driver is out of date.
  3. Install it
  4. Go to the Start Menu and start to type in 'nvidia'. You'll probably get a result that has the word 'PhysX' in it - that will get you to the nVidia control panel.
  5. On the left hand sidebar, select 'Adjust desktop color settings' (under the 'Display' header)
  6. On the screen that appears, under 'Choose how color is set', make sure 'Other applications control color settings' is the choice selected. Click OK, or exit the control panel.
  7. Now, try the guide above again.

I may be the only one with the problem, since I did a lot of messing around to try and get color management working.

Share this post


Link to post
Share on other sites

Oh, sorry,... I thought I can have same *.icc file on my Windows 7 based machine as you have on your OS X. I've misunderstood ya'll.

Share this post


Link to post
Share on other sites

After installing the newest nvidia notebook drivers, I have to re-apply the color profile every time I restart. Nvidia bug? Apparently, I'm not the only one affected.

edit: Ahem, scratch that. Just booted 7 and it applied the color profile at logon. Hope it'll stay that way...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.