• 0

Windows 7 Repair Install - Cannot Connect via Remote Desktop



I ran a repair install on a domain PC in my environment last week to correct an issue it was having. The users profile was also corrupt, so I created a new profile for him on the machine and transferred his file to it. I noticed this morning that I cannot RDP into his machine. As soon as I type the username and password via RDP on my machine, I get the error "Can't connect to remote computer". I searched high and low to find a solution and finally came about one.

In the Event Viewer (on the remote machine) there was error 36888 (Source Schannel) in the System log. There were two of these errors generated every time I tried to connect. The first time I tried to connect after rebooting the remote machine I received error 56 (TermDD) in the System log, also. In the Security log, I received error 5061 (Microsoft Software Key Storage Provider) twice every time I tried to connect.

To resolve the issue, I went into the Certificates console (for the Computer Account) and deleted the computer name certificate from the Remote Desktop certificates folder (after backing the certificate up for good measure). I then disabled Remote Desktop and re-enabled it (I don't know if this step is necessary, but I tried it, thinking it might regenerate the certificate). I then tried to connect from my remote machine, and it connected just fine. It appears that the certificate re-generated on the initial connect after I deleted the certificate.

Problem solved! Hope this helps someone.

  • Like 1
Link to comment
Share on other sites

0 answers to this question

Recommended Posts

There have been no answers to this question yet

This topic is now closed to further replies.

  • Recently Browsing   0 members

    No registered users viewing this page.