Meet the browser: Firefox Next

Recommended Posts

torrentthief    312

Firefox 5 Alpha 2 and Firefox 6 Alpha 1 are now out. Hope someone can run benchmarks on them.

Share this post


Link to post
Share on other sites
grayscale    237

It fills up the whole url bar instead of being a box within the url box.

Share this post


Link to post
Share on other sites
bogas04    198

Firefox 5 Alpha 2 and Firefox 6 Alpha 1 are now out. Hope someone can run benchmarks on them.

i guess only Bug 502892 is fixed in new aurora

Share this post


Link to post
Share on other sites
Oz.    10

New identity button style landed in the nightly.

post-2190-0-34142000-1303278879.png

post-2190-0-67919300-1303278556.png

post-2190-0-03113700-1303278550.png

I have the latest nightly and I can't see it :huh:

Anyone know from where I can get the build with the smooth moving tabs?

Share this post


Link to post
Share on other sites
alisalem    17

New identity button style landed in the nightly.

post-2190-0-34142000-1303278879.png

post-2190-0-67919300-1303278556.png

post-2190-0-03113700-1303278550.png

Aero borders seem to be smaller as well.

Share this post


Link to post
Share on other sites
macel    73

Aero borders seem to be smaller as well.

Firefox still adds an extra pixel to the border, I just reduce the aero's border padding across the board.

Share this post


Link to post
Share on other sites
dnast    39

Anyone know from where I can get the build with the smooth moving tabs?

Looks like it's no longer available. As far as I can tell, the patch is just waiting for review so it shouldn't be too long before it's in the nightlies.

Share this post


Link to post
Share on other sites
+Heartripper    184

Anyone know from where I can get the build with the smooth moving tabs?

i can upload it if you want!

Share this post


Link to post
Share on other sites
kilara1988    27

I played a little with the new settings in the about:config that are introduced by this fix and the font looks much better now.The default values were not good for me.And they say this is only one of the issues causing the bad fonts so there may be more font fixes soon.

Share this post


Link to post
Share on other sites
+Zlip792    463

I played a little with the new settings in the about:config that are introduced by this fix and the font looks much better now.The default values were not good for me.And they say this is only one of the issues causing the bad fonts so there may be more font fixes soon.

Please share you settings with us, so we can also try..

Share this post


Link to post
Share on other sites
+Frank B.    7,104

Please share you settings with us, so we can also try..

Bug 642589 landed in today's nightly, so for everyone having trouble with font rendering, please have a look at the gfx.font_rendering.cleartype_params.* settings in about:config. The params follow the ranges given here: ClearType Registry Settings. In addition, the available rendering modes are explained here: DWRITE_RENDERING_MODE Enumeration. The numbers gfx.font_rendering.cleartype_params.rendering_mode takes correspond with these modes as follows: "0 = default, 1 = aliased, 2 = GDI Classic, 3 = GDI Natural,

4 = Natural, 5 = Natural Symmetric]

Source: mozillazine forum

Share this post


Link to post
Share on other sites
kilara1988    27

LOL.I didn't play with the gfx.font_rendering.cleartype_params.rendering_mode,just with the contrast,gamma and cleartype lvl ones.But when i set those to default and gfx.font_rendering.cleartype_params.rendering_mode to "2" for GDI Classic it is now perfect!!!Like with the AA addon,but without the bad spacing.They finally fixed it!!!

Share this post


Link to post
Share on other sites
The_Decryptor    1,105

GDI Classic adds bad spacing on purpose, some people might prefer it but it's not better from a technical standpoint.

Share this post


Link to post
Share on other sites
kilara1988    27

With the AA addon it was far worse.Some of the letters overlapped and some were too far away within one word.And i prefer the GDI Natural rendering.Didn't try it yet in the previous post.

Share this post


Link to post
Share on other sites
+Heartripper    184

oh noes, please don't remove button borders!

  • Like 1

Share this post


Link to post
Share on other sites
kilara1988    27

Why not?It looks better without borders.What do you need borders for anyway?

  • Like 4

Share this post


Link to post
Share on other sites
Jan    402

Why not?It looks better without borders.What do you need borders for anyway?

That's purely an opinion and I personally like the borders imo.

Share this post


Link to post
Share on other sites
ViperAFK    783

Thank god looks SO much better now.

Set it to 2 if you want the old style cleartype rendering.

Share this post


Link to post
Share on other sites
trag3dy    3,347

Using the latest nightly from today, anyone else notice that Stylish doesn't open in it's own manage window now or is it just me? It forces it open in a tab so I can't search through my styles.

I can right click on the extension and get it that way.. but then it won't let me switch back to firefox without closing that window. :wacko:

Share this post


Link to post
Share on other sites
grayscale    237

Stylish 1.1.2

-Updated the toolbar button to act more like other toolbar buttons

-New default in Firefox 4 is to use the Add-ons Manager when choosing Manage Styles. The setting extensions.stylish.manageView is still available - 0 for add-ons manager, 1 for stand-alone dialog, 2 for sidebar

-Added links for creating a new style and going to userstyles.org in add-ons manager

-Removed Page Style overlay

-Fixes for latest Firefox, Seamonkey, and Thunderbird

-Updated Czech and Japanese localizations

-Added partial Romanian localization

Edit:

Also, you can edit your styles through the addons manager, BUT NOT on the EXTENSIONS tab, but on the USER STYLES tab.

Share this post


Link to post
Share on other sites
trag3dy    3,347

Thanks, it's odd though because Firefox 4 has the normal behavior I'm used to, while the nightly doesn't. Not a big deal though.

Share this post


Link to post
Share on other sites
+Heartripper    184

Thanks, it's odd though because Firefox 4 has the normal behavior I'm used to, while the nightly doesn't. Not a big deal though.

in about config, set:

extensions.stylish.manageView

to 1 to make it open in a dialog!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.