DOOM 3: Windows 2000 and Xp

Huge rumours have been flying around regarding Doom 3's platform compatabilities. It seems as if that Doom 3 can only run through Windows 2000 or XP. Meaning ultimately, if you have Windows or Windows 98SE and below, you will not be able to run the game. planetDOOM dislikes rumours in everyway, and according to them, they have asked Doom 3 developers and they have confirmed that the rumour is true.

Dice says: Not surprising, one of the biggest games will need a OS to run its big graphics and actions.

News source: planetDOOM

Report a problem with article
Previous Story

Apple & Pepsi at it again?

Next Story

Lucasarts Focuses on Star Wars: Episode III Game

0 Comments - Add comment