Jump to content



Photo

ftp streaming using VLC

ftp streaming vlc ftp stream vlc streaming

  • Please log in to reply
3 replies to this topic

#1 capr

capr

    Neowinian Senior

  • Joined: 01-July 05

Posted 10 January 2012 - 23:45

I am trying to stream some files from an ftp server. I have access to the server and can download the file but I want to stream.

I am using this ftp://name:password@.../video/test.avi
for some reason vlc starts playing with high quality and everything but after 3 seconds or so, it stops...

windows media player just doesn't do anything and windows media player classic tries to download the file to a temp folder before playing. so my only option is VLC.

I have tried this from multiple computers on the LAN and off the LAN and i get the same result. so I am thinking something is wrong server side?

ftp server is setup with filezilla.

Here is the log file I have removed the date tags to make this smaller.


15:48:20 PM - (not logged in) (174.127.193.103)> Connected, sending welcome
15:48:20 PM - (not logged in) (174.127.193.103)> 220 test line
15:48:20 PM - (not logged in) (174.127.193.103)> USER user
15:48:20 PM - (not logged in) (174.127.193.103)> 331 Password required for
15:48:20 PM - (not logged in) (174.127.193.103)> PASS ****
15:48:20 PM - user (174.127.193.103)> 230 Logged on
15:48:20 PM - user (174.127.193.103)> EPSV ALL
15:48:20 PM - user (174.127.193.103)> 229 Entering Extended Passive Mode
15:48:20 PM - user (174.127.193.103)> TYPE I
15:48:20 PM - user (174.127.193.103)> 200 Type set to I
15:48:20 PM - user (174.127.193.103)> SIZE movies/test.avi
15:48:20 PM - user (174.127.193.103)> 213 734021632
15:48:20 PM - user (174.127.193.103)> EPSV
15:48:20 PM - user (174.127.193.103)> 229 Entering Extended Passive Mode
15:48:20 PM - user (174.127.193.103)> TYPE I
15:48:20 PM - user (174.127.193.103)> 200 Type set to I
15:48:20 PM - user (174.127.193.103)> RETR movies/test.avi
15:48:20 PM - user (174.127.193.103)> 150 Connection accepted
15:48:20 PM - user (174.127.193.103)> 426 Connection closed; transfer aborted.
15:48:20 PM - user (174.127.193.103)> ABOR
15:48:20 PM - user (174.127.193.103)> 226 ABOR command successful
15:48:20 PM - user (174.127.193.103)> EPSV
15:48:20 PM - user (174.127.193.103)> 229 Entering Extended Passive Mode (|||6001|)
15:48:20 PM - user (174.127.193.103)> TYPE I
15:48:20 PM - user (174.127.193.103)> 200 Type set to I
15:48:20 PM - user (174.127.193.103)> REST 8582
15:48:20 PM - user (174.127.193.103)> 350 Rest supported. Restarting at 8582
15:48:21 PM - user (174.127.193.103)> RETR movies/test.avi
15:48:21 PM - user (174.127.193.103)> 150 Connection accepted, restarting at offset 8582
15:48:21 PM - user (174.127.193.103)> 426 Connection closed; transfer aborted.
15:48:27 PM - user (174.127.193.103)> disconnected.

after googling i know that the problem is with the 426 connection closed line but can't figure out how to fix it. Windows is fully updated.


#2 OP capr

capr

    Neowinian Senior

  • Joined: 01-July 05

Posted 11 January 2012 - 23:42

Further research shows that this is usually a port forwarding problem. the entire port range is open.

Because of the way I have things setup, port 21 is used for instructions and 6000-6010 is used for the connection. does the client need to open these ports as well? VLC is already cleared through the firewall.

I have a feeling that this is a problem of passive connection vs active connection. it looks like the server tries to enter extended passive mode but fails.

What do I include in my VLC command that makes sure an active mode connection is established?
thanks

#3 Koshur

Koshur

    Neowite

  • Tech Issues Solved: 1
  • Joined: 08-February 12
  • OS: Win7, Ubuntu 12.04LTS, PinguyOS 11.10, Backtrack 5R2, Zorin OS

Posted 15 August 2013 - 06:46

Was this ever solved? I'm just trying to do the same. cant stream through a browser or VLC



#4 Koshur

Koshur

    Neowite

  • Tech Issues Solved: 1
  • Joined: 08-February 12
  • OS: Win7, Ubuntu 12.04LTS, PinguyOS 11.10, Backtrack 5R2, Zorin OS

Posted 15 August 2013 - 10:53

wel.. xmbc did the trick for me :)