Question

Posted

I just tried setting up word press, using IIS 7.5, SQL server 2008 R2, PHP 5.3.10, and wordpress 3.3.2. Using various guides on the internet, I was able to get it working, installed, and setup. As far as I can tell there are no issues (i can change settings, update themes, etc. Everything looks like it's working, except no posts show on the home page. If I go into the admin panel, and look at posts, it says "all(3)", but then shows no entries. If I make a new post, it gives me a link that lets me see the post, but then when I click home, or search for it, it doesn't show. What's strange, is that if i create new categories, they show up on the home page, but if I associate a post to a category and then click a category, it doesn't show either.

Anyone know what the issue is?

Here's a link to it:[url="http://www.healthyinspirit.com/wordpress/"]http://www.healthyin....com/wordpress/[/url]

Admin link: [url="http://www.healthyinspirit.com/wordpress/wp-admin/"]http://www.healthyin...press/wp-admin/[/url]

Admin login is admin / 1234abcd


I've tried granting full permissions to all folders, turned off windows firewall on both the SQL server and the IIS server, as well as looked at the database to verify that the content is being inserted into the database. All the posts I've seen on wordpress and other sites are for people who had working sites, but now aren't seeing new posts, but I haven't found anything for new installs yet, so I'm at a loss.

Share this post


Link to post
Share on other sites

10 answers to this question

  • 0

Posted

further, it seems direct links work, such as [url="http://www.healthyinspirit.com/wordpress/?p=5"]http://www.healthyinspirit.com/wordpress/?p=5[/url]

Share this post


Link to post
Share on other sites
  • 0

Posted

Looks like your posts were published private... try change your posts to public then update them.

check your posts status on the right-hand side column when you are at editing post window.

Did you install wordpress from control panel? or you download/install wordpress by yourself?

Share this post


Link to post
Share on other sites
  • 0

Posted

[quote name='shozilla' timestamp='1335503285' post='594828059']
Looks like your posts were published private... try change your posts to public then update them.

check your posts status on the right-hand side column when you are at editing post window.

Did you install wordpress from control panel? or you download/install wordpress by yourself?
[/quote]

downloaded and installed it myself. I went back, wiped it out again, reinstalled wordpress, reconfigured the database, set up url-rewrite mod, and it still doesn't seem to show stuff. I can see posts with a direct link but not on the page, even if i mark it private. Also, this is whats troubling me:
[attachment=310095:psts.png]

It says "ALL: 4" now, but yet "no posts found". It's as if it's not able to read back from the database, but i know thats not true because the direct urls work.

I don't think it's a database issue, I think it's something in the php. I'm looking to try and see where the functions for wordpress are, to see what's going on with reading data back. I'm still looking, but if I can't figure it out, I'm going to try two things. 1.) install all in one, instead of a two-tier environment, and 2.) try running the microsoft wordpress setup that is supposed to download everything and configure it (but usese mysql). I don't really want to run a 2nd database, but I suppose I may have to if I can't get it working with my existing SQL server.

Also, I just added a page, and that shows up as well, so it's something specific to posts. I've used different themes and it doesnt change anything.

Share this post


Link to post
Share on other sites
  • 0

Posted

Try MySQL instead. Info and download: [url="http://www.mysql.com"]http://www.mysql.com[/url]

So you will use MySQL with your IIS server.


See here: [url="http://codex.wordpress.org/Installing_WordPress#Installing_WordPress_on_your_own_Computer"]http://codex.wordpress.org/Installing_WordPress#Installing_WordPress_on_your_own_Computer [/url]

Scroll down until you see "[b]Easy 5 Minute WordPress Installation on Windows[/b]" then read the Step 4 which says "[b]Installation of WordPress and its requirements[/b]".. read that part and Step 5 as well. It might help you out and change SQL server to MySQL or get BitNami which has everything you need out of the box.


If your site is hosted by your provider then ask your site admin to add mysql or change your wordpress settings to MySQL instead...

If your site is hosted on your computer, see the site that i just provided you a link.

Share this post


Link to post
Share on other sites
  • 0

Posted

Offtopic: Didn't realise it even ran on IIS and Ms SQL Server!

Share this post


Link to post
Share on other sites
  • 0

Posted

[quote name='shozilla' timestamp='1335513245' post='594828177'] Try MySQL instead. Info and download: [url="http://www.mysql.com"]http://www.mysql.com[/url] So you will use MySQL with your IIS server. See here: [url="http://codex.wordpress.org/Installing_WordPress#Installing_WordPress_on_your_own_Computer"]http://codex.wordpress.org/Installing_WordPress#Installing_WordPress_on_your_own_Computer [/url] Scroll down until you see "[b]Easy 5 Minute WordPress Installation on Windows[/b]" then read the Step 4 which says "[b]Installation of WordPress and its requirements[/b]".. read that part and Step 5 as well. It might help you out and change SQL server to MySQL or get BitNami which has everything you need out of the box. If your site is hosted by your provider then ask your site admin to add mysql or change your wordpress settings to MySQL instead... If your site is hosted on your computer, see the site that i just provided you a link. [/quote]

Thanks. I was going to give mysql a try next, though I think it's more in something with the PHP going on. I was trying to avoid running two seperate database platforms, but I suppose if it works in mysql then it'll have to do. and yeah nik, theres a dozen or so guides on how to use wordpress with sql..it was actually rather easy to set up.

Share this post


Link to post
Share on other sites
  • 0

Posted

meh. MySql version works fine, although it's using 3.3.1, maybe 3.3.2 doesn't work right. Either way this was easy, so I guess I'll just roll with two databases for now.

Thanks

Share this post


Link to post
Share on other sites
  • 0

Posted

found the solution here [url="http://sourceforge.net/tracker/?func=detail&aid=3485384&group_id=315685&atid=1328061"]http://sourceforge.net/tracker/?func=detail&aid=3485384&group_id=315685&atid=1328061[/url]


[quote][color=#555555][font=arial, helvetica, clean, sans-serif][size=3][left]translations.php[/left][/size][/font][/color]
[color=#555555][font=arial, helvetica, clean, sans-serif][size=3][left]line 726[/left][/size][/font][/color]
[color=#555555][font=arial, helvetica, clean, sans-serif][size=3][left]Change this: $pattern = '/LIMIT\s*(\d+)((\s*,?\s*)(\d+)*)(;{0,1})$/is';[/left][/size][/font][/color]
[color=#555555][font=arial, helvetica, clean, sans-serif][size=3][left]to this: $pattern = '/LIMIT\s*(\d+)((\s*,?\s*)(\d+)*);{0,1}$/is';[/left][/size][/font][/color]

[color=#555555][font=arial, helvetica, clean, sans-serif][size=3][left]Removing the extra parentheses allows "LIMIT 0, 10" to become "TOP 10".[/left][/size][/font][/color]
[color=#555555][font=arial, helvetica, clean, sans-serif][size=3][left]With the extra parentheses, the "0" is used instead.[/left][/size][/font][/color][/quote]

everything works now, and I'm back on SQL Server 2008 r2
1 person likes this

Share this post


Link to post
Share on other sites
  • 0

Posted

Good. Glad that you got it solved.

I mostly use Apache and MySQL for the scripts that I write with.

I used to run IIS on my system but it wasn't long before I changed to Apache.



Have fun with your blog.

Share this post


Link to post
Share on other sites
  • 0

Posted

SirEvan, your post on this issue has been the end of my tortuous way to install WordPress on Windows Server 2008 R2, with IIS, PHP and SQL Server 2008 R2, and in Spanish (which gives more problems)
This problem with the list of posts was the last to be resolved (at least for now).

Thanks a lot for sharing your solution.

Alvaro

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.