Jump to content



Photo

How can I disable Journaling on an external drive?

os x lion disk utility

  • Please log in to reply
10 replies to this topic

#1 kizzaaa

kizzaaa

    Alumni

  • Joined: 06-September 03
  • Location: Sydney, Australia

Posted 05 June 2012 - 05:46

Hi Guys,

I am trying to turn off Journaling on an external hard drive currently formatted as HFS+ (Mac OS Extended, Journaled). For some reason my media centre tv will only support HFS+ with journaling turned off.

I've completed a google search, attempted to turn off journaling through Disk Utility etc, still cannot work it out.

Before suggesting that I use another type partition format:
  • I cannot use FAT32 because file size limitations
  • NTFS is not natively supported by OS X for writing files
  • ExFAT would be perfect but is not supported by my media centre

Does anyone know how I can turn off Journaling without deleting the partition?

Thanks!

OS: Lion OS X 10.7.4


#2 .Neo

.Neo

    Generic User

  • Joined: 14-September 05
  • Location: Amsterdam, NL
  • OS: OS X Mavericks
  • Phone: iPhone 5s

Posted 05 June 2012 - 06:15

With previous OS X / Disk Utility versions you had the option to format a drive as such, but apparently Apple got rid of it in OS X Lion or Snow Leopard. Since you have a 2010 iMac you could try to startup from the OS X Snow Leopard Install DVD and check if the option is still there in Disk Utility. Otherwise you'll need OS X Leopard or some other solution.

#3 Miuku.

Miuku.

    A damned noob

  • Joined: 10-August 03
  • Location: Finland, EU
  • OS: :: OS X :: SLES ::

Posted 05 June 2012 - 06:20

Select the disk, press Option and then the "Disable Journal" will appear in the File menu (Press option, keep it pressed and Click File)

If you don't know what "Option" key is, it's the key between the Ctrl and Command key, left of the Apple logo, now sporting a fancy "Alt" text. :-)

#4 OP kizzaaa

kizzaaa

    Alumni

  • Joined: 06-September 03
  • Location: Sydney, Australia

Posted 05 June 2012 - 07:20

With previous OS X / Disk Utility versions you had the option to format a drive as such, but apparently Apple got rid of it in OS X Lion or Snow Leopard. Since you have a 2010 iMac you could try to startup from the OS X Snow Leopard Install DVD and check if the option is still there in Disk Utility. Otherwise you'll need OS X Leopard or some other solution.

With previous OS X / Disk Utility versions you had the option to format a drive as such, but apparently Apple got rid of it in OS X Lion or Snow Leopard. Since you have a 2010 iMac you could try to startup from the OS X Snow Leopard Install DVD and check if the option is still there in Disk Utility. Otherwise you'll need OS X Leopard or some other solution.


I don't know where I put my Snow Leopard discs, haven't needed them for ages. But that might be the only solution.

Select the disk, press Option and then the "Disable Journal" will appear in the File menu (Press option, keep it pressed and Click File)

If you don't know what "Option" key is, it's the key between the Ctrl and Command key, left of the Apple logo, now sporting a fancy "Alt" text. :-)


One of the first things I tried. The option to disable Journaling has been removed from Lion. :(

#5 OP kizzaaa

kizzaaa

    Alumni

  • Joined: 06-September 03
  • Location: Sydney, Australia

Posted 05 June 2012 - 07:27

Select the disk, press Option and then the "Disable Journal" will appear in the File menu (Press option, keep it pressed and Click File)

If you don't know what "Option" key is, it's the key between the Ctrl and Command key, left of the Apple logo, now sporting a fancy "Alt" text. :-)


Wait!

I re-tried this and held Option before clicking on the File menu. It revealed the Disabled Journaling command. Werid thing is, the partition still states it's journaled.

I will see how the drive works in my media centre now...

Thanks

#6 Miuku.

Miuku.

    A damned noob

  • Joined: 10-August 03
  • Location: Finland, EU
  • OS: :: OS X :: SLES ::

Posted 05 June 2012 - 07:40

Yes sorry, I tried to convey that you should have it pressed before going into the menu - my bad.

You may have to dismount/mount it before "Info" in the Disk Utility properly shows the state of the journalling. If it doesn't work, there is one other way to disable it by forcing it from the command line.

#7 .Neo

.Neo

    Generic User

  • Joined: 14-September 05
  • Location: Amsterdam, NL
  • OS: OS X Mavericks
  • Phone: iPhone 5s

Posted 05 June 2012 - 08:36

Good tip. (Y)

#8 OP kizzaaa

kizzaaa

    Alumni

  • Joined: 06-September 03
  • Location: Sydney, Australia

Posted 05 June 2012 - 10:08

It works! Media Centre now works properly.

Thanks guys. Surprisingly a lot info on the net suggests you can't turn off journaling in Lion.

#9 Miuku.

Miuku.

    A damned noob

  • Joined: 10-August 03
  • Location: Finland, EU
  • OS: :: OS X :: SLES ::

Posted 05 June 2012 - 10:09

That's why you ask the pros ;-)

#10 Richard C.

Richard C.

    Neowinian Senior

  • Joined: 15-April 05
  • Location: Around
  • OS: Windows 8.1 Pro & Mac OSX
  • Phone: iPhone 5

Posted 05 June 2012 - 18:33

I have Snow Leopard, and Lion, and in both I get this choice:

Screen shot 2012-06-05 at 19.31.44.png

#11 Miuku.

Miuku.

    A damned noob

  • Joined: 10-August 03
  • Location: Finland, EU
  • OS: :: OS X :: SLES ::

Posted 05 June 2012 - 18:35

Yes but he wanted to disable journalling on an existing drive.

But you are right - if you create a completely new partition, it allows you to do it right off the bat.