Sign in to follow this  
Followers 0

Cisco Linksys EA4500


51 posts in this topic

Posted

Hi,

So I got some new network equipment and got a really strange issue, been on support to Cisco earlier trying to resolve this and they have no clue. I am going to try explain this the best I can. I have this Router/Modem combination from virgin media called the "SuperHub", it is an absolute pile of rubbish in terms of WiFi hence the new Router. They recently updated it allowing it to be put into "Modem Mode" which turns off all Router features and has only 1 port active.

I have connected the Cisco Linksys EA4500 Internet port to Port 1 of the SuperHub (the only port active in Modem Mode). I turned on the Router and there is no Internet connection unless I set my DNS servers to OpenDNS then it works, as I am using it right now through the router.

But the issue is, I have no features of my router because it cannot see that I am connected to the internet (see below)

wIg9v.png

Also on the Diagnostics page it shows my IP Address as being 0.0.0.0

MM3lo.png

This is what I have setup to get access to the internet

Jjz7T.png

But it still isn't clearly working properly, for some reason some Apple services are failing to connect and I don't have features like "QoS", "Device List", "Guest WiFi" simply because the UI needs Internet access to display those features with "Cisco Cloud".

I am completely lost, I never thought it was so hard to setup a new router, I blame the so-called "SuperHub". According to Cisco theres no issues with the SuperHub and this router.

Help appreciated

Matt.

Share this post


Link to post
Share on other sites

Posted

On that last image I can see the option "Internet Settings". Could you screenshot that page please?

Also, you might want to try 8.8.8.8 and 8.8.4.4 for DNS. They're Google DNS and don't have all the special OpenDNS redirects when things aren't found.

Share this post


Link to post
Share on other sites

Posted

On that last image I can see the option "Internet Settings". Could you screenshot that page please?

Also, you might want to try 8.8.8.8 and 8.8.4.4 for DNS. They're Google DNS and don't have all the special OpenDNS redirects when things aren't found.

Thanks but I will stick to OpenDNS for now! Anyhow here is that page:

95YvZ.png

The dropdown list has "Bridge Mode" and "Static IP" options which are suitable to be, the others are just PPoE or whatever it is for other types of internet connections. Bridge Mode turns off all the router features as it says when I click on it and Static IP would not be ideal for me as my IP changes :/

Any ideas?

Share this post


Link to post
Share on other sites

Posted

Your never going to get anywhere without an internet IP.. So your saying you have internet access from a client connected to this router if you use google or opendns??

Sorry but that is BS plan and simple from what your showing - the router has NO INTERNET CONNECTION, it has NO IP -- it is IMPOSSIBLE for it to route traffic to the internet - dns has nothing to do with this.

So if they put your superhub into modem mode - did you reboot it? And then connect and power up your router? Until your router shows it has an IP address on its WAN interface there is no possible way for it to route traffic.

As suggested already let see the internet setting page.

edit:

Are you getting an IPv6 address??

disconnect your router and unplug it from power. Power Cycle your "modem/superhub" Now connect your router via its internet and port that is active on your superhub, you sure your using the correct port? Then power up your cisco router -- what does it show for internet IP? If nothing - then what your saying is impossible. It is impossible for you to have internet access through this router if it has NO internet IP address.

So your ISP told you that your router should be in dhcp mode? Or do you need to use PPPoE or something?

Share this post


Link to post
Share on other sites

Posted

Your never going to get anywhere without an internet IP.. So your saying you have internet access from a client connected to this router if you use google or opendns??

Sorry but that is BS plan and simple from what your showing - the router has NO INTERNET CONNECTION, it has NO IP -- it is IMPOSSIBLE for it to route traffic to the internet - dns has nothing to do with this.

So if they put your superhub into modem mode - did you reboot it? And then connect and power up your router? Until your router shows it has an IP address on its WAN interface there is no possible way for it to route traffic.

As suggested already let see the internet setting page.

edit:

Are you getting an IPv6 address??

disconnect your router and unplug it from power. Power Cycle your "modem/superhub" Now connect your router via its internet and port that is active on your superhub, you sure your using the correct port? Then power up your cisco router -- what does it show for internet IP? If nothing - then what your saying is impossible. It is impossible for you to have internet access through this router if it has NO internet IP address.

So your ISP told you that your router should be in dhcp mode? Or do you need to use PPPoE or something?

The SuperHub is actually a router, I put it into Modem mode myself following my ISP instructions (http://help.virginmedia.com/system/selfservice.controller?CMD=VIEW_ARTICLE&ARTICLE_ID=412750&CURRENT_CMD=SEARCH&CONFIGURATION=1002&PARTITION_ID=1&USERTYPE=1&LANGUAGE=en&COUNTY=us&VM_CUSTOMER_TYPE=Cable)

I don't need PPPoE or any of that, I plug my SuperHub in and it should just work.

I am on the internet right now through the EA4500, the only way for me to get on is by setting manually DNS settings in the DHCP settings of the EA4500. The EA4500 is saying there is no IP Address or anything but I am on the internet :s I don't know what is going on

Share this post


Link to post
Share on other sites

Posted

And you sure your not wireless on the network next door?

For it to work you HAVE to have a internet IP ;) it is NOT possible for you to connect through that router if it does not have an internet IP - come do we really need to go over that.

Now is it possible your router is NOT showing you what its internet IP is, sure that is possible I guess. Seems unlikely to be honest, it would make more sense that your actually wireless to some network across the street and getting internet that way ;)

Connect your PC to the superhub in modem mode - what does your PC show you for your IP? You will most likely have to power cycle the superhub when connecting a new device with different mac, etc.

Share this post


Link to post
Share on other sites

Posted

And you sure your not wireless on the network next door?

For it to work you HAVE to have a internet IP ;) it is NOT possible for you to connect through that router if it does not have an internet IP - come do we really need to go over that.

Now is it possible your router is NOT showing you what its internet IP is, sure that is possible I guess. Seems unlikely to be honest, it would make more sense that your actually wireless to some network across the street and getting internet that way ;)

Connect your PC to the superhub in modem mode - what does your PC show you for your IP? You will most likely have to power cycle the superhub when connecting a new device with different mac, etc.

I am connected wired to the router which is why I am so confused, is it possible that the "SuperHub" is not sending the IP to the Cisco router and the Cisco router is thinking its got not internet connectivity because the IP displays 0.0.0.0? I don't know how this stuff works but its acting strange

Share this post


Link to post
Share on other sites

Posted

The super hub automatically reboots when modem mode is active.

Your Cisco should have the super hub connected to its wan port. You must use port 1 of the super hub iirc.

Your Cisco should be configured to use dynamic or dhcp on its wan port.

It will then pull DNs and such automatically

Share this post


Link to post
Share on other sites

Posted

The super hub automatically reboots when modem mode is active.

Your Cisco should have the super hub connected to its wan port. You must use port 1 of the super hub iirc.

Your Cisco should be configured to use dynamic or dhcp on its wan port.

It will then pull DNs and such automatically

I have done all that, yet the Cisco router still says there is no ip address or anything, soon as I set my own DNS on the router in the "DHCP SETTINGS" (see image) the internet suddenly works :laugh:

cPAX6.png

Yet the router still says there is no internet, I reset it at the back 3 times, same with the SuperHub. :huh:

Share this post


Link to post
Share on other sites

Posted

"SuperHub" is not sending the IP to the Cisco router"

If that was the case it would be IMPOSSIBLE for you to have internet, if you say your wired to the router and you have internet access while pointing to the cisco as your gateway. Then the only possible way that could happen is that the router does really have an IP and is just not showing it to you.

I would suggest you connect your PC to your superhub just like you would your router - and then look at IPconfig /all -- what do you get? Do you have internet access?

edit: If your router is flaky, ie not showing you its wan/internet IP - then couldn't hurt to do a HARD RESET on it!! Maybe that will clear up anything weird in its settings that is not showing you its wan IP and its dns forwarder not working.

As stated router should be getting your ISP dns and listing those and then that is what it forwards too, but if something flaky with it and its not showing IP, maybe its not using/getting those.

Which is why I suggest you connect a PC to your superhub while its in modem mode and verify you are getting IP and dns from your ISP in this mode, etc.

Share this post


Link to post
Share on other sites

Posted

"SuperHub" is not sending the IP to the Cisco router"

If that was the case it would be IMPOSSIBLE for you to have internet, if you say your wired to the router and you have internet access while pointing to the cisco as your gateway. Then the only possible way that could happen is that the router does really have an IP and is just not showing it to you.

I would suggest you connect your PC to your superhub just like you would your router - and then look at IPconfig /all -- what do you get? Do you have internet access?

edit: If your router is flaky, ie not showing you its wan/internet IP - then couldn't hurt to do a HARD RESET on it!! Maybe that will clear up anything weird in its settings that is not showing you its wan IP and its dns forwarder not working.

As stated router should be getting your ISP dns and listing those and then that is what it forwards too, but if something flaky with it and its not showing IP, maybe its not using/getting those.

Which is why I suggest you connect a PC to your superhub while its in modem mode and verify you are getting IP and dns from your ISP in this mode, etc.

The super hub automatically reboots when modem mode is active.

Your Cisco should have the super hub connected to its wan port. You must use port 1 of the super hub iirc.

Your Cisco should be configured to use dynamic or dhcp on its wan port.

It will then pull DNs and such automatically

Connected directly to the Modem and Internet only works if I manually set a DNS because look!

ZA3BZ.png

My ISP isn't providing me with any DNS, WHAT!?!?!???

IPConfig output:

Ethernet adapter Local Area Connection:


   Connection-specific DNS Suffix  . :

   Description . . . . . . . . . . . : Marvell Yukon 88E8001/8003/8010 PCI Gigab

it Ethernet Controller

   Physical Address. . . . . . . . . : 90-E6-BA-1E-AE-26

   DHCP Enabled. . . . . . . . . . . : Yes

   Autoconfiguration Enabled . . . . : Yes

   Link-local IPv6 Address . . . . . : fe80::b05c:fb1d:496:835a%11(Preferred)

   IPv4 Address. . . . . . . . . . . : 77.98.70.82(Preferred)

   Subnet Mask . . . . . . . . . . . : 255.255.255.0

   Lease Obtained. . . . . . . . . . : 03 October 2012 21:03:54

   Lease Expires . . . . . . . . . . : 10 October 2012 21:03:53

   Default Gateway . . . . . . . . . : 77.98.70.1

   DHCP Server . . . . . . . . . . . : 62.253.131.161

   DHCPv6 IAID . . . . . . . . . . . : 244377274

   DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-16-5C-55-D3-90-E6-BA-1E-AE-26


   DNS Servers . . . . . . . . . . . : fec0:0:0:ffff::1%1

									   fec0:0:0:ffff::2%1

									   fec0:0:0:ffff::3%1

   NetBIOS over Tcpip. . . . . . . . : Enabled

So now, I can only guess that my router is thinking there is no internet connection because It is trying to resolve "www.ciscocloudconnect.com" using the DNS servers the ISP is supposed to provide but it can't find it because there is no DNS! (DNS is set manually by me in the DHCP settings to 'over-ride' the ISP's DNS which is why the internet appears to be working for me).

Wtf? What should I do from here, If i contact my ISP I am going to get someone reading from a script displayed on there computer screen, I will get no where with that :\

Share this post


Link to post
Share on other sites

Posted

Well I would for starters do a sniff of the traffic as you get an IP to verify that they are not providing you dns -- this is going to be an option in the dhcp offer.

So for example here on my work box.

post-14624-0-17464400-1349296742_thumb.j

Its quite possible that they are in the offer and your router is just not taking them? Never heard of an ISP that does not provide DNS. So if they are not offering it in the dhcp offer - then I would for sure call them on it!

On a client its not that big of a deal you can set to be dhcp but set a static dns, not so sure on router? Could you go into your internet settings and look to see if that is an option. I know I can do it on my pfsense box, but not sure about that cisco - I do believe you can do that on 3rd party firmware. Maybe you might want to go that route? If you verify that they are not handing it out and can not get them too?

For example on my router

post-14624-0-21014800-1349297368.jpg

So with this checked box uses what it gets from dhcp, but if uncheck it can put in a list of dns for the router to use and just not pay attention to what is gotten from dhcp on its wan interface - I would look to see if your router has such an option, but I doubt it to be honest. 3rd party allow for it.

edit:

Just fire up wireshark on your client PC you have connected to the modem - then do a ipconfig /release and then renew and you should see your discover go out then the offer then the ack, etc.

Share this post


Link to post
Share on other sites

Posted

Well I would for starters do a sniff of the traffic as you get an IP to verify that they are not providing you dns -- this is going to be an option in the dhcp offer.

So for example here on my work box.

post-14624-0-17464400-1349296742_thumb.j

Its quite possible that they are in the offer and your router is just not taking them? Never heard of an ISP that does not provide DNS. So if they are not offering it in the dhcp offer - then I would for sure call them on it!

On a client its not that big of a deal you can set to be dhcp but set a static dns, not so sure on router? Could you go into your internet settings and look to see if that is an option. I know I can do it on my pfsense box, but not sure about that cisco - I do believe you can do that on 3rd party firmware. Maybe you might want to go that route? If you verify that they are not handing it out and can not get them too?

edit:

Just fire up wireshark on your client PC you have connected to the modem - then do a ipconfig /release and then renew and you should see your discover go out then the offer then the ack, etc.

You can set DNS servers on the EA4500 router but only in the DHCP options. By the looks of it, the routers interface itself doesn't use the DNS servers you set in the DHCP options but uses the servers provided by the ISP which is sent from the modem to the router.

Which is why when the router comes to check "ciscocloudconnect.com" or whatever site it needs to resolve for this Cisco "cloud" it returns as unavailable and the router is displaying no internet connection. So in a way the router has got an IP etc its got everything but the DNS servers.

So really I have two or possibly three options here

1) Tell my ISP somehow that I am not receiving any DNS servers provided by them

2) Tell Cisco a firmware update is needed so that the router checks by IP and not by resolving a domain name wether there is internet connection, or however they do it on there routers I don't know I can only guess this is what its going

and the 3rd option may well be, because my ISP has full control over this "SuperHub" firmware, it is so locked down you can't change the DNS yourself when you wish to use your own, I reckon that the reason why DNS servers are not been provided in Modem mode is because the DNS servers are in fact hard coded into the firmware of the SuperHub itself. (Virgin Media can send firmware updates out to the SuperHub whenever they want and it will automatically update once plugged in).

But really the root cause of this issue is not the router, not ciscos fault but in fact Virgin Media.

I can try the Wireshark thing but what difference is it going to make, if connecting directly to the SuperHub in Modem mode is not working, then something is clearly wrong, I can see that there are no DNS servers being set. I have never seen this happen ever and I can't come to terms with what has happened here.

I am going to try my best to tell Virgin Media what is happening here and let you know what the outcome is or If I need any additional help ill post in this thread but thanks for helping me, this has really made my mind explode today working this out.

Matt.

Share this post


Link to post
Share on other sites

Posted

"I can try the Wireshark thing but what difference is it going to make, i"

You will have PROOF that they are not offering you dns - and can call them on it. Just because your client or router is not showing you that it got them doesn't mean they are not handing them out. Your just assuming they are not until you look at what is actually in the dhcp offer.

You sure you can not set them in your internet settings -- yeah no **** your router should not be using what you setup in dhcp server for dns you hand to clients. Look in the internet settings, post the edit screen on here.

post-14624-0-87556000-1349298272.jpg

You forgot the simple option of just putting 3rd party firmware on your router, if supported - looking now that allows you to set the dns your router uses ;) Scratch that -- doesn't look like the EA4500 would ever be supported by dd-wrt, which more than likely rules out other 3rd party options as well. Sorry you bought such a crappy router. Your other option is to return the crap that does not support 3rd party and buy something that does ;)

Another option might be to go to standard firmware vs cloud crap

http://homesupport.cisco.com/en-us/support/routers/EA4500

Share this post


Link to post
Share on other sites

Posted

DNS IS provided in modem mode, I'm using one - have you got the latest firmware for the EA4500? Have you tried contacting Cisco?

VM Won't help you because they don't support 3rd Party Routers.

Share this post


Link to post
Share on other sites

Posted

"I can try the Wireshark thing but what difference is it going to make, i"

You will have PROOF that they are not offering you dns - and can call them on it. Just because your client or router is not showing you that it got them doesn't mean they are not handing them out. Your just assuming they are not until you look at what is actually in the dhcp offer.

You sure you can not set them in your internet settings -- yeah no **** your router should not be using what you setup in dhcp server for dns you hand to clients. Look in the internet settings, post the edit screen on here.

post-14624-0-87556000-1349298272.jpg

You forgot the simple option of just putting 3rd party firmware on your router, if supported - looking now that allows you to set the dns your router uses ;) Scratch that -- doesn't look like the EA4500 would ever be supported by dd-wrt, which more than likely rules out other 3rd party options as well. Sorry you bought such a crappy router. Your other option is to return the crap that does not support 3rd party and buy something that does ;)

Another option might be to go to standard firmware vs cloud crap

http://homesupport.c.../routers/EA4500

This is the options I get on the Internet Settings

BsGPd.png

None which apply to me other than Automatic Configuration right?

What is wrong with the EA4500 router, I have used DD-WRT in the past on routers and I just didn't want any of that, I just wanted a router, with nice WiFi speeds that I could setup and leave but this has been a complete nightmare and I don't blame Cisco but my ISP. It isn't Cisco or the Routers fault that my ISP "seems" to be not providing any type of DNS server.

DNS IS provided in modem mode, I'm using one - have you got the latest firmware for the EA4500? Have you tried contacting Cisco?

VM Won't help you because they don't support 3rd Party Routers.

I could plug my PC directly into the SuperHub on Modem Mode and just tell them I am plugged in directly and no DNS servers are being provided. and Yes I would of thought DNS servers would be provided in Modem Mode but from what I see I am not gettting any.

Yes I contacted Cisco too, but they couldn't figure out the issue either, other people use this same router and the SuperHub on Virgin Media and have no issues.

Share this post


Link to post
Share on other sites

Posted

Well seems like you got a path then -- if your pc is connected to your superhub in modem mode and you don't have dns - contact your ISP about that, maybe there is just something wrong the dhcp scope your getting and there is suppose to be dns - the other post suggest that is the case.

I would look at the dhcp offer just to be 100% sure they are not handing it out.

"I just didn't want any of that"

Didn't want any of what - features that actually make the hardware useful ;) True not everyone need or desires said features, but I would never buy a router hardware that is not supported by 3rd party firmware. Cuz you can be sure the maker is going to stop providing firmware update for this model as soon as they come out with the next model they want you to buy ;)

But if you can run 3rd party, you will have support and fixes, added features for years to come. Not just the 6 month window that maker feels they need to fix MAJOR problems until their next model comes out. You might not need the added feature set today, but what about next week or next month or 6 months from now when you want to do something a bit out of the standard box -- well oh ****, native firmware does not support that option.. Guess go buy a new router so I can do what I want..

So you get to pick dhcp and that its -- that is not very useful if you ask me. What if you DON"T what the router to use their dns server. What if you want to request a longer dhcp lease? Maybe a shorter one? So looks like for example if you want your clients to use your router as dns, but you want that forwarded to say opendns or googledns you don't have the option to do that.

I really could go on and on and on for pages and pages on limitations of native firmware for what is the most basic of functionality.

Share this post


Link to post
Share on other sites

Posted

Well seems like you got a path then -- if your pc is connected to your superhub in modem mode and you don't have dns - contact your ISP about that, maybe there is just something wrong the dhcp scope your getting and there is suppose to be dns - the other post suggest that is the case.

I would look at the dhcp offer just to be 100% sure they are not handing it out.

If i use router mode on the SuperHub again everything works fine and I have my old IP Address again, on connecting direct to the modem or on the EA4500 i get a new ip address I see at ipchicken.com, are IP Addresses given out based on the device mac address because If i use the clone mac address function and type in the SuperHub's mac address would that give me my old ip address, should I see if that works?

Share this post


Link to post
Share on other sites

Posted

yeah you could always run in double nat mode if what your saying is true and the dns is hardcoded into the superhub.

You lost me -- why do you want your old IP address back? What does your public IP address matter?

Share this post


Link to post
Share on other sites

Posted

EA4500 Doesn't support custom firmware IIRC as it uses a Marvell CPU unless the OpenWRT guys got around to it which I doubt...

Anyway if you connect your PC to your superhub that's in modem mode, reboot the superhub and have Windows try get an IP address and DNS automatically and it should work :p

Also yes you can clone your Superhub MAC to get your old ip back.

Share this post


Link to post
Share on other sites

Posted

yeah you could always run in double nat mode if what your saying is true and the dns is hardcoded into the superhub.

You lost me -- why do you want your old IP address back? What does your public IP address matter?

Because If I turn the SuperHub into Router mode everything else works, I don't know how it all works I am just guessing now and trying anything.

EA4500 Doesn't support custom firmware IIRC as it uses a Marvell CPU unless the OpenWRT guys got around to it which I doubt...

Anyway if you connect your PC to your superhub that's in modem mode, reboot the superhub and have Windows try get an IP address and DNS automatically and it should work :p

Also yes you can clone your Superhub MAC to get your old ip back.

No DNS is provided in Modem Mode and connected directly to my computer. Somethings proper f****d up here.

Share this post


Link to post
Share on other sites

Posted

So glad I stayed away from the EA---- line.

Who knows maybe the Modem is still thinking it's a router and since you put it in "Modem Mode" it's creating a wierd untrusted setup where the WAN IP and DNS is being filtered from the router. The modem assigns an internal IP to the router and refuses to pass on DNS. So the only way to resolve the problem is to set internal DNS on the router as well. I think a hard reset of both devices is in order. Hard reset the modem and enable "Modem Mode", then hard reset the router and hook it up. Could be a bad device or borked data in the modems memory.

Share this post


Link to post
Share on other sites

Posted

This is the biggest pc of **** router I've ever had..I had to get one cause my good dlink died one morning so I figured I'd run to walmart and grab a cheapo to use a few days while I ordered a Asus model to flash WWDRT on but meh I had so many damn issues it wasn't even funny.

They default on IPv6 and THERE IS NOBODY IN MY SIDE OF THE STATE that uses IPv6 yet so that was causing issues right out the gate. Then you had to turn off more defaulted ON features to get anything higher than 100K for wireless download speeds... that was stupid right.

Horrible router - I told the lady at Walmart when I returned it that every single one of them needs to be yanked off the shelves...and yes I flashed new firmware...that infact made it worse.

Share this post


Link to post
Share on other sites

Posted

I'm in here late but if you can get rid of the EA4500 and replace it with an E4200v1 (probably ebay as it's discontinued) like I have, you're opened up to the world of dd-wrt and other alternative fw. I've never had such a stable router!

1 person likes this

Share this post


Link to post
Share on other sites

Posted

I am connected wired to the router which is why I am so confused, is it possible that the "SuperHub" is not sending the IP to the Cisco router and the Cisco router is thinking its got not internet connectivity because the IP displays 0.0.0.0? I don't know how this stuff works but its acting strange

Just to make absolutely sure, you DID connect the cable from superhub to the "internet" port on the cisco, and not one of the lan ports right ? because if it was conected to the lan ports it woudl explain why the cisco don't have internet IP and why you can still onnect to the internet.

1 person likes this

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.