Sign in to follow this  
Followers 0
Gotenks98

Anyone get the media center for Win 8 to work yet?

12 posts in this topic

I been trying to find info on this so I can install the media center. I tried using the same product key I upgraded with earlier but that does not work for getting the media center. Any ideas on this?

Share this post


Link to post
Share on other sites

Who asked you to use the same product key? You need a different key to activate media center. Request one here:

http://windows.micro...8/feature-packs

I have also tried this and its been 48 hours and got nothing so far.

Share this post


Link to post
Share on other sites

It may take a couple of days to get your key . Mine did .Media Center working just fine .

Share this post


Link to post
Share on other sites

Yup my key finally arrived. It isn't quick getting to you but it will get to you.

1 person likes this

Share this post


Link to post
Share on other sites

Waiting for my Media Center key. In the meantime, XBMC runs just fine on Win8. streamed video, DVDs, you name it; it plays. I've never been impressed by Media Center in the past, but I'm willing to give the new version a try once I can install it.

Share this post


Link to post
Share on other sites

got mine late last night. Thanks for the help.

1 person likes this

Share this post


Link to post
Share on other sites

Waiting for my Media Center key. In the meantime, XBMC runs just fine on Win8. streamed video, DVDs, you name it; it plays. I've never been impressed by Media Center in the past, but I'm willing to give the new version a try once I can install it.

Does XBMC interface with the IR Receiver and remote?

Share this post


Link to post
Share on other sites

I still haven't received my key yet. :(

Share this post


Link to post
Share on other sites

my mediac center key took about 3 minutes to get to me, just need to reformat and install everything from scratch

Share this post


Link to post
Share on other sites

It may take a couple of days to get your key . Mine did .Media Center working just fine .

Same here - in fact, mine arrived earlier this afternoon (though I requested it last week).

It took three reboots for it to fully kick in; however, that is likely due to a dual-boot with Windows Server 2012 (which is the default).

I'm waiting for Sandy to go away before physically reinstalling my HDTV Wonder (I'm twenty miles due S. of Washington, DC - hence in danger of power failure over the next 24 hours).

However, I'm as legal as da eagle.....:)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.