Jump to content
Sign in to follow this  
Followers 0

12.10 ubuntu hates me

14 posts in this topic

Posted

so i download install 12.10 everything installs fine no troubles . run the updates fine then BOOM

Comwiz i think thats what its called starts crashing non stop ( i have not updated my video card drivers yet )


so i can do nothing because of the constant crashing ... the one and only time i did update my video drivers ( on a previous attempt ) unity would not even load after i changed drivers O.o

12.04 runs perfectly

so im forced to go back toi winblows 7 but want to run the newest ubuntu

Share this post


Link to post
Share on other sites

Posted

temporarily you could try installing a desktop that doesn't require compiz. sudo apt-get install gnome-panel, and then log into the gnome (no effects) session. What video card is it?
1 person likes this

Share this post


Link to post
Share on other sites

Posted

If compiz is crashing then its likely a video driver problem. Its likely that you don't have any problems with Ubuntu 12.04 because you are running Unity 2D, which doesn't use compiz. Unfortunately, Unity 2D no longer exists in Ubuntu 12.10. One solution is to use another desktop environment, like ViperAFK suggested, but its possible that you could get Unity working with the correct driver (which would give you better graphics performance overall).

If you post the output of the following commands we may be able to help you identify the problem and setup the right driver. (If you can't login normally, start Ubuntu in recovery mode and drop to a root shell from the recovery menu.)
[CODE]
$ sudo lshw -C video
$ tail /var/log/Xorg.0.log
[/CODE]

Also, you might find [url="http://www.neowin.net/forum/topic/1115461-minecraft-in-ubuntu-1210/"]this thread[/url] somewhat related. It doesn't discuss your problem specifically, but it may help you to understand [i]some[/i] of the concepts perpendicular to it.
1 person likes this

Share this post


Link to post
Share on other sites

Posted

[quote name='ViperAFK' timestamp='1351638647' post='595285921']
temporarily you could try installing a desktop that doesn't require compiz. sudo apt-get install gnome-panel, and then log into the gnome (no effects) session. What video card is it?
[/quote]


its a nvidia gforce gts 360m cuda 1g

[quote name='xorangekiller' timestamp='1351640897' post='595286005']
If compiz is crashing then its likely a video driver problem. Its likely that you don't have any problems with Ubuntu 12.04 because you are running Unity 2D, which doesn't use compiz. Unfortunately, Unity 2D no longer exists in Ubuntu 12.10. One solution is to use another desktop environment, like ViperAFK suggested, but its possible that you could get Unity working with the correct driver (which would give you better graphics performance overall).

If you post the output of the following commands we may be able to help you identify the problem and setup the right driver. (If you can't login normally, start Ubuntu in recovery mode and drop to a root shell from the recovery menu.)
[CODE]
$ sudo lshw -C video
$ tail /var/log/Xorg.0.log
[/CODE]

Also, you might find [url="http://www.neowin.net/forum/topic/1115461-minecraft-in-ubuntu-1210/"]this thread[/url] somewhat related. It doesn't discuss your problem specifically, but it may help you to understand [i]some[/i] of the concepts perpendicular to it.
[/quote]

thanks ill give this a shot

Share this post


Link to post
Share on other sites

Posted

Fedora would accept you ;)

Share this post


Link to post
Share on other sites

Posted

Good news! According to the [url="http://nouveau.freedesktop.org/wiki/CodeNames"]nouvea wiki[/url] your GT215 is supported. There are just a few packages that you will need to install to get full graphics acceleration. You may do this via a root shell from recovery, like I mentioned before, if you need to.

[CODE]
$ sudo apt-get install xserver-xorg-video-nouveau libdrm-nouveau1a linux-firmware-nonfree nouveau-firmware libgl1-mesa-dri-experimental libgl1-mesa-glx
[/CODE]

[b]Edit:[/b] My last post in this thread was just instructing you to get diagnostic information. Try my suggestions in this post first. If it doesn't resolve your issue, then go ahead and follow my instructions in the last post to get more specific details.

Share this post


Link to post
Share on other sites

Posted

[quote name='xorangekiller' timestamp='1351656614' post='595286493']
Good news! According to the [url="http://nouveau.freedesktop.org/wiki/CodeNames"]nouvea wiki[/url] your GT215 is supported. There are just a few packages that you will need to install to get full graphics acceleration. You may do this via a root shell from recovery, like I mentioned before, if you need to.

[CODE]
$ sudo apt-get install xserver-xorg-video-nouveau libdrm-nouveau1a linux-firmware-nonfree nouveau-firmware libgl1-mesa-dri-experimental libgl1-mesa-glx
[/CODE]

[b]Edit:[/b] My last post in this thread was just instructing you to get diagnostic information. Try my suggestions in this post first. If it doesn't resolve your issue, then go ahead and follow my instructions in the last post to get more specific details.
[/quote]


hey thanks for work ! but i have a gforce GTS 360M would the above command still work ?

Share this post


Link to post
Share on other sites

Posted

[quote name='(Spork)' timestamp='1351715758' post='595287945']
hey thanks for work ! but i have a gforce GTS 360M would the above command still work ?
[/quote]

Indeed. The command I posted is actually card agnostic; it will work for any nVidia graphics card that is supported by the open-source nouveau graphics driver. Also, if you look at the link to the nouveau wiki that I posted, you will see a list of nVidia's official names for each card paired with the nouveau code names. (Which makes sense since the code name identifies the GPU, which is what driver is actually concerned with, not the marketing designation.)

[quote]
[b]Code Name: [/b]NVA3 (GT215)
[b]Official Name:[/b] GeForce GT (240, 320, 335M), GTS (250M, 260M, 350M, 360M)
Quadro FX 1800M
[/quote]
1 person likes this

Share this post


Link to post
Share on other sites

Posted

[quote name='xorangekiller' timestamp='1351640897' post='595286005']
If compiz is crashing then its likely a video driver problem. Its likely that you don't have any problems with Ubuntu 12.04 because you are running Unity 2D, which doesn't use compiz. Unfortunately, Unity 2D no longer exists in Ubuntu 12.10. One solution is to use another desktop environment, like ViperAFK suggested, but its possible that you could get Unity working with the correct driver (which would give you better graphics performance overall).

If you post the output of the following commands we may be able to help you identify the problem and setup the right driver. (If you can't login normally, start Ubuntu in recovery mode and drop to a root shell from the recovery menu.)
[CODE]
$ sudo lshw -C video
$ tail /var/log/Xorg.0.log
[/CODE]

Also, you might find [url="http://www.neowin.net/forum/topic/1115461-minecraft-in-ubuntu-1210/"]this thread[/url] somewhat related. It doesn't discuss your problem specifically, but it may help you to understand [i]some[/i] of the concepts perpendicular to it.
[/quote]


[CODE]
tesso@PITA:~$ sudo lshw -C video
*-display UNCLAIMED
description: VGA compatible controller
product: GT215 [GeForce GTS 360M]
vendor: NVIDIA Corporation
physical id: 0
bus info: pci@0000:01:00.0
version: a2
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress vga_controller bus_master cap_list
configuration: latency=0
resources: memory:f2000000-f2ffffff memory:e0000000-efffffff memory:f0000000-f1ffffff ioport:d000(size=128) memory:f3000000-f307ffff
[/CODE]

and

[CODE]
tesso@PITA:~$ tail /var/log/Xorg.0.log
[ 11.291] (**) synaptics: SynPS/2 Synaptics TouchPad: MaxSpeed is now 1.75
[ 11.291] (**) synaptics: SynPS/2 Synaptics TouchPad: AccelFactor is now 0.038
[ 11.291] (**) SynPS/2 Synaptics TouchPad: (accel) keeping acceleration scheme 1
[ 11.291] (**) SynPS/2 Synaptics TouchPad: (accel) acceleration profile 1
[ 11.291] (**) SynPS/2 Synaptics TouchPad: (accel) acceleration factor: 2.000
[ 11.291] (**) SynPS/2 Synaptics TouchPad: (accel) acceleration threshold: 4
[ 11.291] (--) synaptics: SynPS/2 Synaptics TouchPad: touchpad found
[ 11.291] (II) config/udev: Adding input device SynPS/2 Synaptics TouchPad (/dev/input/mouse1)
[ 11.292] (**) SynPS/2 Synaptics TouchPad: Ignoring device from InputClass "touchpad ignore duplicates"
[ 27.157] (II) XKB: generating xkmfile /var/lib/xkb/server-8C3648A5FD728529D869F46730BE1BC287DB231C.xkm
[/CODE]


and the error i get from the last command line you posted

[CODE]
tesso@PITA:~$ sudo apt-get install xserver-xorg-video-nouveau libdrm-nouveau1a linux-firmware-nonfree nouveau-firmware libgl1-mesa-dri-experimental libgl1-mesa-glx
[sudo] password for tesso:
Reading package lists... Done
Building dependency tree
Reading state information... Done
Package libgl1-mesa-dri-experimental is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
However the following packages replace it:
libgl1-mesa-dri
E: Unable to locate package linux-firmware-nonfree
E: Unable to locate package nouveau-firmware
E: Package 'libgl1-mesa-dri-experimental' has no installation candidate
[/CODE]

Share this post


Link to post
Share on other sites

Posted

OK, sorry about that. I forgot a couple of things. Since this is a clean install of Ubuntu, you don't have any of the extra repositories enabled (which are required for some of the packages I listed). Try the following:

[CODE]
$ sudo apt-add-repository universe
$ sudo apt-add-repository multiverse
$ sudo apt-get update
$ sudo apt-get install xserver-xorg-video-nouveau libdrm-nouveau1a libdrm-nouveau2 linux-firmware-nonfree nouveau-firmware libgl1-mesa-dri-experimental libgl1-mesa-glx
[/CODE]

[b]Edit:[/b] If you can login normally and would prefer to add the repositories graphically, open [i]Ubuntu Software Center[/i] and select [i]Edit->Software Sources...[/i], then check the boxes for "Community maintained free and open-source software (universe)" and "Software restricted by copyright or legal issues (multiverse)" in the [i]Software Sources[/i] window. After you have done that you can resume my instructions above from 'sudo apt-get update'.

Share this post


Link to post
Share on other sites

Posted

ok thats finally done ( my connection is crap tonight ) then i just select the driver ?

Share this post


Link to post
Share on other sites

Posted

After you reboot the driver should be selected automatically. You can verify that nouveau is actually in use using [i]lshw[/i].

[CODE]
$ sudo lshw -C video | grep config
configuration: driver=nouveau latency=0
[/CODE]

You should get similar output to the above. If you have 'driver=nouveau' then you are using the correct driver. Hopefully you don't experience any more issues.

Share this post


Link to post
Share on other sites

Posted

[quote name='xorangekiller' timestamp='1351734088' post='595288599']
After you reboot the driver should be selected automatically. You can verify that nouveau is actually in use using [i]lshw[/i].

[CODE]
$ sudo lshw -C video | grep config
configuration: driver=nouveau latency=0
[/CODE]

You should get similar output to the above. If you have 'driver=nouveau' then you are using the correct driver. Hopefully you don't experience any more issues.
[/quote]


for some reason it did not set it for me i get this


tesso@PITA:~$ sudo lshw -C video | grep configuration
configuration: latency=0

Share this post


Link to post
Share on other sites

Posted

In that case, you can try to force X to load nouveau since it is not being autodetected. Boot into recovery, drop to a root shell, and try the following to get an initial X configuration file.

[CODE]
$ Xorg -configure
$ nano /etc/X11/xorg.conf
Section "Device"
Identifier "GeForce GTS 360M"
Driver "nouveau"
EndSection
$ reboot
[/CODE]

The code above is an example of the minimum that you must have in your [i]xorg.conf[/i]. Its likely that 'Xorg -configure' will add more than just that. The rest is safe to leave, but I would remove everything other than the "Device" section since it is unnecessary. If you have no "Device" section in [i]xorg.conf[/i], add the one the I posted above; if you have a "Device" section that does not implicate the nouveau driver, replace its driver line with the one above.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.