Sign in to follow this  
Followers 0

RAID Array Stripe Alignment affect Performance

2 posts in this topic

Just found out that RAID arrays can have alignment issues, separate from the well known 4K sector issue.

I suspect it to be the cause of slow transfer rates on my Adaptec RAID 3805 RAID6 (5x Hitachi 2TB 7200 RPM) array.

Nodesoft Disk Bench only gets 100MB/s writes and 80MB/s reads (these figures are more in line my Windows File Copy performance)

But I don't know why the following benchmarks report so much higher






I think I have confirmed that my array is not aligned, but am not sure.

State of Array:



Alignment Calculator:


Alignment Checking Script:

Device ID: Disk #2, Partition #0


Total Volume Size: 5 TB

Starting Offset: 134235136 (131089 KB)

Partition Alignment: ** NOT ALIGNED!! **

VM Check Alignment Tool:


My Calculation:

Formula: ((Partition offset) * (Disk sector size)) / (Stripe unit size)


Partition off set = 134235136b

Disk sector size = 512b

stripe unit size = 262144b

block size = 512b

answer = 262178

This is an integer, thus indicates the array is aligned. But this conflicts with the conclusions of the other calculators, so WTF? I have no idea what I'm doing lol :weep:

Array Info:

Adaptec RAID 3805 RAID6

HD 5x (Hitachi 2TB) Sector Size: 512Bytes

Stripe Size: 256K

Disk Format: GPT

Windows Disc mode, Basic or Dynamic: Basic

Share this post

Link to post
Share on other sites

I think you might be right as a GPT the Partition Starting Offset should be 135,266,304 bytes.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.