Jump to content

5 posts in this topic

Posted

hi ! I have tried to edit my vsftpd.conf so many times now ... I have tried using "vi", "gedit" both user and root I have chmod'ed the file to allow full read and write so open every tom, dick or harry can see it... but I cannot for the life of me edit it! every time i open it with vi (the only thing i have sucessfully opened it with)

I messes up with the keyboard .... and when i try to use gedit it tells me to F my self

Share this post


Link to post
Share on other sites

Posted

use nano - so 'nano vsftpd.conf'.

Go here to learn how to use vi - [url="http://vim-adventures.com/"]http://vim-adventures.com/[/url]

[b]edit - more info[/b]:

to use vim you need to browse to the text you want using the hjkl keys and then switch to input mode, edit the text, switch out of input mode and then write the file.

For quick edits nano is easier - ctrl+w to find some text. ctrl+x to close nano and save the file.

for ubuntu/debian: apt-get install nano
for redhat/fedora/cent: yum install nano

Share this post


Link to post
Share on other sites

Posted

[quote name='BaLdMoNkEy' timestamp='1352860496' post='595318712']
use nano - so 'nano vsftpd.conf'.

Go here to learn how to use vi - [url="http://vim-adventures.com/"]http://vim-adventures.com/[/url]

[b]edit - more info[/b]:

to use vim you need to browse to the text you want using the hjkl keys and then switch to input mode, edit the text, switch out of input mode and then write the file.

For quick edits nano is easier - ctrl+w to find some text. ctrl+x to close nano and save the file.

for ubuntu/debian: apt-get install nano
for redhat/fedora/cent: yum install nano
[/quote]

ahhh thank you I no longer wish to shoot the server :D

[quote name='BaLdMoNkEy' timestamp='1352860496' post='595318712']
use nano - so 'nano vsftpd.conf'.

Go here to learn how to use vi - [url="http://vim-adventures.com/"]http://vim-adventures.com/[/url]

[b]edit - more info[/b]:

to use vim you need to browse to the text you want using the hjkl keys and then switch to input mode, edit the text, switch out of input mode and then write the file.

For quick edits nano is easier - ctrl+w to find some text. ctrl+x to close nano and save the file.

for ubuntu/debian: apt-get install nano
for redhat/fedora/cent: yum install nano
[/quote]

wouldnt be able to tell me how to get this ftp working would ya haha ? I have turned off annoymous ftp and I turnned on SFTP and I thought I turned on authentication FTP as well ... but my ftp client still is getting refused ... just differently...well actually i got the SFTP working just not the ftp but eh who needs that lol :p

Share this post


Link to post
Share on other sites

Posted

Turn on logging on vsftpd and then tail or nano /var/log/vsftpd.log.

The log will tell you what is going wrong.

Also make sure you have allowed ftp in your firewall.

Share this post


Link to post
Share on other sites

Posted

Files in the /etc folder are usually protected and only editable by root. If your OS variant supports [b]sudo[/b], you should toss that in before your editor on the command line... like:

sudo nano /etc/vsftpd.conf

otherwise, use [b]su[/b] first, like:

su
nano /etc/vsftpf.conf
exit


Here, I have used nano as an editor, you could use vi, emacs, whatever, and the exit after the [b]su[/b] is because it starts a shell in the super-user account.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.