Jump to content



Photo

Windows 8- Run everything as Administrator


  • Please log in to reply
52 replies to this topic

#1 chrisd89

chrisd89

    Neowinian

  • Joined: 19-November 12

Posted 19 November 2012 - 21:36

Hi,

I am using Windows 8. I have turned off User Account Control, but it seems that programs that don't request to be run with Administrative privileges (and quite a few, unfortunately badly written legacy programs don't) are still run as a Standard User. I therefore have to fiddle around, e.g. running the programs in compatibility mode, or in the case of MSIs, tricking the programs into running as Administrator by launching an elevated command prompt and running it from that.

I really don't care for this security feature and I would like absolutely every program I ever run to run as Administrator. I know and understand the security risks of doing this, and I know the programs are "to blame", but this computer runs a lot of legacy music software for which updates are not available and is not connected to the internet - I just need things to work.

With this in mind, would anyone who understands Windows 8's user model better than I do please explain how to go about doing this. I note that the built-in Administrator account does exactly what I want - but I would like to same from my normal account ideally.

My account is a member of "Administrators".

ANy tips? Thanks so much!!

CHris


#2 AngelGraves13

AngelGraves13

    Neowinian

  • Joined: 05-September 07
  • Location: Los Angeles, CA
  • OS: Windows 8.1

Posted 19 November 2012 - 21:42

First thing I do after installing Windows is disable User Account Control. It's completely useless if you know what you're doing, and it's annoying to allow a program you trust every single time you launch it. Now if it had a "remember this choice" option then I might leave it on.

#3 OP chrisd89

chrisd89

    Neowinian

  • Joined: 19-November 12

Posted 19 November 2012 - 21:48

Hi,

Thanks for your reply. In Windows 7, this was definitely the case; when you turned off User Account Control, everything ran as Administrator.

But things seem different in Windows 8.

As a test, drag the slider for User Account Control down to the bottom, and restart. Then open the command prompt. Note that even though UAC is off, it does not say "Administrator: Command Prompt" in the title menu.

However, right-click and select "Run As Administrator", and it does.

It is like they have changed it from being "UAC is Off" (as it was in Windows 7) to "UAC Silent Mode" (which was a little known feature which basically did the same as clicking "Yes" to the UAC popups for you if they appeared). It's like that's been made the default, so if a program doesn't itself ask to be run elevated, it never does get run elevated. But I really really want it properly off, so programs get run elevated even if they don't ask to be.

If you see what I mean!

Thanks!!

Chris

#4 Blimpo

Blimpo

    Ricochet

  • Joined: 11-January 05
  • Location: Orlando, FL

Posted 19 November 2012 - 22:29

I'd also like to know how to do this..

I play UT2004 and what I noticed from switching to Windows 8 is that if I don't run the game as admin, and I make changes to my settings, server favorites, etc.. my config files (ini's) are updated and saved to "C:\Users\{Username}\AppData\Local\VirtualStore\UT2004", instead of being directly updated/saved in the the directory where the game is installed.

#5 Dot Matrix

Dot Matrix

    Neowinian Senior

  • Tech Issues Solved: 7
  • Joined: 14-November 11
  • Location: Upstate New York
  • OS: Windows 8.1
  • Phone: Nokia Lumia 920

Posted 19 November 2012 - 22:32

You cannot disable UAC in Windows 8. There is no option to do so.

#6 ITFiend

ITFiend

    ハッピー

  • Joined: 13-October 09
  • Location: Galactic Sector ZZ9 Plural Z Alpha
  • OS: Windows Server 2012 R2, Windows 8.1
  • Phone: Windows Phone 8.1

Posted 19 November 2012 - 22:34

It is like they have changed it from being "UAC is Off" (as it was in Windows 7) to "UAC Silent Mode"


It looks like that is exactly the case. The older method of disabling UAC via the slider no longer works. You must edit the registry now. You may not have noticed, but at no point does the UserAccountControlSetting.exe actually ask you for a reboot in Windows 8 when you move the slider to the bottom.


So don't even bother with the slider. Just run PowerShell as Administrator and paste the following to disable UAC:

Set-ItemProperty -Path "HKLM:\Software\Microsoft\Windows\CurrentVersion\Policies\System" -Name "EnableLUA" -Value "0"
shutdown -r -t 0


#7 TPreston

TPreston

    Neowinian Senior

  • Tech Issues Solved: 1
  • Joined: 18-July 12
  • Location: Ireland
  • OS: Windows 8.1 Enterprise & Server 2012R2/08R2 Datacenter
  • Phone: Nokia Lumia 1520

Posted 19 November 2012 - 22:36

Posted Image


Just do the above, Silently elevate admins and deny guests and users

#8 nekrosoft13

nekrosoft13

    NeKroSoft inc.

  • Joined: 01-November 01
  • Location: IL
  • OS: Windows 7

Posted 19 November 2012 - 22:40

just FYI that will also disable the metro store, can't install anything new with UAC off

Posted Image


Just do the above, Silently elevate admins and deny guests and users


were is that? can you post screenshot?

#9 AngelGraves13

AngelGraves13

    Neowinian

  • Joined: 05-September 07
  • Location: Los Angeles, CA
  • OS: Windows 8.1

Posted 19 November 2012 - 22:46

Well then I suppose I have UAC set to silent. It's good enough for me.

#10 Blimpo

Blimpo

    Ricochet

  • Joined: 11-January 05
  • Location: Orlando, FL

Posted 19 November 2012 - 22:48

Run PowerShell as Administrator and paste the following to disable UAC:

Set-ItemProperty -Path "HKLM:\Software\Microsoft\Windows\CurrentVersion\Policies\System" -Name "EnableLUA" -Value "0"
shutdown -r -t 0


Thank you, this worked for me :)

#11 TPreston

TPreston

    Neowinian Senior

  • Tech Issues Solved: 1
  • Joined: 18-July 12
  • Location: Ireland
  • OS: Windows 8.1 Enterprise & Server 2012R2/08R2 Datacenter
  • Phone: Nokia Lumia 1520

Posted 19 November 2012 - 22:49

just FYI that will also disable the metro store, can't install anything new with UAC off



were is that? can you post screenshot?


group policy or local group policy > Computer configuration > policys > windows >security > local

Silently elevates and dosnt brake the windows store, Good enough for a home network (Y)

#12 HawkMan

HawkMan

    Neowinian Senior

  • Tech Issues Solved: 4
  • Joined: 31-August 04
  • Location: Norway
  • Phone: Noka Lumia 1020

Posted 19 November 2012 - 22:52

First thing I do after installing Windows is disable User Account Control. It's completely useless if you know what you're doing, and it's annoying to allow a program you trust every single time you launch it. Now if it had a "remember this choice" option then I might leave it on.


You second statement invalidates your first statement.

#13 nekrosoft13

nekrosoft13

    NeKroSoft inc.

  • Joined: 01-November 01
  • Location: IL
  • OS: Windows 7

Posted 19 November 2012 - 23:00

group policy or local group policy > Computer configuration > policys > windows >security > local

Silently elevates and dosnt brake the windows store, Good enough for a home network (Y)


thanks will look for it, that can actually make windows 8 more user friendly

#14 AngelGraves13

AngelGraves13

    Neowinian

  • Joined: 05-September 07
  • Location: Los Angeles, CA
  • OS: Windows 8.1

Posted 19 November 2012 - 23:10

You second statement invalidates your first statement.


I said I don't need it and it's annoying, but if it doesn't annoy me then I don't care if it is on or not. What's hard to understand about that?

#15 ITFiend

ITFiend

    ハッピー

  • Joined: 13-October 09
  • Location: Galactic Sector ZZ9 Plural Z Alpha
  • OS: Windows Server 2012 R2, Windows 8.1
  • Phone: Windows Phone 8.1

Posted 20 November 2012 - 00:09

Thank you, this worked for me :)


Actually, as it turns out, what I posted will also break the Microsoft Store. I practically never disable UAC and was unaware of this limitation.

If you entered my registry change to disable UAC, re-enable it with the following command:

PowerShell as Administrator (This requires a restart)
Set-ItemProperty -Path "HKLM:\Software\Microsoft\Windows\CurrentVersion\Policies\System" -Name "EnableLUA" -Value "1" #Default value is 1

shutdown -r -t 0


To enable automatic silent UAC elevation for administrators without breaking the Microsoft Store you should do the following instead.

PowerShell as Administrator (This takes effect immediately)
#The following is equal to the Security Policy "User Account Control: Behavior of the elevation prompt for administrators in Admin Approval Mode" = "Elevate without prompting"
Set-ItemProperty -Path "HKLM:\Software\Microsoft\Windows\CurrentVersion\Policies\System" -Name "ConsentPromptBehaviorAdmin" -Value "0" #Default value is 2

#The following is equal to the Security Policy "User Account Control: Allow UIAccess applications to prompt for elevation without using the secure dekstop" = "Enabled"
Set-ItemProperty -Path "HKLM:\Software\Microsoft\Windows\CurrentVersion\Policies\System" -Name "EnableUIADesktopToggle" -Value "1" #Default value is 0