Jump to content



Photo
nvidia dual monitor multiple monitors ubuntu ubuntu 12.10

  • Please log in to reply
6 replies to this topic

#1 Pubudu Kodikara

Pubudu Kodikara

    Neowinian

  • Joined: 16-April 12

Posted 23 November 2012 - 02:56

I have just setup a dual monitor system with a 23 inch LED monitor and a 19 inch LCD monitor. The 23 inch one is connected through HDMI. The 19 inch one is connected to the analogue port of the same GPU (Nvidia Geforce 210).

In Ubuntu 12.10, after installing Nvidia drivers, the 23 inch monitor works fine but the 19 inch monitor got a very low resolution. When I set the correct resolution, the desktop goes out of the screen. Also I feel a small lag in animations on the 23 inch monitor. Things work fine under Windows 8.... My questions are...
  • How to fix the resolution in the small monitor?
  • What is causing the lag and how to fix it?



#2 Mindovermaster

Mindovermaster

    Neowinian Senior

  • Tech Issues Solved: 10
  • Joined: 25-January 07
  • Location: /USA/Wisconsin/
  • OS: Debian Jessie
  • Phone: HTC ONE V

Posted 23 November 2012 - 03:35

Are you using the default DE, Unity? There's something, oh, I cant remember... Let me check for you, unless someone beats me to it.. :p

#3 OP Pubudu Kodikara

Pubudu Kodikara

    Neowinian

  • Joined: 16-April 12

Posted 23 November 2012 - 03:51

Are you using the default DE, Unity? There's something, oh, I cant remember... Let me check for you, unless someone beats me to it.. :p


Yep :) Im using Unity! Please help :D

#4 Xilo

Xilo

    Neowinian Senior

  • Joined: 28-May 04
  • Location: Austin, TX

Posted 23 November 2012 - 05:10

Yep :) Im using Unity! Please help :D

Unity seem to have horrible dual screen support. From my experiences, it's actually regressed since Unity was made default and Gnome 2 abandoned.

#5 OP Pubudu Kodikara

Pubudu Kodikara

    Neowinian

  • Joined: 16-April 12

Posted 23 November 2012 - 05:29

Unity seem to have horrible dual screen support. From my experiences, it's actually regressed since Unity was made default and Gnome 2 abandoned.


I even tried Linux Mint 14 which have cinnamon instead... In Mint also I face the same issue :(

#6 OP Pubudu Kodikara

Pubudu Kodikara

    Neowinian

  • Joined: 16-April 12

Posted 23 November 2012 - 05:41

Here's my xorg.conf :


# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 310.14  (buildd@komainu)  Tue Oct 23 23:48:50 UTC 2012


Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "0"
EndSection

Section "Files"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"

    # HorizSync source: edid, VertRefresh source: edid
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "CRT-1"
    HorizSync       30.0 - 81.0
    VertRefresh     50.0 - 75.0
    Option         "DPMS"
EndSection

Section "Monitor"
    Identifier     "Monitor1"
    VendorName     "Unknown"
    ModelName      "Samsung S23B370"
    HorizSync       30.0 - 81.0
    VertRefresh     50.0 - 75.0
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce 210"
EndSection

Section "Device"
    Identifier     "Device1"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce 210"
    BusID          "PCI:1:0:0"
    Screen          1
EndSection

Section "Screen"

# Removed Option "metamodes" "DFP: nvidia-auto-select +0+0, CRT: 1360x768 +1920+0"
# Removed Option "metamodes" "DFP: nvidia-auto-select +0+0, CRT: 1360x768_60 +1920+0"
# Removed Option "metamodes" "CRT: 1360x768_60 +0+0"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "Stereo" "0"
    Option         "nvidiaXineramaInfoOrder" "DFP-1"
    Option         "metamodes" "CRT: nvidia-auto-select +1920+0, DFP: nvidia-auto-select +0+0"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

Section "Screen"
    Identifier     "Screen1"
    Device         "Device1"
    Monitor        "Monitor1"
    DefaultDepth    24
    Option         "Stereo" "0"
    Option         "nvidiaXineramaInfoOrder" "DFP-1"
    Option         "metamodes" "DFP: nvidia-auto-select +0+0"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection


#7 OP Pubudu Kodikara

Pubudu Kodikara

    Neowinian

  • Joined: 16-April 12

Posted 23 November 2012 - 07:44

Just found the issue... Its not a software problem... Its the cable! If some one have this same issue... If the second display is not detected or its detected as a CRT... Change the VGA cable and check. It fixed my issue :)

Thanks for everyone who posted here :D