Jump to content
  • 0

Question

Posted

So after a long while of not touching Linux, I am installing the newest Ubuntu. Come to find out, my video card, an AMD 4890 is now a legacy card and Xorg in 12.10 no longer supports these drivers. I've found information stating the way to get it working is to downgrade from Xorg 1.13 to 1.12.4.
[url="https://launchpad.net/~makson96/+archive/fglrx"]https://launchpad.ne.../+archive/fglrx[/url]
Is this really the best option?
Should I just go with 12.04?
Why should I rely on some guys repository instead of figuring out how to downgrade it myself and install the drivers provided by AMD?

Share this post


Link to post
Share on other sites

6 answers to this question

  • 0

Posted

I'd stick with 12.04 in your case, since the drivers should work there without workarounds, and its an LTS that is supported for a long time.

Its not xorg that doesn't support the card anymore, its that AMD's "legacy" driver doesn't support that version of xorg.

Share this post


Link to post
Share on other sites
  • 0

Posted

I'm in the same boat. It's really not even that 12.10 is all that much better than 12.04 anyway. I mean 12.04 is supported until April 2017, so that's nice. 12.10 is supported something like 18 months...?

I tried 12.10, but had the graphics problems (as Viper says, not a Linux issue but rather an AMD issue). 12.04 was nice to return to. None of that Amazon pimping in the dash either. :D

Share this post


Link to post
Share on other sites
  • 0

Posted

12.04 is a very solid release (once you install all the updates). I've found ubuntu 12.10 to be fairly buggy in general anyway. (although I found mint 14 which is based on 12.10 to be pretty stable).

Share this post


Link to post
Share on other sites
  • 0

Posted

The Radeon HD 4890 is supported fairly well by the open-source [i]radeon[/i] driver. (Check the [url="http://www.x.org/wiki/RadeonFeature"]official status page[/url] for more detailed information.) Unless you have some specific reason for running the [i]fglrx[/i] driver instead, I recommend that you run [i]radeon[/i]. Downgrading X in-place is generally a bad idea. I'm with everyone else who has said that the best thing to do is downgrade to Ubuntu 12.04 if you absolutely must use [i]fglrx[/i].

Follow the instructions below to remove [i]fglrx[/i] and revert to [i]radeon[/i].

[CODE]
# Remove the proprietary AMD graphics driver.
sudo apt-get purge $(dpkg --get-selections | awk '{if($1 ~ /fglrx/) print $1}')

# Backup and remove your X configuration file (if one exists).
[ -e /etc/X11/xorg.conf ] && sudo mv /etc/X11/xorg.conf /etc/X11/xorg.conf.fglrx.0

# Install the necessary packages necessary to get full graphical acceleration.
# Some (or all) of these packages may already be installed.
sudo apt-get install libgl1-mesa-dri-experimental libgl1-mesa-glx linux-firmware-nonfree xserver-xorg-video-radeon

# Reboot to apply changes.
sudo reboot
[/CODE]
1 person likes this

Share this post


Link to post
Share on other sites
  • 0

Posted

[quote name='xorangekiller' timestamp='1354407798' post='595362570']
The Radeon HD 4890 is supported fairly well by the open-source [i]radeon[/i] driver. (Check the [url="http://www.x.org/wiki/RadeonFeature"]official status page[/url] for more detailed information.) Unless you have some specific reason for running the [i]fglrx[/i] driver instead, I recommend that you run [i]radeon[/i]. Downgrading X in-place is generally a bad idea. I'm with everyone else who has said that the best thing to do is downgrade to Ubuntu 12.04 if you absolutely must use [i]fglrx[/i].

Follow the instructions below to remove [i]fglrx[/i] and revert to [i]radeon[/i].

[CODE]
# Remove the proprietary AMD graphics driver.
sudo apt-get purge $(dpkg --get-selections | awk '{if($1 ~ /fglrx/) print $1}')

# Backup and remove your X configuration file (if one exists).
[ -e /etc/X11/xorg.conf ] && sudo mv /etc/X11/xorg.conf /etc/X11/xorg.conf.fglrx.0

# Install the necessary packages necessary to get full graphical acceleration.
# Some (or all) of these packages may already be installed.
sudo apt-get install libgl1-mesa-dri-experimental libgl1-mesa-glx linux-firmware-nonfree xserver-xorg-video-radeon

# Reboot to apply changes.
sudo reboot
[/CODE]
[/quote]
Thanks. I will probably try this but I have already gone to Ubuntu 12.04 from other's recommendations and mention of stability being better. Will probably install on another HDD and see if I can get it working with what you suggested. Only reason I would need fglrx is for games using PlayOnLinux. Will see how it works out.

Share this post


Link to post
Share on other sites
  • 0

Posted

the problem with the legacy driver and ubuntu 12.10 (and latest fedora and other distros as well for that matter) is that the driver doesn't support the latest version of xorg-server yet, thus causing a crash at boot

so if you can revert xorg-server to 1.12 the official amd legacy driver should work correctly

so yeah, the info you found on launchpad will be the best bet of getting it to work on ubuntu 12.10

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.