Jump to content



Photo

Skydrive App Not Supported on Snow Leopard!

skydrive

  • Please log in to reply
7 replies to this topic

#1 Scorbing

Scorbing

    Halo Master

  • Joined: 02-December 01
  • Location: Florida
  • OS: Win 7 Pro, OSX 10.8, Ubuntu 12.10
  • Phone: Galaxy Note 2

Posted 11 December 2012 - 00:35

OK this is ridiculous. I went to install Skydrive on my Snow Leopard OS and it is not supported. Really Microsoft? Dropbox has support for SL and you don't? What a joke.


#2 .Neo

.Neo

    Generic User

  • Joined: 14-September 05
  • Location: Amsterdam, NL
  • OS: OS X Mavericks
  • Phone: iPhone 5s

Posted 11 December 2012 - 01:27

You still use Mac OS X Snow Leopard? How quaint!

#3 OP Scorbing

Scorbing

    Halo Master

  • Joined: 02-December 01
  • Location: Florida
  • OS: Win 7 Pro, OSX 10.8, Ubuntu 12.10
  • Phone: Galaxy Note 2

Posted 11 December 2012 - 01:30

You still use Mac OS X Snow Leopard? How quaint!


It is what my Mac came with and I find it faster and more stable than ML. Had ML and took it off. Laggy and too many issues.

#4 Enron

Enron

    Windows for Workgroups

  • Tech Issues Solved: 1
  • Joined: 30-May 11
  • OS: Windows 8.1 U1
  • Phone: Nokia Lumia 900

Posted 11 December 2012 - 01:40

You could always install Windows 8 on your Mac for the ultimate Skydrive experience.

#5 #Michael

#Michael

    Neowinian Senior

  • Joined: 28-August 01

Posted 11 December 2012 - 01:40

Not that I am being a hard ass but did you look at the requirements before you tried to install it? https://apps.live.co...d2-eab969b0fd44

#6 OP Scorbing

Scorbing

    Halo Master

  • Joined: 02-December 01
  • Location: Florida
  • OS: Win 7 Pro, OSX 10.8, Ubuntu 12.10
  • Phone: Galaxy Note 2

Posted 11 December 2012 - 01:42

Not that I am being a hard ass but did you look at the requirements before you tried to install it? https://apps.live.co...d2-eab969b0fd44


Yes I did and that is why I was so surprised that SL was not supported.

#7 #Michael

#Michael

    Neowinian Senior

  • Joined: 28-August 01

Posted 11 December 2012 - 01:53

It appears the reason why SL is not supported is because MS is following Apple's approach of not supporting OS that are two generations old. Explanation on it: http://www.computerw...opard_s_retired

#8 OP Scorbing

Scorbing

    Halo Master

  • Joined: 02-December 01
  • Location: Florida
  • OS: Win 7 Pro, OSX 10.8, Ubuntu 12.10
  • Phone: Galaxy Note 2

Posted 11 December 2012 - 03:05

It appears the reason why SL is not supported is because MS is following Apple's approach of not supporting OS that are two generations old. Explanation on it: http://www.computerw...opard_s_retired


I think that is a very irresponsible attitude from Apple not to update SL. 60% of all mac users are still using SL.