Jump to content



Photo

[C#] Can't create VSIX file. Please help.

[c#] vsix deploy

  • Please log in to reply
2 replies to this topic

#1 sathenzar

sathenzar

    Neowinian

  • Joined: 12-June 06

Posted 07 January 2013 - 23:28

I can't seem to find any article that tells me how to fix my problem. I've tried cleaning and rebuilding everything with no go. I've put together some free controls for the public to use and I want to make a VSIX file. Seems simple enough, so I go download the Visual Studio 2012 SDK and install it, create the VSIX according to this blog: http://timheuer.com/...style-apps.aspx exactly how he has it but when I try to compile the vsix project it says:

The target "PkgdefProjectOutputGroup" does not exist in the project. I'm tugging my hair out here this should not be this hard. I can manually move the files to the extensions folder for vs and get it to show up in VS and work with my projects why can't I create a VSIX file of it? So far googling that error retrieves no results.


#2 OP sathenzar

sathenzar

    Neowinian

  • Joined: 12-June 06

Posted 08 January 2013 - 03:23

Wow after several hours of digging I finally figured out what I needed to do. Remove the property in the reference in the VSIX project. What a head ache that was.

#3 munni

munni

    Resident One Post Wonder

  • Joined: 20-February 13

Posted 20 February 2013 - 14:57

I created a project template for my sample ASP.NET MVC4 project in visual studio 2012 and then export template from file menu. Next I created a Vsix project where I added exported template zip file and its references in VsixManifest. Then I build the project which succeeded. I went to the location where I find the .vsix file and double click on it to install that template. When I opened new instance of visual studio I was able to see that template in the visual studio new project dialogbox. It worked until this point. I need to give the .vsix file to different users in my team. As soon as they double click on file template should create on there project dialog box. It did. But getting problem at resolving references. I tried to enable nuget package manager. Still same issue on their machine. This technique resolved references on my machine but not there machine. Is there any way to fix the issue of resolving dll references. Help would be appreciated.

Thanks,
Munni