Jump to content



Photo

VMWare ESXi vDistrib Switch problem

vmware esxi 5.1

  • Please log in to reply
3 replies to this topic

#1 garethevans1986

garethevans1986

    Neowinian

  • Joined: 01-April 04
  • Location: Gogledd Cymru / North Wales

Posted 08 January 2013 - 12:12

All,

I have a ESXI cluster setup running VMWare ESXI 5.1.

I have a distributed switch which, when 5 vms are connected to it, only 2 can ping eachother.

I can move the same vms to another distributed switch (on another port group) and they all ping fine.

No VLANs.
Security is all set to Accept.

Any ideas why or any pointers as to how to sort it?

Thank you
GE


#2 +BudMan

BudMan

    Neowinian Senior

  • Tech Issues Solved: 90
  • Joined: 04-July 02
  • Location: Schaumburg, IL
  • OS: Win7, Vista, 2k3, 2k8, XP, Linux, FreeBSD, OSX, etc. etc.

Posted 08 January 2013 - 13:58

Can you post your network setup from your esxi host showing us these devices on the port group on the same switch, etc.

As to not being able ping - software firewalls come to mind, many even the windows one block ping by default. Are they on the same network, wrong netmask can screw you up ;)

Are you trying to ping via name or IP? Ping by IP, if does not answer look in the arp table of the pinging machine - does it show the mac of the IP your trying to ping? If not then yeah you have a bit of a problem, never going to ping if can not arp for the mac. If shows a mac, is the mac correct for the IP your trying to ping.

I would assume your on windows vms? You can view your arp table with arp -a

example

C:\Windows\system32>arp -a

Interface: 192.168.1.100 --- 0xc
  Internet Address	  Physical Address	  Type
  192.168.1.7		   00-0c-29-dd-02-ba	 dynamic
  192.168.1.8		   00-0c-29-57-41-d5	 dynamic
  192.168.1.25		  00-13-b6-02-6c-09	 dynamic
  192.168.1.31		  b8-27-eb-1c-6e-09	 dynamic
  192.168.1.40		  2c-76-8a-ad-f6-56	 dynamic
  192.168.1.50		  00-15-99-21-1c-a0	 dynamic
  192.168.1.99		  00-06-dc-43-ad-78	 dynamic
  192.168.1.206		 00-22-5f-90-a3-a2	 dynamic
  192.168.1.214		 00-0c-29-ff-f4-2b	 dynamic
  192.168.1.253		 00-50-56-00-00-02	 dynamic
  192.168.1.255		 ff-ff-ff-ff-ff-ff	 static
  224.0.0.251		   01-00-5e-00-00-fb	 static
  239.255.255.250	   01-00-5e-7f-ff-fa	 static
  255.255.255.255	   ff-ff-ff-ff-ff-ff	 static

C:\Windows\system32>


#3 sc302

sc302

    Neowinian Senior

  • Tech Issues Solved: 25
  • Joined: 12-July 05
  • Location: NJ, USA

Posted 08 January 2013 - 18:12

network connection settings in your vm host would be good

#4 OP garethevans1986

garethevans1986

    Neowinian

  • Joined: 01-April 04
  • Location: Gogledd Cymru / North Wales

Posted 08 January 2013 - 21:39

Gents,

Thanks for the replies....I've found what was causing the problem.

My cluster has 2 Hosts in, each host has 6 physical NICs in....but only 4 plugged into anything (separate networks).

I've created a distrib switch using a non connected NIC meaning the VMs on one host will communicate but the ones on the other host wont due to the lack of switch inbetween.

Which means I need to get another switch tommorow :)

Thanks
GE