Jump to content



Photo

IE10 and CSS problem...

ie10 css background

  • Please log in to reply
11 replies to this topic

#1 LexL

LexL

    Neowinian

  • Joined: 09-September 11
  • Location: Milton Keynes
  • OS: Win7

Posted 10 January 2013 - 23:51

Hello,

Me and a friend made a website for my families holiday apartment (www.stleonard.info)

The background ( a photo ) should be remaining still, while a banner at the top should scroll with the rest of the page....
if your using chrome, or any other browser then you will see that this works...

IE10 however, you will notice that the background and the overlay at the top with the text and flag banner remains locked also and does not scroll with the page...

here is the css code:
body
  {
  font-family: Verdana;
  background-image:url(../images/banner.png), url(../images/bg.jpg);
  background-repeat:no-repeat;
  background-size: auto auto, 100% auto;
  background-position:50% 20px,50% 0%;
  background-attachment:scroll, fixed;
  margin: 0px 0px;
  padding: 0px;
  text-align: center;
  color: #043f7c;
  }


Is there a line of code needs to replace the background-attachment attribute? if this changes wont it mess up all the other browsers?
if anyone knows the answer to this - it would be most appreciated..

Thanks

Alex


#2 OP LexL

LexL

    Neowinian

  • Joined: 09-September 11
  • Location: Milton Keynes
  • OS: Win7

Posted 11 January 2013 - 10:32

anyone?

#3 cetla

cetla

    Neowinian

  • Joined: 09-January 13

Posted 11 January 2013 - 10:42

everything scroll just fine on both firefox and ie10 for me, http://imgur.com/3KGdJ

#4 +Zlip792

Zlip792

    Neowinian Senior

  • Tech Issues Solved: 9
  • Joined: 31-October 10
  • Location: Pakistan
  • OS: Windows 8.1 Pro 64-bit
  • Phone: Nokia C3-00 (8.70 firmware) It sucks!!!

Posted 11 January 2013 - 10:56

Its working fine for me as well, can you show us screencast of problem you are facing. Scrolling is fine for me.

#5 OP LexL

LexL

    Neowinian

  • Joined: 09-September 11
  • Location: Milton Keynes
  • OS: Win7

Posted 11 January 2013 - 11:08

my problem:

scroll.png

#6 goodbytes

goodbytes

    Just below average Joe

  • Tech Issues Solved: 1
  • Joined: 07-May 04
  • Location: England

Posted 11 January 2013 - 11:10

Are you aware this will not work in IE8 and below?

Although i think it's fine for every other browser and version so may not be an issue.

#7 +Zlip792

Zlip792

    Neowinian Senior

  • Tech Issues Solved: 9
  • Joined: 31-October 10
  • Location: Pakistan
  • OS: Windows 8.1 Pro 64-bit
  • Phone: Nokia C3-00 (8.70 firmware) It sucks!!!

Posted 11 January 2013 - 11:37

my problem:
~Snipped~


It is working as expected, on my IE10, it does not do the behaviour you showed me as a issue.

#8 OP LexL

LexL

    Neowinian

  • Joined: 09-September 11
  • Location: Milton Keynes
  • OS: Win7

Posted 11 January 2013 - 11:43

hmm, odd as it did work in ie9 and 8 - since upgrading to ie10 - now it fails to work.

I have also tried to change the background-attachment - to either scroll or fixed - and that does work. only one or the other - not both?!

#9 The_Decryptor

The_Decryptor

    STEAL THE DECLARATION OF INDEPENDENCE

  • Tech Issues Solved: 4
  • Joined: 28-September 02
  • Location: Sol System
  • OS: iSymbian 9.2 SP24.8 Mars Bar

Posted 11 January 2013 - 11:45

Do you have compatibility mode enabled?

#10 TheDisneyMagic

TheDisneyMagic

    Neowinian

  • Tech Issues Solved: 2
  • Joined: 01-October 05
  • OS: Windows 8.1 Pro
  • Phone: Nokia Lumia 1520

Posted 11 January 2013 - 11:45

Are you using the Windows 8 IE10 or the Windows 7 version which is not finished yet?

#11 OP LexL

LexL

    Neowinian

  • Joined: 09-September 11
  • Location: Milton Keynes
  • OS: Win7

Posted 11 January 2013 - 14:42

This is happening on Win8 IE10, and when in compatibility mode the background doesn't show at all...


scroll2.png

#12 +Seahorsepip

Seahorsepip

    http://seapip.com

  • Tech Issues Solved: 16
  • Joined: 23-January 11
  • Location: Netherlands
  • OS: Windows 8.1 Pro
  • Phone: Nexus 5

Posted 11 January 2013 - 19:13

This is happening on Win8 IE10, and when in compatibility mode the background doesn't show at all...


scroll2.png

compatibility mode means it uses IE7 engine so that would indeed look very bad...
tried the IE edge meta tag?



Click here to login or here to register to remove this ad, it's free!