Jump to content



Photo

Just another USB thumb drive problem thread


  • Please log in to reply
4 replies to this topic

#1 astroXP

astroXP

    The outer space geek

  • Joined: 01-December 09
  • Location: TX

Posted 01 February 2013 - 21:18

Long story short; I have an 8GB SandDisk thumb drive (FAT32) which I had plugged to an USB hub. For some reason, the USB hub was constantly plugging and unplugging itself for about 6 times yesterday. I ignored it.

Today at school when plugging in the USB, although the computer recognized it, it was empty. No files. Nada. However, it does say there's 522 MB of used space.

I've already made sure to show hidden files but still nothing comes up. Any ideas?


#2 +bman

bman

    Neowinian Senior

  • Tech Issues Solved: 1
  • Joined: 03-January 03
  • Location: Ottawa, Ontario
  • OS: Windows 8.1 & Android

Posted 01 February 2013 - 21:33

Was there important files on it? If not, I would load up GParted and wipe it clean, do a fresh partition.

Also, if you can, I'd go with NTFS instead.


Assuming there are files that you wanted on it, that is quite the problem. If you aren't seeing anything even after unhiding hidden files, does not make sense. Could be a damaged thumb drive, but I have never heard of them doing that before.

#3 xendrome

xendrome

    In God We Trust; All Others We Monitor

  • Tech Issues Solved: 13
  • Joined: 05-December 01
  • OS: Windows 8.1 Pro x64

Posted 01 February 2013 - 21:34

Try Recuva, google it.. or run a chkdsk /f X: on it, But the only type of "USB Problem" anyone should ever have is finding where to buy a new one, because they are so unreliable to store any critical data that you do not have other copies or backups of..

#4 fmanchu

fmanchu

    Free loader

  • Joined: 15-July 11
  • Location: Wisconsin

Posted 01 February 2013 - 21:35

Look for a program called "Recuva". I'm not sure of the address, but I believe it's free.

#5 remixedcat

remixedcat

    meow!

  • Tech Issues Solved: 1
  • Joined: 28-December 10
  • Location: Vmware ESXi and Hyper-V happy clouds
  • OS: Windows Server 2012 R2
  • Phone: I use telepathy and cat meows to communicate

Posted 01 February 2013 - 21:42

is yours a cruzer? my 16GB one suddenly failed as well... :(


failed to the point of windows not recognizing it....