Jump to content



Photo

Exchange 2003 Queue stuck


  • Please log in to reply
29 replies to this topic

#1 KibosJ

KibosJ

    Neowinian

  • Tech Issues Solved: 1
  • Joined: 27-January 09
  • Location: Darlington, United Kingdom
  • OS: Windows 8.1 Pro x64
  • Phone: Samsung Galaxy S4 (GT-I9505)

Posted 22 February 2013 - 11:08

Hey guys,

I've been banging my about this for so long I'm sure I'm just going round in circles.

I have an exchange 2003 Server emails appear to get stuck in the queue.

I have run smtpdiag and this is the output I get:

Searching for Exchange external DNS settings.
Computer name is ******-SERVER.
VSI 1 has the following external DNS servers:
208.67.222.222

Checking SOA for ****construction.com.
Checking external DNS servers.
Checking internal DNS servers.
SOA serial number match: Passed.


Checking local domain records.

Checking MX records using TCP: ******international.com.
Checking MX records using UDP: ******international.com.
Both TCP and UDP queries succeeded. Local DNS test passed.

Checking remote domain records.

Checking MX records using TCP: ****construction.com.
Checking MX records using UDP: ****construction.com.

Both TCP and UDP queries succeeded. Remote DNS test passed.


Checking MX servers listed for *@****construction.com.
Connecting to mail.***construction.com [81.***.2*8.1*4] on port 25.
Failed to receive data. Error: 10054
Error: Expected "250". Failed to get a response from the server.
Failed to submit mail to mail.asemconstruction.com.


I keep getting Error:10054 no matter what email server I try to send to.

If however I telnet into a mail server it works perfectly fine and I get no errors :(

This is doing my head in!

Any help would be greatly appreciated.

James


#2 AStaley

AStaley

    Neowinian

  • Tech Issues Solved: 4
  • Joined: 07-August 04
  • Location: United Kingdom
  • OS: Windows 8.1 Pro x64, OSX Mavericks, Elementary OS, Server 2008 R2/2012 R2, CentOS.
  • Phone: iPhone 4 (IOS7.1.1)

Posted 22 February 2013 - 11:21

It's been a long while since I looked at Exchange 2003, but a good place to start would be to enable SMTP logs; http://www.msexchang...TP_Service.html

Have you looked/checked all services are running?

#3 Storm

Storm

    Neowinian Senior

  • Joined: 10-August 03
  • Location: Leeds, UK

Posted 22 February 2013 - 11:24

looks like firewall or something?

#4 OP KibosJ

KibosJ

    Neowinian

  • Tech Issues Solved: 1
  • Joined: 27-January 09
  • Location: Darlington, United Kingdom
  • OS: Windows 8.1 Pro x64
  • Phone: Samsung Galaxy S4 (GT-I9505)

Posted 22 February 2013 - 11:29

looks like firewall or something?


I thought that, all the ports are open. Could this be as simple as a faulty router?

It's been a long while since I looked at Exchange 2003, but a good place to start would be to enable SMTP logs; http://www.msexchang...TP_Service.html

Have you looked/checked all services are running?


All the services are running yes I'll get a log in a moment.

#5 ]SK[

]SK[

    Neowinian Senior

  • Tech Issues Solved: 2
  • Joined: 12-October 04
  • Location: Nottingham, UK
  • OS: Windows 8.1
  • Phone: Nexus 5

Posted 22 February 2013 - 11:35

Sorry, you can telnet from the exchange server to the server it's attempting to reach then?

As a quick fix can you not relay via your ISP's mail server (Smart Host)?

#6 OP KibosJ

KibosJ

    Neowinian

  • Tech Issues Solved: 1
  • Joined: 27-January 09
  • Location: Darlington, United Kingdom
  • OS: Windows 8.1 Pro x64
  • Phone: Samsung Galaxy S4 (GT-I9505)

Posted 22 February 2013 - 11:44


Sorry, you can telnet from the exchange server to the server it's attempting to reach then?

As a quick fix can you not relay via your ISP's mail server (Smart Host)?


Yes I can telnet to the mail server perfectly fine and issue commands without being booted.

I'm just about to try the smart host now.

--EDIT--

Okay..... The Smart Host hasn't worked. Setting up the smart host still gives me the same issues. In the queue I have this error message:

The connection was dropped by the remote host.

#7 OP KibosJ

KibosJ

    Neowinian

  • Tech Issues Solved: 1
  • Joined: 27-January 09
  • Location: Darlington, United Kingdom
  • OS: Windows 8.1 Pro x64
  • Phone: Samsung Galaxy S4 (GT-I9505)

Posted 22 February 2013 - 12:20

I have attached the SMTP log in a zip file :)

Attached File  log.zip   186.73KB   46 downloads

#8 sc302

sc302

    Neowinian Senior

  • Tech Issues Solved: 25
  • Joined: 12-July 05
  • Location: NJ, USA

Posted 22 February 2013 - 13:47

when you are running telnet, are you running it from the mail server? This would test port 25 on the mail server to negate any firewalls.

Next you will have to try to find an application conflict, you should also check to see if your smtp service is running as well as your transports. I don't have a 2003 server to help you troubleshoot, I am going off memory and I believe you have to have the microsoft smtp service enabled to even think about sending and receiving mail.. also you will need to make sure the exchange routing engine is started in services.msc

Look at your event logs as well for errors.

#9 OP KibosJ

KibosJ

    Neowinian

  • Tech Issues Solved: 1
  • Joined: 27-January 09
  • Location: Darlington, United Kingdom
  • OS: Windows 8.1 Pro x64
  • Phone: Samsung Galaxy S4 (GT-I9505)

Posted 22 February 2013 - 13:51

when you are running telnet, are you running it from the mail server? This would test port 25 on the mail server to negate any firewalls.

Next you will have to try to find an application conflict, you should also check to see if your smtp service is running as well as your transports. I don't have a 2003 server to help you troubleshoot, I am going off memory and I believe you have to have the microsoft smtp service enabled to even think about sending and receiving mail.. also you will need to make sure the exchange routing engine is started in services.msc

Look at your event logs as well for errors.


I have indeed been running the telnet commands from the mail server.

The SMTP service is started as is the exchange routing engine, both services have also been restarted and still not working :(

#10 sc302

sc302

    Neowinian Senior

  • Tech Issues Solved: 25
  • Joined: 12-July 05
  • Location: NJ, USA

Posted 22 February 2013 - 13:56

You have something that is stopping communications. Do you have a spam filter? What is the outbound rate limit (this will log jam the crap out of your server).

Looking at your log, I would say that you have a low rate limit set on your outbound mail filter. Just to the 1 IP you have over 100 going to it. Set it to 200 or 500.

Here is a pic of my barracuda you will see that it is at the default, some are much lower set to around 50 per Sender.

Attached Images

  • bar.jpg


#11 sc302

sc302

    Neowinian Senior

  • Tech Issues Solved: 25
  • Joined: 12-July 05
  • Location: NJ, USA

Posted 22 February 2013 - 14:09

Just took another look at that log file....postfix is your smtp outbound, you will need to check that box to allow through....it is caught up in there. Judging from the codes you are getting...fix your spam filter.

#12 OP KibosJ

KibosJ

    Neowinian

  • Tech Issues Solved: 1
  • Joined: 27-January 09
  • Location: Darlington, United Kingdom
  • OS: Windows 8.1 Pro x64
  • Phone: Samsung Galaxy S4 (GT-I9505)

Posted 22 February 2013 - 14:11

You have something that is stopping communications. Do you have a spam filter? What is the outbound rate limit (this will log jam the crap out of your server).

Looking at your log, I would say that you have a low rate limit set on your outbound mail filter. Just to the 1 IP you have over 100 going to it. Set it to 200 or 500.

Here is a pic of my barracuda you will see that it is at the default, some are much lower set to around 50 per Sender.


At the moment these limits are off...

The one that is on was already set to MUCH higher than 500

Untitled.png

#13 OP KibosJ

KibosJ

    Neowinian

  • Tech Issues Solved: 1
  • Joined: 27-January 09
  • Location: Darlington, United Kingdom
  • OS: Windows 8.1 Pro x64
  • Phone: Samsung Galaxy S4 (GT-I9505)

Posted 22 February 2013 - 14:17

Just took another look at that log file....postfix is your smtp outbound, you will need to check that box to allow through....it is caught up in there. Judging from the codes you are getting...fix your spam filter.


We don't use PostFix :s There is nothing installed on this server apart from exchange.

#14 sc302

sc302

    Neowinian Senior

  • Tech Issues Solved: 25
  • Joined: 12-July 05
  • Location: NJ, USA

Posted 22 February 2013 - 14:19

lets start simply....do you have a spam solution outside of your exchange solution?

do you have anything setup in your smarthost?
Servers/Your_Server/Protocols/SMTP/Your_SMTP_Virtual_Server
Right-click Your_SMTP_Virtual_Server, and then click Properties.
Click the Delivery tab, and then click Advanced.
In the Smart host box, type the name of the smart host server.

There are 2 areas that I can remember where you can add a smart host....this is one of two.

#15 OP KibosJ

KibosJ

    Neowinian

  • Tech Issues Solved: 1
  • Joined: 27-January 09
  • Location: Darlington, United Kingdom
  • OS: Windows 8.1 Pro x64
  • Phone: Samsung Galaxy S4 (GT-I9505)

Posted 22 February 2013 - 14:21

lets start simply....do you have a spam solution outside of your exchange solution?


No, Exchange is configured to send mail via DNS, we aren't using a Smart Host. The email is not configured to "go" anywhere else.