Jump to content

30 posts in this topic

Posted

Ok, this might seem like a strange thing to worry about, but on my 64-bit Windows 8 Pro (clean) installation, the File Explorer takes about twice as long (1.38 seconds) to start when I click a shortcut on the taskbar than when I click a shortcut from the start screen or the desktop (0.76 seconds). Is there any reason for this? How could I speed of the opening of File Explorer (and probably other programs) when launching from the taskbar? I probably wouldn't care as much if it wasn't such a noticeable difference when waiting for it to open. Both cases (desktop and taskbar) opened instantly on Windows 7 Ultimate.

Share this post


Link to post
Share on other sites

Posted

1.38 seconds.... disgraceful

How would you even have noticed the difference between 0.76 seconds and 1.38 seconds?

Share this post


Link to post
Share on other sites

Posted

Anything over 0.3 seconds is easily noticeable to the average human brain. This difference is well over that threshold. For a task that I perform many times a day, it is an annoying regression and I'm simply looking for insight. If you have nothing constructive to say, please move along.

Share this post


Link to post
Share on other sites

Posted

I think it takes longer for the application to start from the superbar, because of the little anination it does when you click the icon.

Try turning off all Windows animations. That should help your speeds a bit.
(Or just turn off "animations in the taskbar".)

Share this post


Link to post
Share on other sites

Posted

[quote name='tracon' timestamp='1362335800' post='595555420']
Anything over 0.3 seconds is easily noticeable to the average human brain. This difference is well over that threshold. For a task that I perform many times a day, it is an annoying regression and I'm simply looking for insight. If you have nothing constructive to say, please move along.
[/quote]

Moving along
3 people like this

Share this post


Link to post
Share on other sites

Posted

[quote name='KRazpopov' timestamp='1362335941' post='595555422']
I think it takes longer for the application to start from the superbar, because of the little anination it does when you click the icon.

Try turning off all Windows animations. That should help your speeds a bit.
(Or just turn off "animations in the taskbar".)
[/quote]

Disabling all animations and/or the taskbar animations made no difference. Thanks for the suggestion, though!

Share this post


Link to post
Share on other sites

Posted

Do you have any other programs installed or just Windows itself?

If you have security software try disabling it. Same with startup/background processes.

Share this post


Link to post
Share on other sites

Posted

[quote name='ajua' timestamp='1362340880' post='595555568']
Do you have any other programs installed or just Windows itself?

If you have security software try disabling it. Same with startup/background processes.
[/quote]

I do have other software installed now. Just a few common programs (like Google Chrome). I was having this problem before I installed them, though. I disabled all of my security software and startup programs, rebooted, and still have the problem. Interestingly enough, if I right click the File Explorer icon on the taskbar and click on one of the jump list entries, it opens just as quickly as if I used the Start Screen. There's just something wrong with simply left clicking the taskbar icon. At this point, it's a puzzle to solve, not so much a necessity.

Share this post


Link to post
Share on other sites

Posted

[quote name='tracon' timestamp='1362341964' post='595555594']
I do have other software installed now. Just a few common programs (like Google Chrome). I was having this problem before I installed them, though. I disabled all of my security software and startup programs, rebooted, and still have the problem. Interestingly enough, if I right click the File Explorer icon on the taskbar and click on one of the jump list entries, it opens just as quickly as if I used the Start Screen. There's just something wrong with simply left clicking the taskbar icon. At this point, it's a puzzle to solve, not so much a necessity.
[/quote]

That's weird. Have you tried to unpin it and pin it again? That's all I can think of right now.

Share this post


Link to post
Share on other sites

Posted

@OP
Have you installed all the Microsoft Updates after clean install?
There are bunch of updates (above 500 MB) available from Microsoft which improve performance and stability.
I have all the updates applied and don't see any difference in launching File Explorer in my machine.
It's super quick. I see it as soon as I click.

Share this post


Link to post
Share on other sites

Posted

I refuse to believe this. If you have disabled all window animations and you are indeed trying to run the same File Explorer from both locations then there should be no difference at all. Try one thing for me though. Hit up CMD and type

[CODE]
explorer
[/CODE]

and tell us how long that takes to start up.

Share this post


Link to post
Share on other sites

Posted

[quote name='ajua' timestamp='1362635880' post='595562984']
That's weird. Have you tried to unpin it and pin it again? That's all I can think of right now.
[/quote]

That didn't help. Thanks, though.

[quote name='StarkWiz' timestamp='1362636957' post='595563004']
@OP
Have you installed all the Microsoft Updates after clean install?
There are bunch of updates (above 500 MB) available from Microsoft which improve performance and stability.
I have all the updates applied and don't see any difference in launching File Explorer in my machine.
It's super quick. I see it as soon as I click.
[/quote]

Yeah, I updated the system as soon as the install finished. I obsessively update :p

[quote name='ingramator' timestamp='1362644037' post='595563084']
I refuse to believe this. If you have disabled all window animations and you are indeed trying to run the same File Explorer from both locations then there should be no difference at all. Try one thing for me though. Hit up CMD and type

[CODE]
explorer
[/CODE]

and tell us how long that takes to start up.
[/quote]

Entering 'explorer' in the command prompt opens instantly, just like the Jump List entries, hitting windows + E, and shortcut on the start screen. I don't blame you for not believing it. I can assure you, however, that it is happening. It's not a huge deal, so whether or not I find a solution doesn't matter. I made this thread because I, too, see no reason for it and wanted to see if anyone else had heard of a similar issue. I guess not and that's fine.

Share this post


Link to post
Share on other sites

Posted

Replying to this topic to say I have say I have the identical issue, starts perfect from all other sources except task bar. It happened after installing the latest nvidia drivers if that helps

Share this post


Link to post
Share on other sites

Posted

Perhaps the indexing service?
1 person likes this

Share this post


Link to post
Share on other sites

Posted

[quote name='Detection' timestamp='1362335550' post='595555412']
1.38 seconds.... disgraceful

How would you even have noticed the difference between 0.76 seconds and 1.38 seconds?
[/quote]

When you have a high performing system, that's a lifetime to do something like open File Manager, one, one thousand, tw.......

There's clearly something wrong.

[quote name='Co-ords' timestamp='1364159257' post='595595638']
Perhaps the indexing service?
[/quote]

I recently had this problem after opening File Manager and waiting for it to enumerate all drives. Disabling defender eliminated the problem. So I disabled indexing, deleted the indexes, disabled Defender. Rebooted, re-enabled all, and all is well. Took a whole day to figure it out though, with several Google searches which lead to disabling Defender.

Share this post


Link to post
Share on other sites

Posted

typing this from windows 8, and it works beautifully. (Dell Inspiron 1545)....opens as fast as I can click on it. (internal Intel drivers, generic MS drivers to be exact...dell won't release updated graphics drivers for this chipset for 8, frown)

Share this post


Link to post
Share on other sites

Posted

I have the same problem! It actually takes almost 2secs for the file explorer to open on my laptop when clicked from the taskbar.

and yes, 1.38 secs compared to milliseconds is a lot longer when you're always using your computer, so to the first person who replied to this thread, it is very noticeable.

and yeah, opening file explorer from the jump list is instant.

has anyone solved this problem? it is very annoying. can't work fast when you need to browse quick through your files.

right clicking file explorer on the taskbar and clicking any folder (jump list) is not very intuitive.

i just need for file explorer to appear immediately after clicking it on the taskbar.



anyone already has the solution for this? thanks!

Share this post


Link to post
Share on other sites

Posted

I had this problem too, but the solution is obvious! All other methods of opening explorer.exe are quick, but not the taskbar, so it must be using a different path. So it was! It goes to a directory (libraries by default), rather than opening explorer.exe.

THE FIX

Go to C:\Users\USERNAME\AppData\Roaming\Microsoft\Internet Explorer\Quick Launch\User Pinned\TaskBar , where the taskbar shortcuts are stored. (The IE team developed the idea, hence the path)

Right click on File Explorer, and click properties.

Change the path to C:\Windows\explorer.exe .

Problem solved!
6 people like this

Share this post


Link to post
Share on other sites

Posted

Brilliant. Thanks.

Share this post


Link to post
Share on other sites

Posted

I had this problem too, but the solution is obvious! All other methods of opening explorer.exe are quick, but not the taskbar, so it must be using a different path. So it was! It goes to a directory (libraries by default), rather than opening explorer.exe.

THE FIX

Go to C:\Users\USERNAME\AppData\Roaming\Microsoft\Internet Explorer\Quick Launch\User Pinned\TaskBar , where the taskbar shortcuts are stored. (The IE team developed the idea, hence the path)

Right click on File Explorer, and click properties.

Change the path to C:\Windows\explorer.exe .

Problem solved!

 

Thank you! Good thing I came back to this thread I was hoping someone would have figured out the fix already.

 

Thanks again! :laugh: 

 

Now my Windows 8 experience is once again whole. :rofl:

Share this post


Link to post
Share on other sites

Posted

I had the same problem, but it is also slow when I click Windows-E. Anybody knows if there is an obscure shortcut for this as well? Opening Windows Explorer from the task bar is now immediate, but pressing Windows-E takes almost 3 seconds. That's 3 seconds to think about how much I love the improvements in Windows 8...

Share this post


Link to post
Share on other sites

Posted

I seem to have this problem in reverse, its instant on the taskbar, but slow when I right click the start screen button thing and choose file explorer.

Share this post


Link to post
Share on other sites

Posted

I had this problem too, but the solution is obvious! All other methods of opening explorer.exe are quick, but not the taskbar, so it must be using a different path. So it was! It goes to a directory (libraries by default), rather than opening explorer.exe.

THE FIX

Go to C:\Users\USERNAME\AppData\Roaming\Microsoft\Internet Explorer\Quick Launch\User Pinned\TaskBar , where the taskbar shortcuts are stored. (The IE team developed the idea, hence the path)

Right click on File Explorer, and click properties.

Change the path to C:\Windows\explorer.exe .

Problem solved!

 

Hi,

 

first off all, hi to everyone, and thank you PokeOracle for this solution...

 

it solved in windows 8, but now it happened again in windows 8.1 and the target is greyed out...

 

i'm trying to solve this by using same logic, but nothing solves...

 

does anyone solved this in windows 8.1?

 

regards...

Share this post


Link to post
Share on other sites

Posted

Same here. It worked fine until I upgraded to Windows 8.1. Now it takes 4+ seconds to start Windows Explorer, even if I open explorer.exe under c:\Windows. It used to be a snap.Anyone with ideas on how to speed this up? I have a rather new i7 computer with 16GB ram, so the hardware shouldn't be the issue.

Share this post


Link to post
Share on other sites

Posted

Search for "Indexing Options" and make sure there are no invalid locations. That will greatly slow down Explorer.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.