Jump to content



Photo

File Explorer Slow To Open From Taskbar


26 replies to this topic

#16 Obi-Wan Kenobi

Obi-Wan Kenobi

    "You were the chosen one!"

  • Joined: 11-November 02
  • Location: West-Central Texas

Posted 24 March 2013 - 21:27

typing this from windows 8, and it works beautifully. (Dell Inspiron 1545)....opens as fast as I can click on it. (internal Intel drivers, generic MS drivers to be exact...dell won't release updated graphics drivers for this chipset for 8, frown)


#17 ching

ching

    Neowinian

  • Joined: 04-April 13

Posted 04 April 2013 - 11:50

I have the same problem! It actually takes almost 2secs for the file explorer to open on my laptop when clicked from the taskbar.

and yes, 1.38 secs compared to milliseconds is a lot longer when you're always using your computer, so to the first person who replied to this thread, it is very noticeable.

and yeah, opening file explorer from the jump list is instant.

has anyone solved this problem? it is very annoying. can't work fast when you need to browse quick through your files.

right clicking file explorer on the taskbar and clicking any folder (jump list) is not very intuitive.

i just need for file explorer to appear immediately after clicking it on the taskbar.



anyone already has the solution for this? thanks!

#18 PokeOracle

PokeOracle

    Resident One Post Wonder

  • Joined: 07-June 13

Posted 07 June 2013 - 22:18

I had this problem too, but the solution is obvious! All other methods of opening explorer.exe are quick, but not the taskbar, so it must be using a different path. So it was! It goes to a directory (libraries by default), rather than opening explorer.exe.

THE FIX

Go to C:\Users\USERNAME\AppData\Roaming\Microsoft\Internet Explorer\Quick Launch\User Pinned\TaskBar , where the taskbar shortcuts are stored. (The IE team developed the idea, hence the path)

Right click on File Explorer, and click properties.

Change the path to C:\Windows\explorer.exe .

Problem solved!

#19 Growled

Growled

    Neowinian Senior

  • Tech Issues Solved: 1
  • Joined: 17-December 08
  • Location: USA

Posted 08 June 2013 - 04:38

Brilliant. Thanks.

#20 ching

ching

    Neowinian

  • Joined: 04-April 13

Posted 23 June 2013 - 08:58

I had this problem too, but the solution is obvious! All other methods of opening explorer.exe are quick, but not the taskbar, so it must be using a different path. So it was! It goes to a directory (libraries by default), rather than opening explorer.exe.

THE FIX

Go to C:\Users\USERNAME\AppData\Roaming\Microsoft\Internet Explorer\Quick Launch\User Pinned\TaskBar , where the taskbar shortcuts are stored. (The IE team developed the idea, hence the path)

Right click on File Explorer, and click properties.

Change the path to C:\Windows\explorer.exe .

Problem solved!

 

Thank you! Good thing I came back to this thread I was hoping someone would have figured out the fix already.

 

Thanks again! :laugh: 

 

Now my Windows 8 experience is once again whole. :rofl:



#21 Svein

Svein

    Neowinian

  • Joined: 12-July 13

Posted 12 July 2013 - 19:45

I had the same problem, but it is also slow when I click Windows-E. Anybody knows if there is an obscure shortcut for this as well? Opening Windows Explorer from the task bar is now immediate, but pressing Windows-E takes almost 3 seconds. That's 3 seconds to think about how much I love the improvements in Windows 8...



#22 Richard C.

Richard C.

    Neowinian Senior

  • Joined: 15-April 05
  • Location: Around
  • OS: Windows 8.1 Pro & Mac OSX
  • Phone: iPhone 5

Posted 14 July 2013 - 21:27

I seem to have this problem in reverse, its instant on the taskbar, but slow when I right click the start screen button thing and choose file explorer.



#23 geneiros

geneiros

    Resident One Post Wonder

  • Joined: 17-October 13

Posted 17 October 2013 - 16:32

I had this problem too, but the solution is obvious! All other methods of opening explorer.exe are quick, but not the taskbar, so it must be using a different path. So it was! It goes to a directory (libraries by default), rather than opening explorer.exe.

THE FIX

Go to C:\Users\USERNAME\AppData\Roaming\Microsoft\Internet Explorer\Quick Launch\User Pinned\TaskBar , where the taskbar shortcuts are stored. (The IE team developed the idea, hence the path)

Right click on File Explorer, and click properties.

Change the path to C:\Windows\explorer.exe .

Problem solved!

 

Hi,

 

first off all, hi to everyone, and thank you PokeOracle for this solution...

 

it solved in windows 8, but now it happened again in windows 8.1 and the target is greyed out...

 

i'm trying to solve this by using same logic, but nothing solves...

 

does anyone solved this in windows 8.1?

 

regards...



#24 Svein

Svein

    Neowinian

  • Joined: 12-July 13

Posted 21 October 2013 - 13:37

Same here. It worked fine until I upgraded to Windows 8.1. Now it takes 4+ seconds to start Windows Explorer, even if I open explorer.exe under c:\Windows. It used to be a snap.Anyone with ideas on how to speed this up? I have a rather new i7 computer with 16GB ram, so the hardware shouldn't be the issue.



#25 Eric

Eric

    Neowinian Senior

  • Tech Issues Solved: 13
  • Joined: 02-August 06
  • Location: Greenville, SC

Posted 21 October 2013 - 13:44

Search for "Indexing Options" and make sure there are no invalid locations. That will greatly slow down Explorer.



#26 ching

ching

    Neowinian

  • Joined: 04-April 13

Posted 27 April 2014 - 11:17

Same here!

After upgrading to WIndows 8.1 it went back to opening up slow.

Anyone can post a fix?

 

Thanks!



#27 JMASON

JMASON

    Resident One Post Wonder

  • Joined: 29-September 14

Posted 29 September 2014 - 04:37

My jump lists started running very slow.  When opening programs from a shortcut on the desktop it is extremely fast, but when I click on a file pined to the application icon in the task bar it is so slow it has to speed up to stop.  I have read the thread on this and since I have Windows 8.1 I can't change the pate in the properties of the jump list.  I called Microsoft tech support and was told they would have to back up my machine, reinstall the OS.  Since the only back up was going to be the data, I would have to reinstall all my programs.  That is not going to happen.  To do that would shut me down for two days, not including resetting all my custom options and profiles in the many programs I have.  Does anyone have any ideas on how to remedy this situation?