Jump to content



Photo

Connecting printer with ethernet cable to PC?


  • Please log in to reply
10 replies to this topic

#1 Chmura

Chmura

    Neowinian

  • Joined: 26-July 04
  • Location: Chicago

Posted 11 April 2013 - 00:04

I have this older printer HP LaserJet 4200n that used to be connected to my router and I'd just print from any computer, but now the printer was moved and it cannot be connected to the router. I have connected it to my PC (windows 7) with an ethernet cable, but am unable to figure out if this set-up will work or not and unfortunately the printer doesn't have any USB ports.
Is there a way for this to work? How can I do it?


#2 xendrome

xendrome

    In God We Trust; All Others We Monitor

  • Tech Issues Solved: 10
  • Joined: 05-December 01
  • OS: Windows 8.1 Pro x64

Posted 11 April 2013 - 00:10

Wireless Bridge.

#3 sc302

sc302

    Neowinian Senior

  • Tech Issues Solved: 25
  • Joined: 12-July 05
  • Location: NJ, USA

Posted 11 April 2013 - 00:11

You would have to statically assign the nic of the printer and the pc an IP address on the same network


192.168.100.20 PC
192.168.100.21 printer

Subnet 255.255.255.0 will work

If your pc does not have a gigabit nic either get one or get a cross over cable.

This will get you printing. Get a router that is capable of repeater mode or dd-wrt

#4 OP Chmura

Chmura

    Neowinian

  • Joined: 26-July 04
  • Location: Chicago

Posted 11 April 2013 - 00:21

Wireless Bridge.


That would require purchasing a device correct?

You would have to statically assign the nic of the printer and the pc an IP address on the same network


192.168.100.20 PC
192.168.100.21 printer

Subnet 255.255.255.0 will work

If your pc does not have a gigabit nic either get one or get a cross over cable.

This will get you printing.


My PC is connected by wireless and the printer is connected to the only ethernet port (gigabit). Can I still assign the IPs?
I have assigned an IP to the nic card earlier, but couldn't get it working (192.168.1.111, subnet 255.255.255.0, gateway 192.168.1.1)

#5 sc302

sc302

    Neowinian Senior

  • Tech Issues Solved: 25
  • Joined: 12-July 05
  • Location: NJ, USA

Posted 11 April 2013 - 00:23

You have to assign ips. This is how your are going to communicate. You cannot put it ont the same network as your wireless network. It won't work.

#6 OP Chmura

Chmura

    Neowinian

  • Joined: 26-July 04
  • Location: Chicago

Posted 11 April 2013 - 00:27

Can you be more specific? How exactly am I suppose to assign these IPs, where?

#7 sc302

sc302

    Neowinian Senior

  • Tech Issues Solved: 25
  • Joined: 12-July 05
  • Location: NJ, USA

Posted 11 April 2013 - 00:33

The printer has a menu that is painful to navigate through, but It is possible....done it plenty of times. The nic on the computer you change in the network properties.

#8 OP Chmura

Chmura

    Neowinian

  • Joined: 26-July 04
  • Location: Chicago

Posted 11 April 2013 - 00:56

I am having trouble figuring this out, just can't get it to work.

Here's how I set it up:
http://i.imgur.com/upiBk8Y.jpg

#9 trek

trek

    7 / X

  • Joined: 11-August 02
  • Location: Vancouver, Canada

Posted 11 April 2013 - 03:36

And you statically assigned the printer with an address on the 192.168.100.0 network? Can you ping it?

#10 +BudMan

BudMan

    Neowinian Senior

  • Tech Issues Solved: 90
  • Joined: 04-July 02
  • Location: Schaumburg, IL
  • OS: Win7, Vista, 2k3, 2k8, XP, Linux, FreeBSD, OSX, etc. etc.

Posted 11 April 2013 - 03:52

^ exactly did you setup the printer on the 192.168.100 ?? You can not just say on your pc the IP is now 192.168.100.21, you have to actually set that on the printer.

Also there is no gateway - does 192.168.100.1 exist? No - then how it would it be your gateway off that network between your pc and your printer?

#11 OP Chmura

Chmura

    Neowinian

  • Joined: 26-July 04
  • Location: Chicago

Posted 11 April 2013 - 05:00

Ahhh ok! I didn't know I had to physically go to the printer and change it there too. Somehow missed the IP settings on the printer last time, but I found it. Thank you guys!