Jump to content



Photo

Revert to default desktop config Debian Wheezy


  • Please log in to reply
10 replies to this topic

#1 cork1958

cork1958

    Neowinian

  • Tech Issues Solved: 2
  • Joined: 04-October 02

Posted 21 May 2013 - 01:28

My first attempt at using Debian and upon installing, I DID NOT check for Debian to use the default config for desktop so now i have no menu bar/button or top menubar/panel and the bottom panel only has the date/time and log out button.

Everything is working and running fine but I need that menu button/bar and stuff. Just seems to weird without as on my 2nd install on a different computer I DID check to use default desktop config and it looks/works normal.

How do I get those items back WITHOUT having to right click the desktop to launch anything all the time. Do not suggest right clicking the bottom panel, add panel, add items as that is not working, if I remebered that process correctly from the searches I've tried.

i am using wheezy and xfce

thank you


#2 +Karl L.

Karl L.

    xorangekiller

  • Tech Issues Solved: 15
  • Joined: 24-January 09
  • Location: Virginia, USA
  • OS: Debian Testing

Posted 21 May 2013 - 01:33

Try installing the XFCE desktop metapackage that tasksel would have installed had you selected it in the Debian Installer, then reboot.

sudo apt-get install task-xfce-desktop
sudo reboot


#3 OP cork1958

cork1958

    Neowinian

  • Tech Issues Solved: 2
  • Joined: 04-October 02

Posted 21 May 2013 - 01:38

Thank you, although I'm positive I've tried that one. Just tried it anyway, in case maybe I had typed something incorrectly before. This time I just copy and pasted but it was a no go just the same. :(

Been working on this one for a week plus and it's driving me nuts!! :s

Edit:
Just noticed. I did get the Iceweasel applet added to the bottom panel after doing that!

#4 +Karl L.

Karl L.

    xorangekiller

  • Tech Issues Solved: 15
  • Joined: 24-January 09
  • Location: Virginia, USA
  • OS: Debian Testing

Posted 21 May 2013 - 01:44

It may be something with the configuration for your user account. Create a new user and see if you still have the issue.

sudo adduser <username>


#5 OP cork1958

cork1958

    Neowinian

  • Tech Issues Solved: 2
  • Joined: 04-October 02

Posted 21 May 2013 - 02:08

Right on once again, xorangekiller, that did it!!

Now, the next some what obvious question and I haven't even looked for myself, but how do I remove my previous/original user name and then change the one I just created to cork?

#6 +Karl L.

Karl L.

    xorangekiller

  • Tech Issues Solved: 15
  • Joined: 24-January 09
  • Location: Virginia, USA
  • OS: Debian Testing

Posted 21 May 2013 - 03:54

The easiest thing to do is probably to move the configuration from your new user to the old one, then delete the new user profile. The new user account works because you setup a new XFCE configuration for it; all you need to do now is copy that configuration to your old user. It should work something like the following:

sudo -s

export $OLD_USER=<original_user_name>
export $NEW_USER=<new_user_name>

cp -af /home/$NEW_USER/* /home/$OLD_USER
chown -R $OLD_USER:$OLD_USER /home/$OLD_USER
deluser --quiet --group --remove-home $NEW_USER

reboot


#7 OP cork1958

cork1958

    Neowinian

  • Tech Issues Solved: 2
  • Joined: 04-October 02

Posted 21 May 2013 - 10:27

Dude!!

How do you know or remember all that crap?

I've been playing with different versions of Linux for several years and I can't ever even remember the simple commands for opening the source list or host file or anything and I'm usually pretty good at remembering things!!

I'll try this later tonight.

Thank you once again!!

#8 sean.ferguson

sean.ferguson

    Anonymous

  • Joined: 25-June 05
  • Location: Scotland
  • OS: GNU/Linux

Posted 21 May 2013 - 18:01

When it comes to Debian xorangekiller is the guy to go to ;) that has been proven!

#9 Mindovermaster

Mindovermaster

    Neowinian Senior

  • Tech Issues Solved: 10
  • Joined: 25-January 07
  • Location: /USA/Wisconsin/
  • OS: Mint Debian LMDE
  • Phone: HTC ONE V

Posted 21 May 2013 - 18:19

Even Ubuntu help. He helped me a lot getting my HD6740 open source drivers going. :)

#10 OP cork1958

cork1958

    Neowinian

  • Tech Issues Solved: 2
  • Joined: 04-October 02

Posted 22 May 2013 - 01:40

The easiest thing to do is probably to move the configuration from your new user to the old one, then delete the new user profile. The new user account works because you setup a new XFCE configuration for it; all you need to do now is copy that configuration to your old user. It should work something like the following:

sudo -s

export $OLD_USER=<original_user_name>
export $NEW_USER=<new_user_name>

cp -af /home/$NEW_USER/* /home/$OLD_USER
chown -R $OLD_USER:$OLD_USER /home/$OLD_USER
deluser --quiet --group --remove-home $NEW_USER

reboot


Have to apologize as in my haste last night, I came across some searches on how to do this and most of them looked to confusing to mess with. I simply found the command to remove users and just removed my old name. I can live with the new name I created.

Sorry to have you go through the trouble, but appreciate the heck out of it once again.

#11 +Karl L.

Karl L.

    xorangekiller

  • Tech Issues Solved: 15
  • Joined: 24-January 09
  • Location: Virginia, USA
  • OS: Debian Testing

Posted 22 May 2013 - 04:40

You can still change your user name (technically known as your login name) if you wish. It is a more involved procedure than what I suggested already, which is why I did not originally suggest it. Since you have deleted your old user account, boot into single user mode (accessed via the "Recovery Mode" option at the GRUB bootloader prompt) and perform the following actions to effect the modification.

# You must be logged in to a root prompt to perform the following operation.
# You must not be logged in to the user account to which you are applying these changes.
# I recommend that you do this from a prompt in single user mode.

export OLD_USER_NAME=<current_name_of_the_user_you_wish_to_modify>
export NEW_USER_NAME=<new_login_name_of_the_above_user>

usermod --login $NEW_USER_NAME --home /home/$NEW_USER_NAME --move-home $OLD_USER_NAME
groupmod --new-name $NEW_USER_NAME $OLD_USER_NAME

reboot

The commands above will work without changing the ownership of any files. It is also unnecessary to add the user to the group once it is renamed. The reason is that the names are not actually used internally by the operating system - they are merely a mnemonic device. Everything is technically identified by the UID (user identification number) and GID (group identification number) associated with your login name and group name, respectively. Since we did not change the UID or GID we did not need to reassign anything else. However, some programs (such as postfix or samba) potentially have the login name or group name embedded in their configuration files. Therefore while you probably don't need to change anything else, just bear in mind the possibility that your user name may need to be changed in some program's configuration file as well. It is another reason the method I first suggested is somewhat neater.