Jump to content



Photo

help configuring yum on centos

linux centos yum

  • Please log in to reply
2 replies to this topic

#1 krishna@9-zone

krishna@9-zone

    Neowinian

  • Joined: 20-December 09
  • Location: India
  • OS: Windows 8 , Redhat

Posted 05 June 2013 - 06:37

hello all I'm a newbie to Linux...........

I was trying to conf. yum server on CentOS-6.4(running on VMware).........I get this error while createrepo

please someone help me with this......

Attached Images

  • terminal.jpg



#2 Haggis

Haggis

    Neowinian Senior

  • Tech Issues Solved: 10
  • Joined: 13-June 07
  • Location: Near Stirling, Scotland
  • OS: Debian 7
  • Phone: Samsung Galaxy S3 LTE (i9305)

Posted 05 June 2013 - 07:16

as root can you do

yum install python-deltarpm

then try create repo again

#3 +Karl L.

Karl L.

    xorangekiller

  • Tech Issues Solved: 15
  • Joined: 24-January 09
  • Location: Virginia, USA
  • OS: Debian Testing

Posted 05 June 2013 - 14:10

Haggis is correct, installing python-deltarpm should fix your issue. If you are missing a package and don't know what it is called, you can search for it by replacing deltarpm in the following command with the name of the package you wish to search for.

yum search all deltarpm

That said, how did you install createrepo? If you installed it from the repository yum should have installed, deltarpm, python-deltarpm, libxml2-python, and possibly a few other packages for you automatically.



Click here to login or here to register to remove this ad, it's free!