Jump to content

Question

Posted

Hi I have a Sony VGP-BPS21A laptop. It was working fine until I noticed that the battery wasnt charging. I heard the ac adaptor buzzing a bit so I figured the ac adaptor was on its last leg. So I ordered a new one. That didnt charge the battery. So I ordered a new battery. Still nothing charging.
I shut the laptop down, removed the Sony VGP-BPS21A battery(new and old) and tried running the laptop just off the old ac adaptor.
It boots up fine and is usable but I cannot get the battery to charge whether its the new Sony VGP-BPS21A battery /ac adaptor or the old ones.
Is there anything that possibly went on the board itself?????
I have been doing some research but cant find much answers out. I read some other people having the same problem but nothing answered in several forums I have read.      

Share this post


Link to post
Share on other sites

1 answer to this question

  • 0

Posted


Is there anything that possibly went on the board itself?????

 

Hi, there!

 

I doubt it's a hardware issue.

 

I'd suggest that you go to bios, look for a "smart battery" feature there, and disable it. If you can't find it there, look for sony utilities in windows and try to do the same.

 

 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.