Jump to content



Photo

Connect two computers via Ethernet?


  • Please log in to reply
6 replies to this topic

#1 Lamp0

Lamp0

    Neowinian Senior

  • Joined: 14-December 08

Posted 22 August 2013 - 14:00

I've tried connect laptops(Win 7 & Win 8 machines) via ethernet numerious times & I've only ever got it working once where I could transfer one way, but I can't seem to get it working again.

 

I have followed countless instructions & it just won't work. I am not using a cross over cable, but as I have gotten it to work before I assume the machines have the "Auto-MDIX" thing?

 

How do I get this to work? Should it not just be a "plug & play" thing?

 

 




#2 +BudMan

BudMan

    Neowinian Senior

  • Tech Issues Solved: 89
  • Joined: 04-July 02
  • Location: Schaumburg, IL
  • OS: Win7, Vista, 2k3, 2k8, XP, Linux, FreeBSD, OSX, etc. etc.

Posted 22 August 2013 - 20:48

yes if one of your interfaces is gig, then it should auto cross.

With just a cable between your machines, its unlikely you have dhcp server to give the interfaces IP.. So they would most likely just use APIPA.. Which means if the interfaces are set for dhcp and no dhcp server answers they will just give themselves a random IP.

So something starting with 169.254.x.x

Look on both machines do they get these addresses? Can you ping the other machines 169.254 address?

Why type of network did you tell windows this connection was, home/work/public ? Did you enable file sharing? How are you trying to access the file shares on the other machine? If you setup for public on the connection, the firewall would block any access. Would not be discoverable and would not announce itself to any browse list, etc.

yes its pretty much plug and play, but you have to have a basic understanding of what your doing ;)

Plug in your machines - set the connection as HOME.. And enable file sharing.. Now can you ping the other machine by IP, can you ping by name?

what do you get if you do net view \\computername or \\ipaddress on one machine?

#3 OP Lamp0

Lamp0

    Neowinian Senior

  • Joined: 14-December 08

Posted 22 August 2013 - 22:14

yes if one of your interfaces is gig, then it should auto cross.

With just a cable between your machines, its unlikely you have dhcp server to give the interfaces IP.. So they would most likely just use APIPA.. Which means if the interfaces are set for dhcp and no dhcp server answers they will just give themselves a random IP.

So something starting with 169.254.x.x

Look on both machines do they get these addresses? Can you ping the other machines 169.254 address?

Why type of network did you tell windows this connection was, home/work/public ? Did you enable file sharing? How are you trying to access the file shares on the other machine? If you setup for public on the connection, the firewall would block any access. Would not be discoverable and would not announce itself to any browse list, etc.

yes its pretty much plug and play, but you have to have a basic understanding of what your doing ;)

Plug in your machines - set the connection as HOME.. And enable file sharing.. Now can you ping the other machine by IP, can you ping by name?

what do you get if you do net view \\computername or \\ipaddress on one machine?

 

Ok so both machines have the 169.254.x.x ip, and both machines say "Unidentified network" & "Public network". When I do a net view \\computername or \\ipaddress I get, "system error 53 has occurred. The network path was not found."

 

On the windows 7 machine, when I click on the bench icon in the network map, under "network & sharing center" it brings me to the network "directory" & a message under the toolbar says "File sharing is turned off. Some network computer and devices might not be visible." If I click on that it will ask me if I want to turn on network discovery & public file sharing. Which I assume I shouldn't do?

 

How can I change the connection to a HOME one?

 

Also I have private filesharing on & can access it through the wi-fi.

 

Thanks!



#4 +BudMan

BudMan

    Neowinian Senior

  • Tech Issues Solved: 89
  • Joined: 04-July 02
  • Location: Schaumburg, IL
  • OS: Win7, Vista, 2k3, 2k8, XP, Linux, FreeBSD, OSX, etc. etc.

Posted 23 August 2013 - 01:49

"I have private filesharing on & can access it through the wi-fi."

What? So are these devices both connected to the same wifi network? Your router? If that is the case why don't you just wire them both to your router? Then you don't have to work with the whole APIPA thing?

To change it to HOME connection..

windows 7

changenetworktypewindows7.png

Windows 8 if it shows public -- its a bit more involved

run gpedit.msc

Computer Conf - Windows Settings - Security - Network List Manager

windows8.png

#5 OP Lamp0

Lamp0

    Neowinian Senior

  • Joined: 14-December 08

Posted 23 August 2013 - 17:16

I can't seem to get that dialog on Windows 7. The "Public network" text under the "Unidentified network" isn't Clickable(or blue) like the "Home network" text is in your shot.

 

On Windows 8 I don't seem to have gpedit.msc, which I assume means I don't have the required version of Windows 8 :/ .

 

I don't know if there is another way but I looked up the registry edit:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\NetworkList\Profiles\

Open the network profile that you want to change and modify the "Category" value:

0 = public
1 = private
2 = domain

"I have private filesharing on & can access it through the wi-fi."

What? So are these devices both connected to the same wifi network? Your router? If that is the case why don't you just wire them both to your router? Then you don't have to work with the whole APIPA thing?
 

 

Honestly I have never even considered that. I've never even done that before. I don't nesscarily need to transfer files right now though, I've just always had great difficulty getting this to work, & I am interested to learn how to get it working!



#6 OP Lamp0

Lamp0

    Neowinian Senior

  • Joined: 14-December 08

Posted 23 August 2013 - 17:58

So I ran this "Fix  it" thing on Windows 7 machine:

 

http://support.micro....com/kb/2578723

 

It said it couldn't fix it, but I seem to be able to connect & transfer files now, yet the network is still labeled as "Unidentified network" & "Public network". And my sharing settings are turned off for public network discovery & filesharing....

 

I am very confused now...

 

It works though. but the transfer speeds seem to be slower than transfering over wireless??



#7 +BudMan

BudMan

    Neowinian Senior

  • Tech Issues Solved: 89
  • Joined: 04-July 02
  • Location: Schaumburg, IL
  • OS: Win7, Vista, 2k3, 2k8, XP, Linux, FreeBSD, OSX, etc. etc.

Posted 23 August 2013 - 18:30

And you sure your just not using your wireless network?

If you want - and both these machines can get to the internet. Lets schedule some time for a TeamViewer session.. Set it up so can get into both machines and will take a look see.

We can chat while doing it, you can see everything I do and will be much faster than going back and forth via messages.

Unless there is something really wrong with your machines.. It should be click click working.. As to your speed.. I assume nic is gig at min or crossover wouldn't work.

If both are gig you should be seeing 30MBps file xfer.. If one is 100, then you would be limited to 10MBps Still much faster than wireless.