Jump to content



Photo

Tips on how to slightly improve wifi video streaming?


  • Please log in to reply
8 replies to this topic

#1 moeburn

moeburn

    tracer bullet

  • Joined: 10-March 04
  • Location: Toronto, Ontario

Posted 28 September 2013 - 21:46

I have a WNDR3700v2 Netgear router, running Gargoyle/OpenWRT, with an attached NAS usb hard drive.  I like to stream tv shows and movies off said usb hard drive to my laptop/phone in my shed in the back yard while I have a smoke.  Right now, it works 90% of the time.  But every now and then, if the wind blows the wrong way or there's a solar flare or god knows what, the streaming cuts out and pauses for 1-2 minutes, which is really annoying.  It happens every 10 minutes or so.  But for the other 9 minutes, the video streams just fine. 

 

This happens regardless of the file's bitrate, whether it is a highly compressed 70mB 22min mp4, or a high bitrate 720p 500mB 22min mkv.  I have OpenWRT on the router, so I can access every low level wifi setting that exists, including using channels 12 and 13 which I believe are banned here in Canada.  The Atheros chipset has a hardware limit on the wifi dB gain, and it is currently set to max in the software.  The router is dual band 2.4ghz/5ghz, but the 5ghz is totally useless because we keep the router in the 2nd floor of our house, and you practically have to be in the same room as the router to use the 5ghz band.  So I keep it disabled.

 

I can only ever get a 65mbit connection out of the 2.4ghz, even though it is 300mbit capable.  Even if I turn off every single device except for an 802.11n laptop/phone, they still can't connect at anything higher than 65mbit.  No idea why, not sure if it affects range or not, but if it doesn't then I don't care, I just need a little extra range.  The router is currently set to b/g/n 2.4ghz mode.  I have tried 20mhz bandwidth, and both 40mhz upper and lower dual bandwidths, on every channel combo I could think of.  I'm pretty sure I have the best combo, channel 2 with the second band on the upper half.  

 

I have also tried making the foil directional antennas.  They seem to be great at blocking the wifi signal, but horrible at reflecting it.  It doesn't matter what shape or how I position a home-made foil wifi reflector antenna, it just makes the signal worse. 

 

It is definitely not a CPU speed limitation, the router is more than powerful enough to stream HD video, and htop confirms that the samba protocol daemon is only using ~20% of the CPU when streaming HD video.

 

This router does not accept threaded antenna extensions, because it uses that new antenna technology where the antennae are super small (actually just a bunch of copper pads on the PCB), but sized perfectly optimized to the wifi chipset or something like that.  So adding a bigger antenna, without measuring it to be exactly a fraction of the built in antenna's size, would just make the transmission strength worse.

 

So aside from adding an antenna, does anyone have any tips on how I can stream video out to my shed without these connection dropouts?  Either just by boosting the signal strength a little, or configuring the router for wifi video streaming better?  I've tried: setting the dB gain in software to max, using different channels, using different wifi configurations, making DIY foil antenna reflectors




#2 remixedcat

remixedcat

    meow!

  • Tech Issues Solved: 1
  • Joined: 28-December 10
  • Location: Vmware ESXi and Hyper-V happy clouds
  • OS: Windows Server 2012 R2
  • Phone: I use telepathy and cat meows to communicate

Posted 29 September 2013 - 15:18

Scan for congestion using InSSIDer and see if you are running on a congested WLAN channel. 



#3 +BudMan

BudMan

    Neowinian Senior

  • Tech Issues Solved: 74
  • Joined: 04-July 02
  • Location: Schaumburg, IL
  • OS: Win7, Vista, 2k3, 2k8, XP, Linux, FreeBSD, OSX, etc. etc.

Posted 29 September 2013 - 16:13

Why would you be set to b/g/n - do you really have B devices around?  I doubt it..  Change to g/n or just N if all you have is newer equipment.



#4 OP moeburn

moeburn

    tracer bullet

  • Joined: 10-March 04
  • Location: Toronto, Ontario

Posted 29 September 2013 - 16:54

Why would you be set to b/g/n - do you really have B devices around?  I doubt it..  Change to g/n or just N if all you have is newer equipment.

 

I do not have a G/N option.  Here are the options I have:

 

- Dual Band

- N+G+B

- N+A

- G+B

- B

 

I'm not even sure what 802.11a is.  But I'm pretty sure we have some g-only equipment, like a wireless printer, and an old laptop that still gets heavy use.



#5 vcfan

vcfan

    POP POP RET

  • Joined: 12-June 11

Posted 29 September 2013 - 16:56

putting a bigger antenna doesn't make reception better,it actually makes it worse because the antenna is no longer resonant at the wifi frequency. To have better gain, you have to add antennas, not change the size(unless you change the type). The reason why those threaded antennas look bigger than the internals is because they are full wave monopole antennas. the internal ones are half wave dipoles. 

 

about the foil antenna, was it parabolic? because if it isn't parabolic or if you're using the incorrect focal point, you're damn right your signal will be degraded. signals from different phases(because of reflections) will mix together and create nulls, meaning in certain points in your signal, there will be no signal because a positive wave and a negative wave will basically cancel out to nothing.

 

the best method is to use a real satellite dish, you don't need bigger than 18",and use the correct focal point.



#6 OP moeburn

moeburn

    tracer bullet

  • Joined: 10-March 04
  • Location: Toronto, Ontario

Posted 29 September 2013 - 16:58

putting a bigger antenna doesn't make reception better,it actually makes it worse because the antenna is no longer resonant at the wifi frequency. To have better gain, you have to add antennas, not change the size(unless you change the type). The reason why those threaded antennas look bigger than the internals is because they are full wave monopole antennas. the internal ones are half wave dipoles. 

 

about the foil antenna, was it parabolic? because if it isn't parabolic or if you're using the incorrect focal point, you're damn right your signal will be degraded. signals from different phases(because of reflections) will mix together and create nulls, meaning in certain points in your signal, there will be no signal because a positive wave and a negative wave will basically cancel out to nothing.

 

the best method is to use a real satellite dish, you don't need bigger than 18",and use the correct focal point.

 

I did mention everything you just said in my first post, that I cannot add an antenna because it would no longer be resonant.  

 

I never made a foil antenna.  I made a foil reflector.  I tried both parabolic and flat, although I never did any precise measurement.



#7 vcfan

vcfan

    POP POP RET

  • Joined: 12-June 11

Posted 29 September 2013 - 17:07

I did mention everything you just said in my first post, that I cannot add an antenna because it would no longer be resonant.  
 
I never made a foil antenna.  I made a foil reflector.  I tried both parabolic and flat, although I never did any precise measurement.


I know youre talking about the transmitter when you say reflector, its still called an antenna. measurements are important,because if it isn't perfectly parabolic, then it will be even worse as most of your signal will bounce out of range. flat is also not good for the phase reasons I mentioned earlier.



#8 +BudMan

BudMan

    Neowinian Senior

  • Tech Issues Solved: 74
  • Joined: 04-July 02
  • Location: Schaumburg, IL
  • OS: Win7, Vista, 2k3, 2k8, XP, Linux, FreeBSD, OSX, etc. etc.

Posted 29 September 2013 - 19:12

A is 5ghz..  So quite often you will have to enable that if you want to use dual band.

 

Didn't you say you were running openwrt?

 

http://wiki.openwrt....oc/uci/wireless

11ng (11N+11G, 2.4GHz, mac80211 only), 11na (11N+11A, 5GHz, mac80211 only)

 

under hwmode.



#9 OP moeburn

moeburn

    tracer bullet

  • Joined: 10-March 04
  • Location: Toronto, Ontario

Posted 29 September 2013 - 19:37

A is 5ghz..  So quite often you will have to enable that if you want to use dual band.

 

Didn't you say you were running openwrt?

 

http://wiki.openwrt....oc/uci/wireless

11ng (11N+11G, 2.4GHz, mac80211 only), 11na (11N+11A, 5GHz, mac80211 only)

 

under hwmode.

 

Thanks!  I'm actually running Gargoyle, which is a frontend for OpenWRT.  I just listed the only options it gave me in Gargoyle's WebUI dialog flyout.  But if I can edit some low-level config to change it to N+G 2.4ghz only mode, I will give that a try.  But I thought that even if you were running in N+G+B mode, you could still get 300mbit N connections as long as you didn't have any devices running in B or G mode?

 

EDIT: Even though my Gargoyle's web UI is set to B+G+N mode, /etc/config/wireless doesn't mention anything about B:


config wifi-device 'radio0'
	option type 'mac80211'
	option hwmode '11ng'
	option macaddr 'e0:91:f5:cc:35:de'
	list ht_capab 'SHORT-GI-40'
	list ht_capab 'TX-STBC'
	list ht_capab 'RX-STBC1'
	list ht_capab 'DSSS_CCK-40'
	option htmode 'HT40+'
	option channel '2'

config wifi-device 'radio1'
	option type 'mac80211'
	option channel '36'
	option hwmode '11na'
	option macaddr 'e0:91:f5:cc:35:e0'
	option htmode 'HT20'
	list ht_capab 'SHORT-GI-40'
	list ht_capab 'TX-STBC'
	list ht_capab 'RX-STBC1'
	list ht_capab 'DSSS_CCK-40'

config wifi-iface 'ap_g'
	option device 'radio0'
	option mode 'ap'
	option network 'lan'
	option ssid 'xxxxxxxxxxxx'
	option encryption 'psk2'
	option key 'xxxxxxxxxxxx'


I gather from this config that radio0 is my 2.4ghz hardware, radio1 is my 5ghz hardware, and wifi-iface is set to use radio0 only.  radio0 was already set to 11ng mode, even though Gargoyle lists it as 11bng mode.  How very odd.





Click here to login or here to register to remove this ad, it's free!