Jump to content



Photo

Windows 8.1 search causes explorer.exe to spike to 100% CPU

Answered Go to the full post

  • Please log in to reply
11 replies to this topic

#1 GarakObama

GarakObama

    Neowinian

  • Joined: 23-October 12

Posted 17 October 2013 - 15:38

As soon as anything is typed into search the process uses 100% CPU. It slows down the whole system and even typing in search slows to the point where I'm waiting for keys I've pressed to show up. It stops using up CPU about a minute or so after the search thing is closed. It happens everytime I try to use search.

 

HP Ultrabook

Intel i5 3317U

8GB RAM

500GB HDD + 32GB msata SSD



Best Answer +snaphat (Myles Landwehr) , 23 December 2013 - 05:50

So, I just noticed this topic when I was discussing Windows 8.1 search issues in a newer thread.

 

Here's the possible solution:

http://superuser.com...pu-usage-at-100

Go to the full post



#2 jmc777

jmc777

    Neowinian

  • Joined: 01-July 03
  • Location: Scotland

Posted 17 October 2013 - 17:25

I experienced this as well. Seems to be ok now though.  :/



#3 freak180

freak180

    Mr. GreatDisaster

  • Joined: 02-December 08
  • Location: Philadelphia, PA
  • OS: Windows 8 Pro 64-bit

Posted 17 October 2013 - 17:28

Im sure you have to tweak a few things or clean your system. (temp update files)



#4 acido00

acido00

    Software Developer

  • Joined: 22-June 04

Posted 17 October 2013 - 17:36

Run CCleaner and remove all temp, fix register, etc.

 

After I that it worked for me, very good



#5 Roger H.

Roger H.

    Neowinian Senior

  • Tech Issues Solved: 22
  • Joined: 18-August 01
  • Location: Germany
  • OS: Windows 8.1
  • Phone: Nexus 5

Posted 17 October 2013 - 18:08

Don't think any of that stuff makes a diff, as I mentioned in another thread. Newer versions of Windows will rebuild some stuff after major updates which is why people were complaining that Vista was so slow. They backed off the throttle in Windows 7 but the process is still there. So yeah, just ignore it for the first few days.



#6 jmc777

jmc777

    Neowinian

  • Joined: 01-July 03
  • Location: Scotland

Posted 17 October 2013 - 18:31

For me, Event Viewer shows some "corrupted data files in the index" errors, which seemed to have been fixed by rebuilding the search index.



#7 Anibal P

Anibal P

    Neowinian

  • Tech Issues Solved: 1
  • Joined: 11-June 02
  • Location: Waterbury CT
  • OS: Win 8.1
  • Phone: Android

Posted 17 October 2013 - 18:42

Don't think any of that stuff makes a diff, as I mentioned in another thread. Newer versions of Windows will rebuild some stuff after major updates which is why people were complaining that Vista was so slow. They backed off the throttle in Windows 7 but the process is still there. So yeah, just ignore it for the first few days.

 

This plus it will have to reindex your drive after the update also, gonna take some time



#8 OP GarakObama

GarakObama

    Neowinian

  • Joined: 23-October 12

Posted 17 October 2013 - 20:07

I have run CCleaner already. In Control Panel>Searching and Indexing the only location I have set it to search is the Start Menu items. I have clicked the rebuild button.

 

I found this post from the 8.1 Preview period. It seems like a bug that didn't get fixed.



#9 DwindleFlip

DwindleFlip

    Resident One Post Wonder

  • Joined: 17-October 13

Posted 18 October 2013 - 05:39

I have this same exact problem. It makes no sense, and Windows 8.1 runs worse than 8 :( 



#10 +snaphat (Myles Landwehr)

snaphat (Myles Landwehr)

    Electrical & Computer Engineer

  • Tech Issues Solved: 29
  • Joined: 23-August 05
  • OS: Win/Lin/Bsd/Osx
  • Phone: dumb phone

Posted 23 December 2013 - 05:50   Best Answer

So, I just noticed this topic when I was discussing Windows 8.1 search issues in a newer thread.

 

Here's the possible solution:

http://superuser.com...pu-usage-at-100



#11 OP GarakObama

GarakObama

    Neowinian

  • Joined: 23-October 12

Posted 27 December 2013 - 00:29

The solution by nhkhanh worked for me. I removed all of the folders in Libraries. I tried adding AppData\Local\Packages to the index but it didn't work. I didn't try the whole AppData folder because it takes forever to index it.

 

 

Adding the AppData folder back to the Search-Index is not working for me. But after inspecting with Process Monitor, I found out that Explorer will continue search all files and folders in Libraries (which is disable by default in Windows 8.1) until it is completed. Bring Libraries back by http://lifehacker.co...-8-1-1446756473 and remove all folders in Libraries or add them to Search-Index.



#12 +snaphat (Myles Landwehr)

snaphat (Myles Landwehr)

    Electrical & Computer Engineer

  • Tech Issues Solved: 29
  • Joined: 23-August 05
  • OS: Win/Lin/Bsd/Osx
  • Phone: dumb phone

Posted 27 December 2013 - 00:34

The solution by nhkhanh worked for me. I removed all of the folders in Libraries. I tried adding AppData\Local\Packages to the index but it didn't work. I didn't try the whole AppData folder because it takes forever to index it.

 

Good post, I just tried that and I think it does work better for me than the AppData solution also.