Jump to content



Photo

  • This topic is locked This topic is locked
5 replies to this topic

#1 jebus197

jebus197

    Neowinian

  • Joined: 08-March 07

Posted 22 December 2013 - 14:54

OK this is one for all of the guys on here who came on about a year ago or so 'screaming' at me and trying to force me to reinstall my Windows 8, over what was a relatively minor, although no less anoying bug at that time. These guys practically accused me of "lying" and denied that any such bug could possibly exist - and even though it was a very small/anoying bug, for the vast majority of them the only possible solution was to 'reinstall windows'. Clearly they imagined because they knew how to do this, this made them 'tech experts.' Never mind the fact that reinstalling windows is as best a basic skill that requires almost no knowledge at all, or the fact that reinstalling windows has been shown in many cases not to be effective in this bug. Nor it seems did the concept of 'sticking with a problem' and 'troubleshooting' in order to get to the bottom of it, seem to have any meaning to them. You learn nothing by reinstaling, even if sometimes it might seem faster.

Anyway, that's all water under the bridge. The reason I am here today is to report that I have now resolved this problem on the affected system 100%. Yes it took nearly a year and a lot of persistence and a lot of effort, but hey I learned something useful in the end.

To understand this bug you can look here:

https://social.techn...forum=w7itproui

and here:

https://encrypted.go...lorer windows 8

which all in all is a llot of chatter about a bug a lot of people on here implied was a figment of my imagination. However it was the technet thread above that finally caught my attention. On here I found two possible solutions I had never seen before.

These were:

"Turn off Windows write-cache buffer flushing", by  Noel Carboni at the start of this thread and the registry key fix proposed by user Lurkout:
 

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Update]
"UpdateMode"=dword:00000000

I won't go over them all again here as they are both on the first page of this thread, my pupose here is simply to point anyone else who is stumped and who is looking for a solution to this problem in the right direction. Apparently there's no reason why the second of these fixes should work, as "UpdateMode" has something to do with group policy (second hand information, so I'm not sure how accurate this is), But anyway this seemed to do the trick for me. In my case there was a slight variation in that as my sytem is 64 bit I used a qword instead of a dword, but all the same it worked fine. (After a reboot).

I also tried the first fix and then forgot I had done this, so to be fair I am not certain at this time which of these fixes was responsible for sorting this issue. But at least I have a much better clue than I did before. I have also included the first fix as it seemed to deliver a significant performance boost, as my system has gone from a two year windows install type sluggish, to almost 'snappy' after this setting was enabled. It might not be safe on desktops without UPS, but on laptops (particularly if they are set to hibernate on low batttery power) or UPS enabled systems, it should be fine.

Of course this fix might not work for everyone, but that thread is packed full of possible solutions, so well worth a visit anyway. My guess is that this probably will work in most cases however.

Anyway, like I said, every day you learn something new.




#2 OP jebus197

jebus197

    Neowinian

  • Joined: 08-March 07

Posted 22 December 2013 - 14:56

Anyway a Mod can mark this as 'solved' if they wish.



#3 Studio384

Studio384

    Neowinian

  • Tech Issues Solved: 1
  • Joined: 06-July 12
  • OS: Windows 8.1 Pro
  • Phone: Windows Phone 8.0 GDR3

Posted 22 December 2013 - 15:13

Uhm, where is this about. I'm sorry but I'm a little bit out of context, can you give a link to the topic you referenced too?



#4 Pam14160

Pam14160

    Lee

  • Joined: 12-November 07
  • Location: Idaho

Posted 22 December 2013 - 15:16

O'boy another one of those I told you so. . .



#5 OP jebus197

jebus197

    Neowinian

  • Joined: 08-March 07

Posted 22 December 2013 - 15:27

O'boy another one of those I told you so. . .

More like 'probably more than half the people on here don't have a clue what they are talking about'. Anyway come on now, be a little bit generous. Some points for persistence please.

 

A bigger point to this thread however and a more serious purpose is to show aspiring tech-heads the value of persisting with a problem and troubleshooting, as opposed to just reaching for the 'nuclear' option of reinstalling every time they encounter even a minor problem. This in my view has become an all to common 'Microsoft Mantra' to cure all PC related ills.

Moreover the thread does have a serious purpose, as having serached on here previously when I encountered my own difficulties and having found nothing, now there is a placeholder for anyone performing a similar search that may offer a viable solution.

Given that I have been around since the very early days on Neowin (although my current profile doesn't illustrate this) and given that in the old days there used to be a lot of very impressive and knowledgable tech types on here, it seems the least I could do.



#6 Eric

Eric

    Neowinian Senior

  • Tech Issues Solved: 11
  • Joined: 02-August 06
  • Location: Greenville, SC

Posted 22 December 2013 - 15:29

[Thread closed]

There doesn't seem to be a question or answer here?



Click here to login or here to register to remove this ad, it's free!