Jump to content



Photo
Answered Go to the full post

  • Please log in to reply
8 replies to this topic

#1 MariosX

MariosX

    The man with no dreams

  • Joined: 20-July 06
  • Location: Dreamless Land
  • OS: Windows 7 x64

Posted 29 January 2014 - 07:49

Hello!

I've been encountering a Windows 8.1 Annoyance in the last months with the custom short date format.

Apparently the Date is not being shown, for more info check the screenshots

 

 

 

How do I fix this? I want to use my own custom date format and that does it on particular days such as Wednesday

Attached Images

  • 1.png
  • 2.png


Best Answer +virtorio , 29 January 2014 - 08:51

The Clock seems to have a max length for date strings it can display. If it reaches the limit it either seems to not attempt to display the date, or increases the Clock size and still not display the date.

 

Your closest option is to use the shorter month format like this: "dddd, dd MMM yyyy" because you're most likely to hit the limit on months with long names.

 

That'll display something like '‎Wednesday, ‎29 ‎Jan ‎2014', and not hit the character length limit.

 

It's also worth mentioning that using a long date format for the short date format setting can result in unpredictable behaviour in various programs (e.g. a program might use this format to display a date on a display box, but not provide enough room to display a date in the long date format, because they're expecting a short date.)

Go to the full post



#2 +virtorio

virtorio

    4089 III

  • Tech Issues Solved: 9
  • Joined: 28-April 03
  • Location: New Zealand
  • OS: OSX 10.9, Windows 8.1
  • Phone: Samsung Galaxy SIII

Posted 29 January 2014 - 08:51   Best Answer

The Clock seems to have a max length for date strings it can display. If it reaches the limit it either seems to not attempt to display the date, or increases the Clock size and still not display the date.

 

Your closest option is to use the shorter month format like this: "dddd, dd MMM yyyy" because you're most likely to hit the limit on months with long names.

 

That'll display something like '‎Wednesday, ‎29 ‎Jan ‎2014', and not hit the character length limit.

 

It's also worth mentioning that using a long date format for the short date format setting can result in unpredictable behaviour in various programs (e.g. a program might use this format to display a date on a display box, but not provide enough room to display a date in the long date format, because they're expecting a short date.)



#3 MiniMeSorinel

MiniMeSorinel

    I aim to misbehave.

  • Joined: 27-October 05
  • Location: Bucuresti, ROU
  • OS: Windows 8.1 Pro
  • Phone: Nokia Lumia 520

Posted 29 January 2014 - 09:51

I don't really understand what you want to do, but i do know that windows does not display the date when using small icons in taskbar.



#4 Steven P.

Steven P.

    aka Neobond

  • Tech Issues Solved: 56
  • Joined: 09-July 01
  • Location: Neowin HQ

Posted 29 January 2014 - 10:01

SNAG-0001.png

 

works for me?



#5 +Frank B.

Frank B.

    Member N° 1,302

  • Tech Issues Solved: 6
  • Joined: 18-September 01
  • Location: Frankfurt, DE
  • OS: OS X 10.9.2
  • Phone: Nexus 5

Posted 29 January 2014 - 10:05

I don't really understand what you want to do, but i do know that windows does not display the date when using small icons in taskbar.

^ that'd be why. It'll display when you set the superbar to full size.



#6 Steven P.

Steven P.

    aka Neobond

  • Tech Issues Solved: 56
  • Joined: 09-July 01
  • Location: Neowin HQ

Posted 29 January 2014 - 10:09

Oops, missed that..



#7 +virtorio

virtorio

    4089 III

  • Tech Issues Solved: 9
  • Joined: 28-April 03
  • Location: New Zealand
  • OS: OSX 10.9, Windows 8.1
  • Phone: Samsung Galaxy SIII

Posted 29 January 2014 - 11:39

^ that'd be why. It'll display when you set the superbar to full size.

That is true, but in this case the date is reaching the string size limit.

Attached Images

  • date.jpg


#8 OP MariosX

MariosX

    The man with no dreams

  • Joined: 20-July 06
  • Location: Dreamless Land
  • OS: Windows 7 x64

Posted 29 January 2014 - 16:19

Can I change those limits via registry?



#9 +virtorio

virtorio

    4089 III

  • Tech Issues Solved: 9
  • Joined: 28-April 03
  • Location: New Zealand
  • OS: OSX 10.9, Windows 8.1
  • Phone: Samsung Galaxy SIII

Posted 29 January 2014 - 19:01

Can I change those limits via registry?

I'm afraid not.





Click here to login or here to register to remove this ad, it's free!