Sign in to follow this  
Followers 0
Phouchg

Lynx Point and Haswell Refresh

3 posts in this topic

Having a bit of trouble here with Asus B85M-G (rev. 1.01) and the "new" Core i5-4460. More precisely, two such boards and two such CPUs. Updated both boards to v908, v904 and v905, in that order, using Pentium G3430, but swap it out for H-R and it simply doesn't work - there's no signal from built-in or discrete video, no beeps. Generally they don't POST.

 

Both CPUs work with Asrock B85M-HDS (v1.30, supports H-R from the factory). All three boards work with aforementioned Pentium G.

 

Anyone got any ideas, experience? I mean, it's doubtful that anyone reading has got this exact setup, but just generally - getting Haswell Refresh to work on Lynx Point?

I think every manufacturer went ahead and said - yeah, they'll work, just update BIOS. That was the case with Cougar Point and Ivy Bridge and I never had any hiccups.

 

I mean, it's right there on the damn support list and there's been two more BIOS updates. Could it be that Asus drop the ball so hard?

Share this post


Link to post
Share on other sites

im not familiar w/ Lynx Point.

 

also, you flashed the BIOS from 908, to 904, to 905? is that just a typo?

Share this post


Link to post
Share on other sites

It had 705 from factory. Before even starting the build I looked up the support list, which says "since 904". I just took the latest - 908.

When it didn't work, I went and tried previous versions that should have supported H-R, namely 904 and 905, in hopes that some mystery bug might have creeped in 908.

 

Anyway, had no choice, but to solve the problem using i5-4440 instead, to get the build out of the door.

 

Leaves a sour taste...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.