Jump to content



Photo

Access DB not opening.

access

  • Please log in to reply
4 replies to this topic

#1 StrikedOut

StrikedOut

    Outside the box

  • Joined: 09-December 08
  • Location: Southampton

Posted 20 June 2014 - 12:16

Hi All.

 

We have a couple of users that need to access an old Microsoft Database created in Access 2000 which has a security (mdw) file associated to it. They are using Access 2010 and I have created a shortcut with the following target.

 

"C:\Program Files (x86)\Microsoft Office\Office14\MSACCESS.EXE" "O:\Programme Files\Orange Structures 2000 O.mdb" /wrkgrp "O:\Programme Files\Opcs_DB.mdw"

 

O:\ is the correct mapped drive and I have also swapped this out for \\Sever\Programme Files\etc on both folder targets and still get the following error.

 

You do not have the necessary permissions to use the O:\Programme Files\Orange Structures 2000 O.mdb object. have your system administrator or the person who created this object establish the appropriate permissions for you.

 

This was working until the beginning of this week. nothing on the server has changed, the users PC's have not changed and the folder permissions are correct and working (tested by creating a folder in the same location).

 

The users are on Win7 SP1 and Win8.1, both with all updates and Access 2010 has all of its updates too. Something else that may cause a problem is that we are using Office 365 so they also have Office 2013 installed too but from what I have read I cant use 2013 Access to see this database.

 

Any thoughts on why this has all of a sudden stopped working?




#2 Hum

Hum

    totally wAcKed

  • Tech Issues Solved: 10
  • Joined: 05-October 03
  • Location: Odder Space
  • OS: Windows XP, 7

Posted 20 June 2014 - 12:24

Some recent Update may have changed Permissions.

 

Maybe software like this could help you:

 

http://www.softpedia...Extension.shtml

 

http://www.howtogeek...-menu-in-vista/



#3 +BudMan

BudMan

    Neowinian Senior

  • Tech Issues Solved: 96
  • Joined: 04-July 02
  • Location: Schaumburg, IL
  • OS: Win7, Vista, 2k3, 2k8, XP, Linux, FreeBSD, OSX, etc. etc.

Posted 20 June 2014 - 12:44

What I don't understand is why would this database still be 2000, if your users are 2010 - why was the database not updated??  Just freaking blows my mind how a "business" runs on stuff that came out in 1999..

 

What I suggest is get yourself an old version of access, open the file - remove the user level permissions with the use of .mdw and then convert this database to your current version of access and apply current methods of security that meet your needs.

 

Sorry but anything that allows you to continue to use a database in a format from 1999 is not the correct solution.



#4 +InsaneNutter

InsaneNutter

    Neowinian Senior

  • Tech Issues Solved: 4
  • Joined: 15-March 03
  • Location: Yorkshire, England
  • OS: Windows 8.1 & OSX 10.9
  • Phone: OnePlus One

Posted 20 June 2014 - 13:32

Try this:

1. Open a blank database
2. Press Ctrl + G
3. Run the command: DoCmd.RunCommand acCmdWorkgroupAdministrator
4. Join the Workgroup using the mdw file located at O:\Programme Files\Opcs_DB.mdw

If that works just save the database in the .accdb file format (Access 2007-2013) and you shouldn't have any more permission problems, any workgroup permissions are then removed when this is done however.

 

Later versions of access really don't like older databases with workgroup permissions i've found.

 

I recently converted some Access 97 databases to work in 2013. I had to take the databases to the 2000 file format, then to 2003 using Access 2003 before finally converting them to .accdb. using Access 2010. That was the only way i could actually get them in a usable state where Access 2013 would open them.

 

You will probably find your databases will work as they did in Access 2000, even any old switchboards will still work in Access 2013. About the only thing you loose is user permissions from the workgroup.



#5 OP StrikedOut

StrikedOut

    Outside the box

  • Joined: 09-December 08
  • Location: Southampton

Posted 20 June 2014 - 13:41

I have had the same conversation for a few years now and have tried more and more so over the past few months due to migrating to 365 but never get anywhere so I am stuck with this.

 

Fortunately one of our backups allowed access again and it is up and running. Who knows, perhaps they will sit up and listen the next time I tell them to export the data to a better format.

 

+InsaneNutter, will try that one too.