Jump to content



Photo

Halflife 2 issue: I've ascertained the problems exact location


  • Please log in to reply
2 replies to this topic

#1 chrisj1968

chrisj1968

    copyrighted!! ©

  • Tech Issues Solved: 3
  • Joined: 17-June 08
  • Location: United States

Posted 21 July 2014 - 22:29

Hello everyone! Sorry to bother you. I presented this problem before but now months later, I've located the exact location as to where I'm guessing is the shaders stop working. I still enjoy playing HL2 alot, probably one of the best storylines I've seen in a game.anyway on to the problem.

 

the shaders or whatever part of the game that deals with the lighting of the level happens right after the loading when I make the jump with the airboat off the large dam arriving at Eli's lab. I took the screenshot of the look, it looks so 90's but for some reason, the lighting or shaders appear to mis-load and it is a constant issue. I've deleted the local content in steam, then re-installed the game. But I can say 100% that it happens everytime.

 

Q: I know where the config.cfg file is, is there a command I can put in there to fix this issue?

 

I've played this game the last 10-15 times and can say it is at the point when I jump from the dam, the game loads then, whacko! there is no lighting to the level from that point on.

 

I appreciate ahead of time if anyone can possibly explain what is going on and how to get the work around going to fix this.

 

Thank you.

 

~Chris

 

idxjkk.jpg

 

I found this on youtube. gonna give it a try but this should NOT be happening. but if there's another is another better option excellent and thanks

 

In case you didnt get the commands, they are here, type them in the same order as I put them.
mat_dxlevel 90
mat_hdr_level 2
mat_hdr_enabled
mat_fullbright 0
If you get checkerboards after all this, try typing mat_dxlevel 80 after typing in all the above commands, thanks to João Victor F. S. Fernande for the possible solution, also notify me on wether or not this worked for you.

 




#2 OP chrisj1968

chrisj1968

    copyrighted!! ©

  • Tech Issues Solved: 3
  • Joined: 17-June 08
  • Location: United States

Posted 21 July 2014 - 22:43

hmm, the command mat_dxlevel 80 seems to have fixed the problem without all the other commands.

 

I'm going to investigate this more.

 

Q: does anyone know of an email address to correspond with the developers about this by chance?

 

~chris

 

After the mat_dxlevel 80 command alone

 

2mdkqq9.jpg



#3 OP chrisj1968

chrisj1968

    copyrighted!! ©

  • Tech Issues Solved: 3
  • Joined: 17-June 08
  • Location: United States

Posted 22 July 2014 - 21:14

Update*** 7/22/2014

 

to update on the previous posts and to help others, I'm making some educated guesses.

 

in the big picture:

 

I re-installed my laptop back to it's factory state with Windows 7. please note** this not is bashing windows 8/8.1 or up and coming 8.2.. they are good functioning OSes. What "seems to be the problem is the way the OS is involved, at whatever level in the "mat_dxlevel xx" aspect of the game. I can say with 100% confidence that with Windows 7 now, I have absolutely no lighting or is it shader issues. I'm supplying a screenshot in game to show that for some reason, my thinking is, the game was optimized somehow in such a way that somewhat works or could be hit or miss with Win 8/8.1. this issue started after I installed Win8 initially. Did they change the way games work with or the way Win8/8.1 runs games?

 

conclusion: I'm enjoying my halflife 2 again without any rendering issues. 

 

In Windows 7

pu8sn.jpg