Jump to content



Photo

Howto: Ubuntu dapper + internet connection sharing


  • Please log in to reply
No replies to this topic

#1 Z3r0

Z3r0

    Neowinian

  • Joined: 27-November 01

Posted 02 May 2006 - 07:45

This thread is slightly different to the last as it describes how to enable internet connection sharing over an ad-hoc network, as opposed to just connecting to an Ad-Hoc network with a static IP, I decided to put it into a seperate thread as it relates to configuring a seperate card and I didn't want the other thread getting too busy

My network is set up as so:

ADSL Router -> ethernet -> Dapper PC -> wireless -> Dapper Laptop

Here are the instructions on how to set up the Dapper PC to share the internet to lan clients:

Under the x86_64 Dapper beta 2, the network configuration program crashes, so I installed the i386 version of Dapper beta 2 and now it works.

My ethernet card, connected to the router, was already configured by DHCP, so all I had to do was set up the PCs ra0 card with a static IP address

This wasn't as simple as I thought, we can set it up with ubuntus network configuration manager and it will save the settings correctly to /etc/network/interfaces but it will not set it up as an Ad-Hoc network, to do this you must issue iwconfig ra0 mode Ad-Hoc
iwconfig ra0 essid Z3r0 #your essid here

My PC could now ping the laptop, the laptop could now ping the PC, but the laptop couldn't reach the internet through the PC, this requires another step

modprobe iptable_nat
iptables -t nat -A POSTROUTING -o eth0 -j MASQUERADE
echo 1 > /proc/sys/net/ipv4/ip_forward

The laptop can now access the internet

Finally add these commands to rc.local to execute on each bootup
iwconfig ra0 mode Ad-Hoc
iwconfig ra0 essid Z3r0 #your essid here
modprobe iptable_nat
iptables -t nat -A POSTROUTING -o eth0 -j MASQUERADE
echo 1 > /proc/sys/net/ipv4/ip_forward

Troubleshooting:
if you have wireless-mode Ad-Hoc in /etc/network/interfaces your PC will freeze the PC after logging in, do not put it in there, issuing post-up wireless-mode Ad-Hoc doesn't work and pre-up will cause the system not to boot
It is therefore necessary to add the command to rc.local as above.

I had a look at WEP, issuing iwconfig ra0 key s:1234567891011 works but the laptop and PC fail to communicate, I already know it works as the laptop was working with windows before with WEP, so I assume that the drivers are broken? or there is another unknown to me configuration option

--------------------------------------------------------------------------------------------------------------------------------
Just for clarity
/etc/network/interfaces should look like this:
auto lo
iface lo inet loopback

#The primary network interface configured via DHCP
auto eth0
iface eth0 inet dhcp

auto ra0
iface ra0 inet static
address 192.168.0.1
netmask 255.255.255.0
gateway 10.0.0.138 #my router

/etc/resolv.conf should look like this:
nameserver 10.0.0.138 #my router or your ISPs DNS server instead

----------------------------------­ ---------------------
If you are connecting directly to a router, try this
set up the ip etc in network manager with dhcp assigned address and WEP off
iwconfig ra0 mode managed #default
iwconfig essid youressid
iwconfig channel 6 #your channel
dhclient ra0 #get ip address from router, no need to issue ifconfig ra0 up/down, I suggest trying a static IP first though
ping 10.0.0.138 #your router

If that works add the iwconfig commands to /etc/rc.local to execute on bootup



Here are two wikis (with info about WPA/WPA2)

One for the AR5212

http://forums.whirlp...wiki&tag=ar5212

One for the RT61

http://forums.whirlp...a=wiki&tag=rt61

Enjoy:))

Edited by Z3r0, 15 May 2006 - 12:00.