Sign in to follow this  
Followers 0

Ubuntu: monitor turning off during boot?

18 posts in this topic

Posted (edited)

Basically I've decided to install linux on my oldish PC downstairs for my mother to use.

Installation was fine, but I seem to have a problem now.

When I turn the computer on, everything happen as it should up until where the boot screen starts. Sometimes It will boot as it should, but most of the time it will not. I usually a blank screen, followed the monitor turning off. Nothing I do makes it turn back on again (unless I restart the PC). It's not the monitor as it works with my other PC (and I've tried my other monitor with this PC and the same happens).

And I don't think its the video card as it worked fine with windows 98 on the same pc.

I've tried Ubuntu and Xubuntu (as it should be faster on older PC's), but the same thing happens. Any ideas?

It's using a Radeon 9200 btw, and I've tried both VGA and DVI.

thanks

Edited by WelshBluebird

Share this post


Link to post
Share on other sites

Posted

Try this if you can. It may help since it turns off all of the power saving features.

Edit your /etc/X11/xorg.conf in root mode and add the following lines:

Section "ServerFlags"

#other options can go here

Option "BlankTime" "0"

Option "StandbyTime" "0"

Option "SuspendTime" "0"

Option "OffTime" "0"

EndSection

Under this section just add the "false" after "DPMS" like it shows here.

Section "Monitor"

#other options can go here

Option "DPMS" "false"

EndSection

Share this post


Link to post
Share on other sites

Posted (edited)

Right before I tried that, I took out my wireless card, and it seems to be working fine now. Could be a coincidence though, so I'm going to try it with the wireless card back in it now.

Thanks for the input though, I may need a little more help if it won't work with the wifi card (it needs to use wifi, as the distance between the pc and the router is too much for a cable).

edit - so much for that. Put the wifi card in, didn't work. Taken it back out, and still the monitor turns off.

Will try what you suggested if I can get the thing to boot.

Edited by WelshBluebird

Share this post


Link to post
Share on other sites

Posted

If the screen "shuts off", chances are that the video card is outputting a video mode/frequency that the monitor cannot handle.

The quickest, easiest way to toggle resolutions in Linux is to use CTRL + ALT + [num pad plus] or [num pad minus] to step through the allowed modes until you get one that works (usually just a couple times will find one for you).

Share this post


Link to post
Share on other sites

Posted

Hi,

I also have been having the same problem, both with the alt cd and normal live cd both 64. I have tried to run recovery mode and can get to the root command line or whatever its called (im a complete noob, this is my first linux install). I tried to install the nvidia drivers but the program asks me to go into init 3 and then the problems starts again. This time though my monitor flashes a few times and then goes blank but does not turn off.

I also tried to to go to the file "etc/X11/xorg.conf" but when i run recovery mode the file is not there, maybe this is my problem but since this is my first ever install i have no idea, i wouldnt even know how to edit this file if it was there.

I would be very grateful if you have any sugestions.

By the way i have 2 nvdia 8600 GT cards which i normally run in sli mode in windows.

Share this post


Link to post
Share on other sites

Posted

First thing I would suggest to you is to not use the procedure from the nVidia site. While it does work, it does put Linux 'newbies' into modes that they will not be familiar and/or comfortable with.

Get your Linux to boot normally (with default video drivers), then use your package manager to point to the nVidia drivers, and install that way. No mess. No fuss. And keeps itself updated when you update your system. (Y)

Share this post


Link to post
Share on other sites

Posted

Many thanks for that, i shall keep that in mind, problem is i cant get into Ubuntu in the first place even with the default video drivers, my screen just turns itself off or i get a blacnk screen. I only tried to install the nvidia drivers to try and resolve the problem.

Share this post


Link to post
Share on other sites

Posted

That is covered by my earlier post. Try CTRL+ALT+[num pad plus] or [num pad minus] to switch between resolutions.

Share this post


Link to post
Share on other sites

Posted

i tried to re-install again but the problem is still the same, i tried the alt cd and installation went fine but when you chose to load Ubuntu the screen turns off again. I tried the CTRL + ALT thing but that has not worked. Do you think having 2 graphics cards with SLI bridge on could be possibly causing the problem? if not i have no idea what to do next, i guess ill just have to keep looking.

Share this post


Link to post
Share on other sites

Posted

If you have two cards, did you check the output of each card individually?

I don't have any SLI experience, I am afraid...

Share this post


Link to post
Share on other sites

Posted

Try hitting CTRL+ALT+F1. That should take you to a text-based terminal where you can login and edit your xorg.conf file using your favorite text-based text editor (vim FTW!!!!).

Share this post


Link to post
Share on other sites

Posted

How do i check the output of the card? the only screen i can get up is the root command prompt after you load in recovery mode, seems strange that i can install Ubuntu fine using alt cd but not be able to load into it.

Share this post


Link to post
Share on other sites

Posted

I have managed to find a few things that have worked for other people but not for me, some suggest changing the splash to nosplash in the GRUB booloader GUI. Others have pointed to editing the menu.lst in the boot directory but when i view mine it completely empty and i dont have a xorg.conf file either.

I know how to navigate through the different directories and edit file using nano now but im now at a complete loss.

Just to confirm what is happening and what ive tried:

I cant run the LIVE x86 amd 64 CD, it just hangs on a blank screen but the monitor remains on

I can install Ubuntu from the alt CD and install seem to go ok uo tp the point it asks you to remove the disk and reboot computer.

Just after the bootloader GUI after selecting Ubuntu the screen turns itself off but the computer seems to carry on loading

I have tried running reovery mode and can get a command prompt, as soon as i type init 3 etc Ubuntu starts to load but then the screen flashes a few times and goes black but stays on

I have tried using the CTRL+ALT+ -/+ to change resolution but nothing, also when i try to use CTRL+ALT+F2/F3/F4 etc i cant bring up any other consoles, CTRL+ALT+f1 is the only one available

xorg.conf is missing and menu.lst is missing.

My system is: AM2 6000, 320gb sata hd, corsiar 2gb 6400 memory, 2 x PCi-E Nvidia 8600gt running in SLI.

My dad has just installed with no problems and since we are both jsut starting to get into linux we want to run the same Linux if possible and i been told Ubuntu is a nice version to start with.

If you can help, thank you in advance.

Share this post


Link to post
Share on other sites

Posted

Peter, I'm pretty sure the nvidia cards are your problem. I have 3 different PC's in my house, each with a different nvidia card, and I have yet to have any distro be able to boot into any sort of graphical interface by default. My suggestion is in the terminal type "sudo dpkg-reconfigure xserver-xorg" answer the questions, and make sure to choose as your driver "vesa" (I've never had the opensource "nv" driver work) Once that's working and you have , enable the restricted drivers, and back in the terminal do "sudo nvidia-xconf". That should set you up for good drivers and all. Hope this helps, and good luck.

Share this post


Link to post
Share on other sites

Posted

Many thanks for that Mitch,

I did find that on another post and i think i set the drivers as VESA. Does that "enable restricted drivers"? I went through the xserver-xorg thing but its possible that I did something wrong in there.

As the only way to get a terminal is through recover, could this be a reason for my boot.lst been empty and xorg.conf missing?

I have also noticed that after you start recovery from the boot GUI you see the text showing whats its doing, An error does show but its so fast that i cant read it properly, i think it has something to with the PCI-E slot, is there a log file somewhere that would tel me what this error is?

Share this post


Link to post
Share on other sites

Posted

this is getting silly now.

I've tried around 5 distro's, and either they don't detect my wireless card, or will choose randomly not to boot.

If it won't boot, the splash screen of the distro will come up. It will start to load the OS, but then the monitor goes blank saying "no input". I've tried it on my other monitor too, so thats not the issue. Any idea? I can kinda see why linux isn't mainstream now.

Share this post


Link to post
Share on other sites

Posted

Yeah the new nvidia cards are a problem with Gutsy. This fix from the Ubuntu forums worked for me which I will copy here:

I found a solution that worked for me on kubuntuforums:

(before I did what follows, I used StartupManager to set the boot-splash resolution to 1024x768 16-bit)

edit /etc/initramfs-tools/modules

add the following

vga16fb

fbcon

vesafb

edit /etc/modprobe.d/blacklist-framebuffer

comment out the following (prefix with #)

blacklist vesafb

blacklist vga16fb

last but not least, run the following in a terminal

sudo update-initramfs -u

http://ubuntuforums.org/showpost.php?p=363...amp;postcount=9

This enabled all simple output (not sure of the technical term, ie. without nvidia drivers) to work including the boot screen and ttys. Remember to actually use startupmanager like the post says because I didn't and it broke Gnome somehow.

Ubuntu is probably the best distro for getting wireless to work. In fact I first heard of Ubuntu because of its good wireless support, even though it is all a hack really (a bit like windows).

Share this post


Link to post
Share on other sites

Posted

Something really awesome about ubuntu 8.10 is that it can be installed from windows, so what you can do is:

1) format your pc and install all drivers

2) download ubuntu 8.10, burn it, and run it from windows

3) with just one click you'll get ubuntu installed

4) your system will reboot and will run the live cd (just select there to boot from the next booting device)

5) you will be asked to start from ubuntu or windows (select ubuntu)

6) the system will finish the install

7) there you have ubuntu with all drivers installed

that's the way I did it and that's how it worked for me pretty awesome!

Edit:

btw... http://www.ubuntu.com/getubuntu/download

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.