Jump to content



Photo

Remote Desktop Issue, Sticky Keys Stuck On?


  • Please log in to reply
5 replies to this topic

#1 BAW

BAW

    MCP, MCDST

  • Joined: 28-March 04
  • Location: Birmingham, UK

Posted 16 May 2008 - 13:35

Hi All,

After installing SP3, which comes with Remote Desktop 6.0 i have been experiencing a problem.

When in remote desktop, it will be fine, and then randomly whenever i press the E key it will act as if sticky keys is stuck on, and so will open Explorer, or when i press D it will display the desktop.

Sticky keys is not enabled, neither are Filter Keys and i have double checked this. And this is not affected for anybody else running remote desktop 6, but i am using this with SP3, and i only have the issue?


#2 OP BAW

BAW

    MCP, MCDST

  • Joined: 28-March 04
  • Location: Birmingham, UK

Posted 21 May 2008 - 07:40

Anyone?

#3 Snafu

Snafu

    Neowinian

  • Joined: 06-October 03
  • Location: Newfoundland

Posted 21 May 2008 - 10:15

Typically it's the windows key that gets stuck for me when connecting over RDP. I Uuually load the on-screen keyboard on remote system and see if the key is on. Could be a similar fix for you.

#4 Coppertop

Coppertop

    Resident One Post Wonder

  • Joined: 02-February 09

Posted 02 February 2009 - 22:31

Typically it's the windows key that gets stuck for me when connecting over RDP. I Uuually load the on-screen keyboard on remote system and see if the key is on. Could be a similar fix for you.


Hi,

As found on experts-exchange:

"This is a bug in RDP client 6.0 (occasionally RDP 5.2 also showed that behaviour).
We asked MS, they know about the problem but they won't fix it. period.
Sometimes it helps to bash the Windows key or Alt or Ctrl multiple times.
It’s a Remote Desktop 6 bug which Microsoft don’t intend fixing it seems."

What did the trick for me:

"1. Close the RD window
2. Open new RD but make sure the "Apply Windows key Combinations" is set to "On the remote computer"
3. Now press the Ctrl+Alt+End and lock the computer
4. Log in again and it should work."

Happy days!

#5 Tom - MSFT

Tom - MSFT

    Resident One Post Wonder

  • Joined: 10-February 10

Posted 10 February 2010 - 19:50

The well-known problem regarding "stuck" CTRL+ALT key sequence has now been officially fixed for Vista and Server 2008/R2 client systems.
KB978829 has been published and addresses the fix in more detail.
The hotfix can be downloaded via the following URL:
http://support.microsoft.com/kb/978829

This problem manifests itself under the following conditions:
1. when connecting via Windows Remote Desktop Connection to a remote system (physical or virtual)
2. Locking the host machine (machine from which you are connecting) with CTRL+ALT+DEL sequence
3. Transient network disconnection occurs
4. Unlocking the host machine thereafter

Users find that typing the DEL key on the target machine (such as in a Word or notepad document) causes the target session to be locked as though CTRL+ALT+DEL had been typed.


A fix for XP SP3 is currently being proposed and analyzed, but no guarantees when or if it will be released, at this time.

#6 Granville@Skytrans

Granville@Skytrans

    Resident One Post Wonder

  • Joined: 10-March 10

Posted 12 March 2010 - 01:11

I found this in another forum but I forget which.

"There are often problems with ALT GR key combinations in the Remote Desktop client (mstsc.exe).

To make this work as expected for XP:

Control Panel -> Regional and Language Options -> Languages Tab -> Details Button

In the Dialog "Text Services and Input Languages" press the Button "Key Settings". If that button is disabled, just add another language with the "Add" button.

In the "Advanced Key Settings" dialog press "Change Key Sequence" for "Switch between input languages".

In the "Change Key Sequence" Dialog uncheck "Switch keyboard layout" and confirm the change through the series of dialogs.

Remove the extra language if you like."



Click here to login or here to register to remove this ad, it's free!