23 posts in this topic

Posted (edited)

Hi,

I just bought a MSI CX700 laptop with windows 7 home and I can't connect to my home wifi.
My modem only supports WEP, and my XP laptops connect fine.
but when i try it with my Windows 7 laptop. it says unable to connect, troubleshoot.
using the lan cable works fine tho.

Does anyone know how I can get it to connect?

Thanks Edited by RayJai

Share this post


Link to post
Share on other sites

Posted

put in the right wep key ;)

Are you trying to put in an ascii (password) version of your wep key, or the actual hex 10 or 26 character key?
1 person likes this

Share this post


Link to post
Share on other sites

Posted

[quote name='RayJai' date='25 January 2010 - 14:27' timestamp='1264429677' post='592153576']
Hi,

I just bought a MSI CX700 laptop with windows 7 home and I can't connect to my home wifi.
My modem only supports WEP, and my XP laptops connect fine.
but when i try it with my Windows 7 laptop. it says unable to connect, troubleshoot.
using the lan cable works fine tho.

Does anyone know how I can get it to connect?

Thanks
[/quote]

Something you may have overlooked\forgotten if you set it in the past, is MAC authentication on the router. I have this set on my home router and forget from time to time to set new connections MAC address' as allowed to connect...

Share this post


Link to post
Share on other sites

Posted

Thanks guys,

but i do all the networking around the house, so i know the WEP is correct.
and I don't have mac filter.

the thing is, when i see my SSID on the network list, i click it and W7 doesn't even ask for the WEP password, it just tries to connect and fails.
i see other people's wifi, they use WPA, when i try to connect it asks for the Password.

Share this post


Link to post
Share on other sites

Posted

[quote name='RayJai' date='25 January 2010 - 15:02' timestamp='1264431778' post='592153722']
Thanks guys,

but i do all the networking around the house, so i know the WEP is correct.
and I don't have mac filter.

the thing is, when i see my SSID on the network list, i click it and W7 doesn't even ask for the WEP password, it just tries to connect and fails.
i see other people's wifi, they use WPA, when i try to connect it asks for the Password.
[/quote]

Have you tried to manually setup the connection?

Share this post


Link to post
Share on other sites

Posted (edited)

Hmmm -- I found this thread, but find it unlikely to be honest.. And would would have to do some more research on it. And I don't have a windows 7 running where I could test it. It seems just asinine to not support WEP to be sure -- which is why I would be hesitant to trust this post... But it is the same issue your reporting - no password box on wep network, etc.

--
http://social.technet.microsoft.com/Forums/en/w7itpronetworking/thread/5268575e-5b93-4967-8eee-cfc05d99c1ae

Friday, November 13, 2009 2:59 AM
A long call with MS Tech Support for Networking has fixed the issue!!

[u]The problem is that Win7 will NOT utilize WEP security.[/u]

Guess it worked until my first updates, & then WEP was killed off, & wireless adapter would not connect.
[b]Password dialog box never came up, connection just failed.[/b]
The troubleshooting dialogs said everyt5hing was fine.
We changed the wireless router to WPA Personal security & all is well!
You should add this to your Knowledge Base.
--

hmmmmm - the only wireless card I have that I could test with is pcmcia based (so can not use in desktop), and the laptops I have are not running window7

here is yet another thread that states that W7 does not support wep.. Hmmm

http://www.<< spam >>.com/network-sharing/48417-w7-not-asking-passkey-when-connecting-wep-wifi.html
Windows 7 - W7 not asking for passkey when connecting to WEP wifi

And they even show a screen shot, and wep is not listed.. Hmmmmm

[attachment=249492:wep.jpg]

I will have to do some more research -- I agree that is an out dated protocol and not very secure and should not be used unless you have NO other choice, etc.. But to pull support for it all together seems asinine...

Again I find this unlikely that w7 would not support wep.. I think it falls under open, and then select wep.. Can you show us your settings for your manual setup. I think I can look on the setting of my w7 box even if no wireless?? Looking now. Does not seem like I even view the wireless dialog box without a wireless device.. So I can not look on my 7 machine to see what it lists under OPEN type of connection - I believe WEP would be here as an option. Edited by BudMan

Share this post


Link to post
Share on other sites

Posted (edited)

i can confirm wep works just fine in windows 7 its under no authentication in that list then under encryption type select wep Edited by Lathuc

Share this post


Link to post
Share on other sites

Posted

Try restarting the computer.... Had the problem the other day my laptop wouldn't connect to college's wireless.... restarted and it worked fine.

Share this post


Link to post
Share on other sites

Posted

Thanks,
but it's not working, i see WEP on the list.
and it connects when i turn WEP off.
but once i turn it back on, it fails.

Share this post


Link to post
Share on other sites

Posted

I still have this problem.
windows won't even let me put in a passkey.

Share this post


Link to post
Share on other sites

Posted

Put the wep key in manually before you try to connect. As stated it would be a open network, encryption type would be wep - then you would put in your wep key. And pick your index number using on the router for your wep key, normally defaults to 1.

Then try to connect.

Share this post


Link to post
Share on other sites

Posted

tried that too. does windows 7 think wep is crappy so it doesn't support it?
cuz that sucks.
i didn't have this problem with vista

Share this post


Link to post
Share on other sites

Posted (edited)

A google seems to show quite a few people having issues with it - is yours win7 64 or 32 bit? What driver are you using for your wireless card? A MS one? Or one by the maker of the card?

If your manually setting up the network, and putting in the actual HEX key and picking the correct index setting - it should work.

On your wireless router you should see something sim to this.

[attachment=250636:wepkeysetting.jpg]

Verify that your putting in the ACTUAL key ie in this example the 62CA15E1EA vs the test123 which the router used to generate the key. Also verify that the index one used matches up, see how its using index 1, verify that your putting that in you wireless settings on the machine and using the correct key for index 1.

Make sure you remove any auto created networks for your SSID and create the manual one where you select open and wep and use the actual HEX KEY vs any sort of passphrase or ascii password you use to create the keys. Edited by BudMan

Share this post


Link to post
Share on other sites

Posted

Silly question, but you are using the Windows wireless and not some 3rd party utility right?

Share this post


Link to post
Share on other sites

Posted

I've faced this exact same problem a few days ago at a friends' place. His router was configured for shared WEP key and Windows 7 won't even bring up the password box.
If you search for wep in windows help and open section titled "Set up a security key for a wireless network", scroll down for this,

[quote]
[b]To manually create a network profile using WEP shared key authentication[/b]
[list=1][*]Click to open Network and Sharing Center.[*]Click Set up a new connection or network.[*]Click Manually connect to a wireless network, and then click Next.[*]On the Enter information for the wireless network you want to add page, under Security type, select WEP.[*]Complete the rest of the page, and then click Next.[*]Click Change connection settings.[*]Click the Security tab, and then, under Security type, click Shared.[*]Click OK, and then click Close.[/list]
[/quote]

This worked for me without changing any router settings.

Share this post


Link to post
Share on other sites

Posted

doesn't work.
it says something about home groups and stuff.
and i have to leave it or i already have one set?

Share this post


Link to post
Share on other sites

Posted

What?? WTF does home groups have to do with setting up a wireless connection?

Can you give us the details of exactly what your doing and what exact errors your getting.

Share this post


Link to post
Share on other sites

Posted

[quote name='BudMan' date='08 February 2010 - 08:42' timestamp='1265643737' post='592214942']
A google seems to show quite a few people having issues with it - is yours win7 64 or 32 bit? What driver are you using for your wireless card? A MS one? Or one by the maker of the card?

If your manually setting up the network, and putting in the actual HEX key and picking the correct index setting - it should work.

On your wireless router you should see something sim to this.

[attachment=250636:wepkeysetting.jpg]

Verify that your putting in the ACTUAL key ie in this example the 62CA15E1EA vs the test123 which the router used to generate the key. Also verify that the index one used matches up, see how its using index 1, verify that your putting that in you wireless settings on the machine and using the correct key for index 1.

Make sure you remove any auto created networks for your SSID and create the manual one where you select open and wep and use the actual HEX KEY vs any sort of passphrase or ascii password you use to create the keys.
[/quote]
[font="Garamond"][/font]

Hi:
I don't have a win 7 but based on the jpeg u posted; can you pls tell me whether there is an option under 'Encryption' for 26 hex digits. The reason I ask this is because the wep key index 1 on the AP has a WEP key with 26 hex chars as I have chose 128 key bit.
Can you please let me know
Thanks.

Share this post


Link to post
Share on other sites

Posted

I believe the setting is actually "Shared" instead of No Auth....


And I can confirm it:

[quote]
In Open System authentication, the WLAN client need not provide its credentials to the Access Point during authentication. Thus, any client, regardless of its WEP keys, can authenticate itself with the Access Point and then attempt to associate. In effect, no authentication (in the true sense of the term) occurs. After the authentication and association, WEP can be used for encrypting the data frames. At this point, the client needs to have the right keys.

In Shared Key authentication, the WEP key is used for authentication. A four-way challenge-response handshake is used:

1.The client station sends an authentication request to the Access Point.
2.The Access Point sends back a clear-text challenge.
3.The client has to encrypt the challenge text using the configured WEP key, and send it back in another authentication request.
4.The Access Point decrypts the material, and compares it with the clear-text it had sent. Depending on the success of this comparison, the Access Point sends back a positive or negative response.
After the authentication and association, the pre-shared WEP key is also used for encrypting the data frames using RC4 .

At first glance, it might seem as though Shared Key authentication is more secure than Open System authentication, since the latter offers no real authentication. However, it is quite the reverse. It is possible to derive the keystream used for the handshake by capturing the challenge frames in Shared Key authentication.[2] Hence, it is advisable to use Open System authentication for WEP authentication, rather than Shared Key authentication. (Note that both authentication mechanisms are weak.)
[/quote]

Set it to Shared.

Share this post


Link to post
Share on other sites

Posted

[quote name='rjwtac' date='30 April 2010 - 19:13' timestamp='1272672797' post='592566742']
[font="Garamond"][/font]
can you pls tell me whether there is an option under 'Encryption' for 26 hex digits. The reason I ask this is because the wep key index 1 on the AP has a WEP key with 26 hex chars as I have chose 128
[/quote]

Yes you can do 128 -- did not see the point in just making the numbers longer ;) But here

[attachment=261026:128bitkeys.jpg]

Well I now have a windows 7 laptop -- so can do some testing on this now.. I find it unlikely that I will run into any problems connecting to wep.. But will give it a test here in a bit.

Share this post


Link to post
Share on other sites

Posted (edited)

Ok I just did some testing with both open and shared types of wep.. With [b]open[/b] win7 connected just fine - asked for key, bing bang zoom in!!!

[attachment=261030:askedforkey.PNG]

Now I set the wireless accesspoint to "shared" security -- and now it had a problem, did not ask for key and would not connect.. But here is what ticks me off about users, if you would of freaking bothered to run the tools there -- ie when it did not connect it popped up a windows asking if you wanted to diagnose, troubleshoot the problem.

[attachment=261034:troubleshoot.PNG]

It then CLEARLY TELLS you wireless is set for SHARED and not to use it, if you want to continue using it then you need to create a MANUAL profiles -- its right there!!! tells you EXACTLY WTF to do!!!!

[attachment=261036:tellsyouywhattodo.PNG]

So -- I manually create a profile, setting it to shared and putting in my key, etc.

[attachment=261038:setprops.PNG]

Couple seconds later - bing bang zoom Im connected to the WEP Shared auth network.

[attachment=261040:connectedshared.PNG]

So from this testing -- clearly window7 supports connecting to WEP, JFC it even tells why it doesn't connect if you have it set to SHARED and what to do.. Even better is tells you should prob use WPA or WPA2 ;) So if set to open it connects straight away with no issues if you put in the correct KEY! If shared wep it tells you can not auto setup the profile and for you to do it manually, etc. even offers to walk you though how to do that, etc. etc.

So I would have to chuck up this whole thread, and the links on the google with users having issues with wep on win7 to pretty much user error!

edit: Again your best best would be to move to WPA/WPA2 anyway!!! But if your going to use WEP, on your wireless router set it OPEN vs shared an then you wont have to manually created the profile. Edited by BudMan

Share this post


Link to post
Share on other sites

Posted

hi there, i'm having the same problem here but i already do all the step you tell me but still cannot connect to it

Share this post


Link to post
Share on other sites

Posted

riding the neco wave

[b] [url="../../user/439152-polime/"]polime[/url] have you considered freeRadius? [/b]

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.