Jump to content



Photo

Laptop connected by HDMI

laptop hdmi hdtv samsung

  • Please log in to reply
12 replies to this topic

#1 dlf

dlf

    Neowinian

  • 259 posts
  • Joined: 02-June 04

Posted 18 December 2011 - 19:45

I have a 11" or so laptop connected to a receiver by HDMI which is connected to our Samsung TV by another HDMI, but sound is coming from the laptop instead of the 'surround' speakers. How can I resolve this? I want to watch some youtube vids (playthroughs in (near) HD) on the TV . . . . . . . Oh and I KNOW I've gotten sound from the speakers (non-Laptop) before today. . . .


#2 Wombatt

Wombatt

    Neowinian

  • 617 posts
  • Joined: 04-May 09
  • Location: London, United Kingdom
  • OS: Windows + OSX + Linux

Posted 18 December 2011 - 19:51

Window 7?
Go to 'Sound' under 'Control Panel' and change the default output to the one listed with a description of 'HDMI'
If this doesn't exist, the correct sound driver is probably not installed.

#3 StealMySoda

StealMySoda

    Neowinian

  • 1,410 posts
  • Joined: 13-August 06
  • Location: Merseyside, UK

Posted 18 December 2011 - 19:52

Right click the speaker icon in your tray and click 'playback devices'. You need to select the HDMI device as your output.

#4 roadwarrior

roadwarrior

    Mississippian by birth and by choice

  • 12,944 posts
  • Joined: 25-April 03
  • Location: Republic of Mississippi

Posted 18 December 2011 - 19:52

You didn't state what OS you are running, but if you are running Windows, go to the sound control panel and make sure you have the correct device selected as default:
http://digiex.net/gu...dows-vista.html

#5 OP dlf

dlf

    Neowinian

  • 259 posts
  • Joined: 02-June 04

Posted 18 December 2011 - 20:07

Windows 7 64 Bit For some reason an Icon of a TV isn't showing. We did used to have a optical and or RCA cables going from the TV I think to the recev.

#6 HyBry

HyBry

    Neowinian

  • 1,013 posts
  • Joined: 25-April 06
  • Location: around somewhere

Posted 19 December 2011 - 11:05

Have you got all the drivers installed?

When I installed latest AMD driver package, I am sure, there was option HDMI audio.

Besides that, I agree with what others have said: right click Volume icon in system tray -> playback devices -> set default as appropriate

I do that all the time to switch between speakers, headset, tv speakers

#7 ARchamps

ARchamps

    Neowinian

  • 502 posts
  • Joined: 08-January 03
  • Location: Toronto ON

Posted 19 December 2011 - 14:15

Try connecting via HDMI directly into the TV.. to rule out the reciever.

#8 OP dlf

dlf

    Neowinian

  • 259 posts
  • Joined: 02-June 04

Posted 19 December 2011 - 17:12

Tried that Archamps, same damn thing.

#9 ARchamps

ARchamps

    Neowinian

  • 502 posts
  • Joined: 08-January 03
  • Location: Toronto ON

Posted 19 December 2011 - 18:20

Only thing I can think of is what the others have suggested. I had a similar issue when I hooked up my monitor to my laptop through HDMI. You have to navigate to control panel -- sound options and chose the default to HDMI or something along those lines.

Good luck!

#10 Astra.Xtreme

Astra.Xtreme

    Electrical Engineer

  • 8,040 posts
  • Joined: 02-January 04
  • Location: Milwaukee, WI

Posted 19 December 2011 - 18:25

In the Sound control panel, you have to disable the 'Speakers" and then enable the "Digital Output" (or set as default). Those are the obvious steps though, which you probably already tried.

Otherwise, here are some other suggestions you can read through:
http://www.<< spam >...rough-hdmi.html
http://answers.micro...5c-b2c1fce17fe6
http://social.techne...97-bb5fa30b34c6

#11 +jamesyfx

jamesyfx

    Neowinian Senior

  • 8,382 posts
  • Joined: 04-February 06
  • Location: Manchester, UK
  • OS: OS X 10.9 / Windows 8.1
  • Phone: Nexus 5

Posted 20 December 2011 - 20:53

Some HDMI ports on laptops don't carry the audio signal. Unlikely that yours is like that but it could be an explanation.

#12 OP dlf

dlf

    Neowinian

  • 259 posts
  • Joined: 02-June 04

Posted 21 December 2011 - 01:52

Finallaly did get it, it may be two (or three) channels but it's better than coming from the laptop speaker . . . .

#13 nw2001

nw2001

    Neowinian

  • 211 posts
  • Joined: 29-June 08

Posted 21 December 2011 - 01:57

For the longest time I had to run into the control panel, pull open the device manager and disable and re-enable the HDMI sound(It is listed seperately from the GFX card.(Im using ati, like a 5870m or some crap.) and it would work.