Sign in to follow this  
Followers 0
Steven P.

Unable to add Exchange account to Windows 8 CP

35 posts in this topic

Can't for the life of me add the exchange account to Windows 8 Mail app.

It works in Windows 7, Outlook 2010 (cached mode) but with SSL turned off (also in my iPhone) but there isn't an option for that in the mail app. It just keeps saying "Can't connect to Exchange, check the settings"

I'm also logged into Windows 8 using my domain account.

Any ideas?

Share this post


Link to post
Share on other sites

Same issue here, am really wishing there was an option for more detailed error messages.

Share this post


Link to post
Share on other sites

I'm beginning to think they've intentionally crippled a lot of features for the beta Customer Preview. You can't select media folders for the music or video apps, either... Nor can I sign in to my Zune account in them from the UK.

Share this post


Link to post
Share on other sites

Well it automatically added my hotmail account as well, but shows no mails at all?

I have my hotmail account (Microsoft ID) linked with my domain account in Windows 8.

Share this post


Link to post
Share on other sites

the metro mail app is so unbelievably crippled, i can't believe anyone would want to use it with exchange...

Share this post


Link to post
Share on other sites

I'm beginning to think they've intentionally crippled a lot of features for the beta Customer Preview. You can't select media folders for the music or video apps, either... Nor can I sign in to my Zune account in them from the UK.

I've seen reports on "how easy it is" to add Exchange to the mail app, by doing a Google search as well :/

Share this post


Link to post
Share on other sites

What version of Exchange? Once I get the network guys to fix the 802.1x on my work laptop/Win 8 CP, I'll try. We use the Autodiscover along with RPC so I would think it would work, but I'll test it out later and report back.

Share this post


Link to post
Share on other sites

Having the same issue as well, and that is with my trying to set it up while on the network. We are using Exchange 2010 with Autodiscover. Maybe I should try setting it up when im outside the network. That's the trick I have to use with Android phones :D

Share this post


Link to post
Share on other sites

My Exchange accounts work fine. One Office 2007 and one Office 2010 (office.com).

Share this post


Link to post
Share on other sites

Having the same issue as well, and that is with my trying to set it up while on the network. We are using Exchange 2010 with Autodiscover. Maybe I should try setting it up when im outside the network. That's the trick I have to use with Android phones :D

I have Exchange 2010, What's autodiscover and how/should I enable it? None of my setups correctly detect Exchange from the email and password (on the local network, or outside it) I have to manually enter all the server and domain info and then it works, but in this case not in Windows 8 Mail app.

Share this post


Link to post
Share on other sites

Autodiscover can get a bit tricky, but once you get it going it is really convenient, especially for mobile devices...

http://technet.microsoft.com/en-us/library/bb124251.aspx

mostly it involves some dns changes (A record for autodiscover.domain.com) although there are other URL's it checks automatically (like domain.com/autodiscover I believe)...

microsoft also has a great utility to troubleshoot autodiscover and activesync issues etc:

https://www.testexchangeconnectivity.com/

Share this post


Link to post
Share on other sites

I can verify that Outlook over RPC does work. Autodiscover worked perfectly! :)

EDIT: Oh, and I was able to get it added through the mail app in the Start Screen. I did get a message that I needed to make my PC more secure, and when I accepted, I now see my Exchange emails along with GMail and Hotmail.

Share this post


Link to post
Share on other sites

It took a few tries for me to get my Exchange account added, but I just can't seem to switch to using it. The tab that comes up when I go into settings has Hotmail, Exchange and Google (I added all three), but I just can't click on any account to switch to it. The main pane displays Hotmail forever.

:-S

Share this post


Link to post
Share on other sites

It took a few tries for me to get my Exchange account added, but I just can't seem to switch to using it. The tab that comes up when I go into settings has Hotmail, Exchange and Google (I added all three), but I just can't click on any account to switch to it. The main pane displays Hotmail forever.

:-S

Do you mind sharing how you managed to get it setup? :p

I have checked exchange settings and I can't find why it won't connect when Outlook Anywhere works fine, and also works fine on my iPhone (no SSL).

Share this post


Link to post
Share on other sites

I'm beginning to think they've intentionally crippled a lot of features for the beta Customer Preview. You can't select media folders for the music or video apps, either... Nor can I sign in to my Zune account in them from the UK.

Well they are beta apps, as for media, add the folders to you music/video library

Share this post


Link to post
Share on other sites

Do you mind sharing how you managed to get it setup? :p

I have checked exchange settings and I can't find why it won't connect when Outlook Anywhere works fine, and also works fine on my iPhone (no SSL).

I suspect not using SSL might be the issue, have you tried with SSL - even if you you a self cert that may help.

Share this post


Link to post
Share on other sites

I suspect not using SSL might be the issue, have you tried with SSL - even if you you a self cert that may help.

The internal/external address of the Exchange server is the same, only with http:// (internal) and https:// (external) for OWA etc.. I have a self signed certificate for Exchange Server as well that's also in the Server Root Certificate Trust, so I'm assuming when the Mail app connects, it would connect to the address that complies with needing SSL or not since there isn't an option to enable/disable it in the Mail app.

I'm really stumped!

I can confirm that Exchange works fine on my iPhone with SSL enabled too.

Share this post


Link to post
Share on other sites

Have a lookie here to test your exchange config.

https://www.testexch...nnectivity.com/

Or, hold the ctrl or alt or shift button (can't remember which) and click the Outlook icon in system tray and select the diagnostics option for autodiscover. AutoDiscover can be a pain to set up.

Share this post


Link to post
Share on other sites

I have my exchange account added to win8 CP, but im using it like I would a cell phone, so it connected to my mobile exchange server and uses the exact same settings as a portable device.

Share this post


Link to post
Share on other sites

Have a lookie here to test your exchange config.

https://www.testexch...nnectivity.com/

Or, hold the ctrl or alt or shift button (can't remember which) and click the Outlook icon in system tray and select the diagnostics option for autodiscover. AutoDiscover can be a pain to set up.

Autodiscover isn't the issue though, because I can already enter everything manually, just like in Outlook (which doesn't auto-resolve anyway) and my iPhone.

Share this post


Link to post
Share on other sites

Autodiscover isn't the issue though, because I can already enter everything manually, just like in Outlook (which doesn't auto-resolve anyway) and my iPhone.

That said, though, I didn't have any issues adding my Exchange account to Windows Mail.

Share this post


Link to post
Share on other sites

That said, though, I didn't have any issues adding my Exchange account to Windows Mail.

Thanks for the info, but your setup could still be different to mine. Do you have a trusted certificate, not a signed one? Mine is self signed and yeah autodiscover doesn't work, I'd need to know if that was an actual requirement, but so far people with the same issues haven't been told that autodiscover is the issue :/

I may have to look into getting that working though, as usual (with any major server work) it will take me hours or all day to do it :p

I tend to leave the server well alone as it all works, changing stuff can cause huge problems, as I've experienced in the past lol.

Share this post


Link to post
Share on other sites

I've been unable to get my iCloud email @me account working on it either. It's a shame. I'd love to use mail as my email app. But while Windows 8 is in Beta I'll have to stick with postbox. If they open up support for all emails like the old Live Mail client could I'll switch in a heartbeat.

Share this post


Link to post
Share on other sites

Thanks for the info, but your setup could still be different to mine. Do you have a trusted certificate, not a signed one? Mine is self signed and yeah autodiscover doesn't work, I'd need to know if that was an actual requirement, but so far people with the same issues haven't been told that autodiscover is the issue :/

I may have to look into getting that working though, as usual (with any major server work) it will take me hours or all day to do it :p

I tend to leave the server well alone as it all works, changing stuff can cause huge problems, as I've experienced in the past lol.

Autodiscover works fine on mine, and I still can't persuade it to connect.

1 person likes this

Share this post


Link to post
Share on other sites

Autodiscover works fine on mine, and I still can't persuade it to connect.

That answers that then :p

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.