Sign in to follow this  
Followers 0

IDE To AHCI In Windows 8 Build 8250

5 posts in this topic

Posted

Loaded Build 8250 on a SSD and had to use IDE in the motherboard bios to get it on the drive. I need to convert back to AHCI which is definately better performance for me. The registry edits for Win7 and the former Win 8 Preview do not seem to be applicable since the keys seem to be different in this new build. Any ideas or thoughts? Thanks in advance ............. Dos ;-)

Share this post


Link to post
Share on other sites

Posted

This method worked like a champ ............. ;-)

Enabling AHCI/RAID on Windows 8 after installation

Been playing around with Windows 8 Consumer Preview and Windows 8 Server recently. After installing, I needed to enable RAID mode (Intel ICH9R) on one of the machines that was incorrectly configured for legacy IDE mode (why is this the default BIOS setting Dell?). In Win7, you would just ensure that the Start value for the Intel AHCI/RAID driver is set to 0 in the registry, then flip the switch in the BIOS, and all's well. Under Win8 though, you still end up with the dreaded INACCESSIBLE_BOOT_DEVICE. The answer is simple enough: turns out they've added a new registry key underneath the driver you'll need to tweak: StartOverride. I just deleted the entire key, but if you're paranoid, you can probably just set the named value 0 to "0".

So, the full process:

- Enable the driver you need before changing the RAID mode setting in the BIOS:

(for Intel stuff, the driver name is usually iaStorV or iaStorSV, others may use storahci)

-- Delete the entire StartOverride key (or tweak the value) under HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\(DriverNameHere)

- Reboot to BIOS setup

- Enable AHCI or RAID mode

- Profit!

Also ........... here is the link for full author credit:

http://blog.rolpdog.com/2012/03/enabling-ahciraid-on-windows-8-after.html

Share this post


Link to post
Share on other sites

Posted

Oddly enough I have a post on here currently about the opposite.. I'm trying to get my system to boot while in AHCI mode coming FROM windows 8 ... not hijacking.. just saying.. Is there something going on with windows 8??

Share this post


Link to post
Share on other sites

Posted

Go here for the solution. I had the same problem in Windows 8. The solution basically involves rebooting in Safe Mode, changing to AHCI in the BIOS settings, letting it boot in Safe Mode, and then restarting in Normal Mode again. It magically fixes itself. I'm not kidding. Hours of frustration avoided... :)

http://support.microsoft.com/kb/2751461

Share this post


Link to post
Share on other sites

Posted

If it's an AMD chipset (7 & 8 series), I haven't had much luck with that. I had to install Windows 8 again from scratch in AHCI mode then install the AMD supplied driver later.

After the boot loader it failed to read the HDD (Selecting F8 to get to safe mode would result in the same behaviour).

Intel X38Express and Intel HM67 switch without issue though.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.