Jump to content



Photo

IDE To AHCI In Windows 8 Build 8250


  • Please log in to reply
4 replies to this topic

#1 Doskiller

Doskiller

    Neowinian

  • Joined: 22-February 07

Posted 01 March 2012 - 23:38

Loaded Build 8250 on a SSD and had to use IDE in the motherboard bios to get it on the drive. I need to convert back to AHCI which is definately better performance for me. The registry edits for Win7 and the former Win 8 Preview do not seem to be applicable since the keys seem to be different in this new build. Any ideas or thoughts? Thanks in advance ............. Dos ;-)


#2 OP Doskiller

Doskiller

    Neowinian

  • Joined: 22-February 07

Posted 05 March 2012 - 17:32

This method worked like a champ ............. ;-)

Enabling AHCI/RAID on Windows 8 after installation


Been playing around with Windows 8 Consumer Preview and Windows 8 Server recently. After installing, I needed to enable RAID mode (Intel ICH9R) on one of the machines that was incorrectly configured for legacy IDE mode (why is this the default BIOS setting Dell?). In Win7, you would just ensure that the Start value for the Intel AHCI/RAID driver is set to 0 in the registry, then flip the switch in the BIOS, and all's well. Under Win8 though, you still end up with the dreaded INACCESSIBLE_BOOT_DEVICE. The answer is simple enough: turns out they've added a new registry key underneath the driver you'll need to tweak: StartOverride. I just deleted the entire key, but if you're paranoid, you can probably just set the named value 0 to "0".

So, the full process:

- Enable the driver you need before changing the RAID mode setting in the BIOS:
(for Intel stuff, the driver name is usually iaStorV or iaStorSV, others may use storahci)
-- Delete the entire StartOverride key (or tweak the value) under HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\(DriverNameHere)
- Reboot to BIOS setup
- Enable AHCI or RAID mode
- Profit!

Also ........... here is the link for full author credit:
http://blog.rolpdog....ws-8-after.html

#3 jbarcus81

jbarcus81

    American

  • Joined: 30-November 01
  • Location: Ohio
  • OS: Windows 8 x64

Posted 13 March 2012 - 23:25

Oddly enough I have a post on here currently about the opposite.. I'm trying to get my system to boot while in AHCI mode coming FROM windows 8 ... not hijacking.. just saying.. Is there something going on with windows 8??

#4 Sean McCarthy

Sean McCarthy

    Resident One Post Wonder

  • Joined: 31-December 12

Posted 31 December 2012 - 08:34

Go here for the solution. I had the same problem in Windows 8. The solution basically involves rebooting in Safe Mode, changing to AHCI in the BIOS settings, letting it boot in Safe Mode, and then restarting in Normal Mode again. It magically fixes itself. I'm not kidding. Hours of frustration avoided... :)

http://support.micro....com/kb/2751461

#5 Aergan

Aergan

    Neowinian Senior

  • Tech Issues Solved: 6
  • Joined: 24-September 05
  • Location: Staffordshire, UK
  • OS: Windows 8.1 Pro / Server 2012 R2 / Xubuntu 14.04
  • Phone: Sony Xperia Z1

Posted 31 December 2012 - 13:03

If it's an AMD chipset (7 & 8 series), I haven't had much luck with that. I had to install Windows 8 again from scratch in AHCI mode then install the AMD supplied driver later.
After the boot loader it failed to read the HDD (Selecting F8 to get to safe mode would result in the same behaviour).

Intel X38Express and Intel HM67 switch without issue though.



Click here to login or here to register to remove this ad, it's free!