Jump to content



Photo
windows 8 radeon radeon x1300 drivers

  • This topic is locked This topic is locked
12 replies to this topic

#1 L1520

L1520

    Neowinian

  • Joined: 06-May 09

Posted 08 March 2012 - 11:17

I cannot get any ATI Radeon X1300 drivers / Catalyst Control Centre versions to work with Windows 8 CP x64...any help you guys can offer to get it sorted? I'm using a Dell Dimension 9200 from 2007.

Thanks in advance :-)


#2 B26354

B26354

    Neowinian

  • Joined: 03-September 04
  • OS: Windows 8.1 Pro 64 bit

Posted 08 March 2012 - 11:35

Hello:
I have a computer with a radeon X1300 and since Windows 7 i used the 10.2 Catalyst legacy drivers for Windows Vista. They aren’t great but worked for Windows 8 also. When you execute the package they expand in the c: root ati\support\10-02_Legacy_vista…. They may not run because of the Windows version but you can go to the Device Manager and update the driver from there (browse).
I hope this helps..

#3 Buendia

Buendia

    Neowinian

  • Joined: 09-February 09

Posted 08 March 2012 - 11:37

I have X1350 card and I use the drivers for Windows 7 x64. They work perfectly for me.

You can download drivers for your card from Microsoft here:

http://catalog.updat.../site/home.aspx
(IE only)

#4 Lee G.

Lee G.

    Neowinian Senior

  • Joined: 28-October 04
  • Location: London, UK
  • OS: Windows 8.1

Posted 08 March 2012 - 11:38

I'm using Windows 8 CP on a Dell Inspiron 6400 with an ATI Mobility Radeon X1300. I installed ATI Catalyst 7.5 after modding the drivers with Mobility Modder.

ATI Catalyst 7.5 for Windows Vista 32-bit
ATI Catalyst 7.5 for Windows Vista 64-bit

I hope this works for you.

Edit: Looks like I'm wrong. For the mobility version I couldn't get any version higher than 7.5 to work.

#5 OP L1520

L1520

    Neowinian

  • Joined: 06-May 09

Posted 08 March 2012 - 14:04

Thanks for taking the time to reply Gents - I feel proud to know I can ask Neowin members for help and assistance is offered really quickly :D

Thanks again :woot:

#6 godmode

godmode

    Resident One Post Wonder

  • Joined: 20-April 12

Posted 20 April 2012 - 13:22

@lcg
I'm in the same situation. Same PC : Dell Inspiron 6400 with ATI Radeon X1300 Mobility and Windows 8 CP can't detect this video card.
Could find a solution or a work around ? Thanks

#7 dantiags

dantiags

    Resident One Post Wonder

  • Joined: 17-September 12

Posted 17 September 2012 - 14:28

I´m having the same situation with ATI Mobility Radeon X1400 in Windows 8 X64 .... Did yoy solve this problem in Windows 8 X64??? or only in 32 Bits?

best Regards!

Carlos.

#8 Lee G.

Lee G.

    Neowinian Senior

  • Joined: 28-October 04
  • Location: London, UK
  • OS: Windows 8.1

Posted 17 September 2012 - 15:01

I´m having the same situation with ATI Mobility Radeon X1400 in Windows 8 X64 .... Did yoy solve this problem in Windows 8 X64??? or only in 32 Bits?

best Regards!

Carlos.


Yes, I solved this problem the other day with an ATI Mobility Radeon X1300 and Windows 8 x64.

Here is how to do it:

1. Download ATI Catalyst 9.3 and extract the installation files.

2. Modify the drivers using Mobility Modder (the tool doesn't seem to work on Windows 8, but it works on Windows 7).

3. Disable driver signature enforcement and install the driver '9_3_vista64_win7_64_dd_ccc_wdm_enu\Driver\Packages\Drivers\Display\LH6A_INF\CH_76829.inf' in Device Manager, i.e. Update Driver Software... > Browse my computer for driver software > Let me pick from a group of device drivers on my computer > Have Disk.

#9 Hart Nadav Feuer

Hart Nadav Feuer

    Resident One Post Wonder

  • Joined: 03-January 13

Posted 03 January 2013 - 15:53

Happy to report my experience based on your suggestions:

System: Win 8 32-bit, Inspiron E1505, with Radeon Mobility X1300

At first, I could not run Mobility Modder on Win8, so moved over to a Win7 machine. Modded the Catalyst 7.5 Drivers from the package "7-5_vista32_dd_ccc_enu_46757". After that just went to Device Manager, Display Adaptor -> Upgrade Drivers -> Browse -> Let Me Pick -> Have Disk and selected the .INF file. It instantly recognized Mobility x1300 and ONLY this driver (not an entire list of irrelevant drivers). Installation required disabling UAC and allowing unsigned drivers.

Bumped me up to 1680 x 1050 Resolution. Whew, looks much better. Thanks for all the tips!

#10 satsurfer

satsurfer

    Resident One Post Wonder

  • Joined: 30-January 13

Posted 30 January 2013 - 21:26

Hi Hart Nadav Feuer,

I also have a ATI Radeon X1300pro (silent)

Could you are anyone else place a link with the modded Catalyst 7.5 drivers from the package? I don't have a win7 machine, just win8. Also, I'm not a pro, like you guys.

I bought a new dvb-t card, because I thougt my old one was broken...But now I realise....It's due to win8

Many thanks for your work. Very much appreciated!

#11 Calamvs Gladio Fortior

Calamvs Gladio Fortior

    Resident One Post Wonder

  • Joined: 19-April 13

Posted 19 April 2013 - 09:56

I modified the driver of an installer with the characteristics of X1300-1500.
You can find it here: http://www.alaricvs...._X1300-1500.zip
First, though, you have to uninstall all existing display drivers.

Tell me if it works

#12 felyn

felyn

    Resident One Post Wonder

  • Joined: 28-April 13

Posted 28 April 2013 - 03:55

Yes, I solved this problem the other day with an ATI Mobility Radeon X1300 and Windows 8 x64.

Here is how to do it:

1. Download ATI Catalyst 9.3 and extract the installation files.

2. Modify the drivers using Mobility Modder (the tool doesn't seem to work on Windows 8, but it works on Windows 7).

3. Disable driver signature enforcement and install the driver '9_3_vista64_win7_64_dd_ccc_wdm_enu\Driver\Packages\Drivers\Display\LH6A_INF\CH_76829.inf' in Device Manager, i.e. Update Driver Software... > Browse my computer for driver software > Let me pick from a group of device drivers on my computer > Have Disk.


I try the step belong you,but the final step cause a wrong dialog that said "there's a wrong hash in drive file,this is the wrong drive file has modified "
how to solve.thks.

#13 Alin Iliuta

Alin Iliuta

    Resident One Post Wonder

  • Joined: 27-October 13

Posted 27 October 2013 - 13:01

I cannot get any ATI Radeon X1300 drivers / Catalyst Control Centre versions to work with Windows 8 CP x64...any help you guys can offer to get it sorted? I'm using a Dell Dimension 9200 from 2007.

Thanks in advance :-)

I solve this driver problem after 3h. Here is the solution for instaling Ati Radeon x1300 driver for Windows 8 32:
1. Download catalyst_8-31-100_vista32_rtm
2. Set for downloaded file(catalyst_8-31-100_vista32_rtm) the compatibility mode for Vista(simple, not Service pack 1 or 2)
3. Instal and enjoy!





Click here to login or here to register to remove this ad, it's free!